Please do not post a support request without first reading and following the advice in

  • Hi there
    I'm using a Raspberry Pi 4 Model B, 2GB RAM with an official power supply.
    RetroPie Version 4.6.7 built on an existing Stretch image
    1 USB Logitech USB keyboard and 1 USB mouse attached, with ControlBlock attached but not yet configured with driver. (Most recent model, purchased 2020 and connected to two sets of wired 8 arcade buttons and 4-way joysticks.

    I couldn't get the image to display via HDMI on my Pi 4, but it would load on my old Raspberry Pi Model B+ (although Retropie didn't launch) so I updated the Stretch OS on the card to Buster using this guide:

    I also updated Retropie to the latest version, and did this all on the old Model B. I was now able to transfer it to the Pi 4 and the display worked, but failed to launch Emulation Station with the following error:
    /opt/retropie/supplementary/emulationstation/emulationstation: /usr/lib/arm-linux-gnueabihf/ version 'CURL_OPENSSL_3' not found (required by /opt/retropie/supplementary/emulationstation/emulationstation)

    I tried updating Retropie and the OS on the Pi 4 again in case of firmware mismatches from the setup on the Model B. I also updated the binary for Emulation Station and got the following error:

    Could not successfully build retroarch - RetroArch - frontend to the libretro emulator cores - required by all lr-* emulators (/home/pi/RetroPie-Setup/tmp/build/retroarch/retroarch not found).

    Here's the log the above process generated: <script src=""></script>

    I found a post for a similar problem here ( and am resigned to the fact that updating the OS in this case won't be possible, but wondered if anyone could help advise any fixes? I saw something about getting the correct libcurl (as mentioned here but not sure this would help or whether I'm up to the task as a Linux dunce!
    Thanks in advance, Benn

  • Global Moderator

    I found a post for a similar problem here ( and am resigned to the fact that updating the OS in this case won't be possible, but wondered if anyone could help advise any fixes?

    You should have installed from a fresh Pi4 image - RetroPie (and neither Raspbian) doesn't support this kind of in-place upgrade for the OS. Even if you do it, you still have to upgrade your packages afterwards (like you started doing).

    You error probably stems from the incorrect config.txt file from the image you upgraded - the Pi4 image has a different configuration and you're using an old config.txt that doesn't know about the Pi4.
    The file is probably missing the Pi4 specific config lines:

    # Enable DRM VC4 V3D driver on top of the dispmanx display stack

    If you add those lines and re-try the package updates, you'll probably be able to upgrade from binary all your packages.

    However, my advice would be to start with a fresh Pi4 image from and install anew. You can back-up your ROMs/BIOS/configs using file shares (see here) and restore them on the newly installed system.

  • Thanks mitu, I'd assumed that a lot of the image I was trying to update would have stuff woven throughout various folders and forgot that the configs folder will often house all that stuff - hence trying to update it wholesale. But it makes much more sense to import the existing content onto a fresh build as you point out - not sure why I didn't think to do that in the first place, thank you for helping see the wood through the trees!

    And FYI I tried the config change and update as suggested and it didn't seem to help so I'll start with the clean rebuild. Thanks again for your prompt reply.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.