Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Amiberry not autobooting lha files



  • Pi Model or other hardware: 3b+
    RetroPie Version Used 4.6
    Built From: Pre made SD Image on RetroPie website
    Controller used: Sony DS3
    Error messages received: None (as such)
    Guide used: https://github.com/midwan/amiberry/wiki/Using-Amiberry-WHDBooter-with-RetroPie-(Step-1)
    Emulator: Amiberry

    Hey,

    I'm pulling what's left of my hair out trying to get a one-click system working with Amiga. I've followed @midwan's guide on the GitHub but I must be missing a piece of the puzzle as every .lha 'rom' I launch just presents me with a white screen with a hand holding the workbench floppy disk. When I press Hotkey+X (triangle) to get to the Amiberry menu, I can see no auto-config has been loaded.

    Here's what I've done:

    • Installed Amiberry (from source) from the Opt menu.
    • Copied the Kickstart files listed on Step 2 of the wiki (all crc checked) into my bios directory
    • Added .lha and .sh in my es_systems file and made the default emulator amiberry in emulators.cfg
    • Copy a few .lha files into my amiga roms directory
    • Launch +Start Amiberry.sh and set the bios path explicitly to /home/pi/RetroPie/BIOS/ (where my Kickstart roms are). I also do a rescan and update xml for good measure.
    • I then attempt to launch a .lha rom I have copied over (tried a few, all the same result). The screen goes from black, to grey, then white with the aforementioned Workbench logo.

    Am I right in thinking that the game should just autoboot with the correct settings? No more individual configs per rom? If so can anyone spot where I am going wrong and help point me in the right direction?

    Here is the log file for Amiberry if that helps: Log File

    Cheers,
    Stranger


  • Global Moderator

    @strangeruk Did you also update your RetroPie-Setup script ? Amiberry has changed the launching command syntax recently and you need to update your setup script first and then install Amiberry again.



  • @mitu Thanks for the reply. Admittedly, the last time I did an update it broke the audio (which I see there is now a workaround). I'll give it another try. Do I need to install from source when I reinstall Amiberry?


  • Global Moderator

    the last time I did an update it broke the audio (which I see there is now a workaround).

    Updating just RetroPie-Setup will not break your audio, it's the Kernel/firmware upgrades that changed the audio configuration.

    Do I need to install from source when I reinstall Amiberry?

    No, I don't think it's necessary. Binary update will work.



  • @mitu So we have some progress, but not sure it's in the right direction. Now rather than getting the Workbench screen I just get a black screen. The Amiberry menu doesn't show any sign of attempting to load any configuration. I've attached the new log file here.


  • Global Moderator

    I see an error from Amiberry trying to load a Kick file:

    ROM loader.. (<none>)
    Failed to open './kick13.rom'
     
    mapped_malloc(): 0x00e00000 - 0x00e80000 (0x743e1000 - 0x74461000) -> Extended Kickstart ROM (rom_e0)
    mapped_malloc(): 0x00a80000 - 0x00b00000 (0x74061000 - 0x740e1000) -> Non-autoconfig RAM #1 (custmem1)
    mapped_malloc(): 0x00b00000 - 0x00b80000 (0x740e1000 - 0x74161000) -> Non-autoconfig RAM #2 (custmem2)
    ROM loader end
    memory init end
    

    and then later the emulation stops.

    Do you have an example game you're trying to run and get this error ?



  • @mitu That one was SimonTheSorcerer_v1.3.lha from a certain pack that is made reference to in the Wiki. I can try some others and see what happens.


  • Global Moderator

    @strangeruk No need, I just trying to check with the same game. Seems to load for me, though the log is a bit different:

    failed to load config '/opt/retropie/emulators/amiberry/conf/default.uae'
    KS ver = 0 (0x00)
    Stored port 0/0 d=1: added 200 0 Mouse MOUSE0
    Port0: COMBO 'Mouse' + 'MOUSE0' matched
    Stored port 1/0 d=1: added 101 0 RetroArch Keyboard as Joystick [#2] JOY1
    Port1: COMBO 'RetroArch Keyboard as Joystick [#2]' + 'JOY1' matched
    Port2: NONE
    Port3: NONE
    WHDLoad... /home/pi/RetroPie/roms/amiga/SimonTheSorcerer_v1.3.lha
    WHDBooter LaunchedSymLink Kickstart ROMs for Booter
    WHDBooter - Loading whdload_db.xml
    WHDBooter - Searching whdload_db.xml for SimonTheSorcerer_v1.3
    WHDBooter - Game H/W Settings:
    
                    PRIMARY_CONTROL=MOUSE
                    PORT0=MOUSE
                    PORT1=JOY
                    FAST_COPPER=FALSE
                    JIT=FALSE
                    SCREEN_AUTOHEIGHT=FALSE
                    SCREEN_HEIGHT=400
                    SCREEN_CENTERH=SMART
                    SCREEN_CENTERV=SMART
    
    WHDBooter - Default Slave: SimonTheSorcerer.Slave
    WHDBooter - SubPath:  SimonTheSorcerer
    WHDBooter - Libraries:  SimonTheSorcerer
    WHDBooter - Created Startup-Sequence
    ...
    

    I'll try it on a Pi3 - though I think it's a configuration problem.



  • I've made a copy of the kickstart file and manually named it kick13 and now get presented with the Workbench screen again. Log file

    Just ran the crc check (for my own sanity) and it is c4f0f55f for Kickstart v1.3 rev 34.5 (1987)(Commodore)(A500-A1000-A2000-CDTV).rom and my copy named kick13.rom


  • Global Moderator

    I don't think it's the kickstart file's name - same configuration works, even if the filename is not the same. I tried the same archive (.lha) on an updated Pi3 and the game boots directly (takes a few seconds to start).

    Try re-setting the .uae files to default - rename the configuration files in \\retropie\configs\amiga\amiberry\conf and then re-install the emulator, it should re-create those files. Then boot again the game and see if it makes a difference.



  • @mitu which .uae files? The rp-a500 and rp-a1200?


  • Global Moderator

    @strangeruk These are the configuration files created by RetroPie, yes.



  • @mitu So I uninstalled Amiberry. Deleted the Amiga system from the configs directory and cleared out the Amiberry directories left over in the emulators directory and then rebooted. Then I installed from source.

    Back to the Workbench icon now when I launch a rom. I'm really at a loss. Will try and do a full update and see how that goes.



  • @mitu well I've done a full system update. Completely removed Amiberry and any trace of it. Reinstalled it and still no joy. I have no idea where it's going wrong. Don't suppose I could send my img for you to take a look at? I'm at a loose end.


  • Global Moderator

    That's not practical. If you're just starting out, then you can re-install the RetroPie image, this will get a stock system and re-try.
    Make sure that you update your RetroPie-Setup script and the installed packages (you can skip updating the OS and included packages). Copy your BIOS files (kickstart...) and your lha files to the amiga roms folder and try starting a game.



  • @mitu it's an image I've been working on for a while (labour of love, you know how it goes). I'll dig out a spare micro sd card and try and fresh install on there and hopefully that will point me in the right direction.



  • So a fresh install with doing package (not OS) updates worked!

    I don't understand what could be causing it from my own build, though. Amiberry was a fresh install on both attempts so there were no underlying conf files there. Same BIOS files, same roms. Could it be retroarch.cfg?


  • Global Moderator

    @strangeruk said in Amiberry not autobooting lha files:

    Could it be retroarch.cfg?

    I doubt it, AFAIK Amiberry uses it just to find out the controller/keyboard configuration.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.