Please do not post a support request without first reading and following the advice in

  • I'm trying to install RetroPie in a fresh installation of OSMC (Debian Buster) and when I run the setup, it throws an error:

    = = = = = = = = = = = = = = = = = = = = =
    Installing dependencies for 'lr-gpsp' : GBA emu - gpSP port for libretro
    = = = = = = = = = = = = = = = = = = = = =
    Did not find needed dependencies: gcc-6. Trying to install them now.
    Reading package lists...
    Building dependency tree...
    Reading state information...
    E: Unable to locate package gcc-6
    Could not install package(s): gcc-6.

    and it stops the installation of the rest of the emulators (also, I'm not interested in playing GBA...).

    I really don't know how to install the old gcc-6 in my Debian Buster system. I tried without success. Another alternative for me could be skipping the installation of the GBA emulator, but I don't know how to do it.

    The other alternative seems to be installing the emulators and other packages one by one from the configuration screen... they are too many packages to do it this way...

    Thank you in advance, best regards.

  • Global Moderator

    You can temporary remove/rename the $HOME/RetroPie-Setup/scriptmodules/ and re-try the installation.
    What apt repositories does OSMC include ?

  • Wou! Thank you very much @mitu :D that worked! In particular, if it helps for anyone else:

    mv $HOME/RetroPie-Setup/scriptmodules/libretrocores/ $HOME/RetroPie-Setup/scriptmodules/libretrocores/lr-gpsp.sh_SKIP

    And, in fact, reinstalling worked fine. I confirm now all packages are marked as installed (except lr-gpsp, of course, but I think it doesn't matter at all, due having lr-vba-next as alternative).

    These are the repositories includen in OSMC:

    deb buster main contrib non-free
    deb buster-updates main contrib non-free
    deb buster/updates main contrib non-free
    deb buster main

    Anyone who upgrades from stretch to buster won't had this problem, because gcc-6 is available on stretch, and the RetroPie installation was already done. However, installing RetroPie in a fresh buster installation would fail due the problem I've just reported... at least for OSMC dist. Does Raspbian buster (or other debian based dist) may have the same problem?

    Best regards and thank you very much

  • Global Moderator

    @posti85 said in Installation fails (due gcc-6 was unable to locate):

    Does Raspbian buster (or other debian based dist) may have the same problem?

    No, Raspbian includes gcc-6 in Buster (though apparently Debian doesn't). You can also use lr-mgba as GBA emulator.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.