Please do not post a support request without first reading and following the advice in

GPIO joystick driver works on command line, but loading through /etc/modules fails

  • After a fresh install of Retropie 4.02 on my Rpi3 my two db9 joysticks don't work anymore, when I try to load the driver through /etc/modules

    I can load the driver on command line with "modprobe db9-gpio-rpi map=1,1" and everything works as expected, but autoloading through "db9-gpio-rpi map=1,1" in /etc/modules is ignored. It did work with Retropie 3.x on my Rpi2 without problems.

    Any hint what could be wrong?

    This is what it looks like after manual loading the driver:

    P: /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0/input/input2/js0
    N: input/js0
    S: input/by-id/usb-©Microsoft_Corporation_Controller_082A851-joystick
    S: input/by-path/platform-3f980000.usb-usb-0:1.2:1.0-joystick
    E: DEVLINKS=/dev/input/by-id/usb-©Microsoft_Corporation_Controller_082A851-joystick /dev/input/by-path/platform-3f980000.usb-usb-0:1.2:1.0-joystick
    E: DEVNAME=/dev/input/js0
    E: DEVPATH=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0/input/input2/js0
    E: ID_BUS=usb
    E: ID_FOR_SEAT=input-platform-3f980000_usb-usb-0_1_2_1_0
    E: ID_INPUT=1
    E: ID_MODEL=Controller
    E: ID_MODEL_ENC=Controller
    E: ID_MODEL_ID=028e
    E: ID_PATH=platform-3f980000.usb-usb-0:1.2:1.0
    E: ID_PATH_TAG=platform-3f980000_usb-usb-0_1_2_1_0
    E: ID_REVISION=0114
    E: ID_SERIAL=©Microsoft_Corporation_Controller_082A851
    E: ID_SERIAL_SHORT=082A851
    E: ID_TYPE=generic
    E: ID_USB_DRIVER=xpad
    E: ID_USB_INTERFACES=:ff5d01:ff5d03:ff5d02:fffd13:
    E: ID_VENDOR=©Microsoft_Corporation
    E: ID_VENDOR_ENC=©Microsoft\x20Corporation
    E: ID_VENDOR_ID=045e
    E: MAJOR=13
    E: MINOR=0
    E: SUBSYSTEM=input
    E: TAGS=:seat:uaccess:

    P: /devices/virtual/input/input3/js1
    N: input/js1
    E: DEVNAME=/dev/input/js1
    E: DEVPATH=/devices/virtual/input/input3/js1
    E: ID_INPUT=1
    E: ID_SERIAL=noserial
    E: MAJOR=13
    E: MINOR=1
    E: SUBSYSTEM=input
    E: TAGS=:seat:uaccess:

    P: /devices/virtual/input/input4/js2
    N: input/js2
    E: DEVNAME=/dev/input/js2
    E: DEVPATH=/devices/virtual/input/input4/js2
    E: ID_INPUT=1
    E: ID_SERIAL=noserial
    E: MAJOR=13
    E: MINOR=2
    E: SUBSYSTEM=input
    E: TAGS=:seat:uaccess:
    E: USEC_INITIALIZED=67372867

    db9_gpio_rpi, 1.0, 4.4.13-v7+, armv7l: installed
    gamecon_gpio_rpi, 1.2, 4.4.13-v7+, armv7l: installed
    xpad, 0.4, 4.4.13-v7+, armv7l: installed (original_module exists)'

  • administrators

    Please format output/configs when posting on the forum

    Module options do not go in /etc/modules - just the module name goes there. Module options go in a file in /etc/modprobe.d/ eg /etc/modprobe.d/db9.conf with the contents options db9-gpio-rpi map=1,1

  • Thanks! I'll try that.
    But it did work in Retropie 3 without problems and it is also described this way in the wiki:

    EDIT: Nice. It's working again after moving options to file /etc/modprobe.d/db9-gpio-rpi.conf :)

  • administrators

    using /etc/module for module options has been deprecated for some time, but worked in Raspbian Wheezy. Now it doesn't - the wiki needs updating in this area - feel free :-)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.