Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SFC30; SFC30 & Kodi; Kodi CEC crash



  • Last week I bought a Raspberry Pi 3, with the intention of upgrading my previous OSMC media player on a Pi 2 to a RetroPie (4.02)/Kodi setup on my Sony TV. In this I have been mostly successful, but I ran across a few issues:

    1. I also bought an 8bitdo SFC30 bluetooth controller to use as the input for both RetroPie and Kodi. I followed the instructions on the relevant wiki page, but it seems quite a lot has changed in the Bluetooth setup menu since the guide was written. Once I'd worked this out, setting up the SFC30 was much easier than suggested in the wiki. But...

    2. ...a lot of forum posts suggest that the SFC30 needs to be started using Start+R. However, I wasn't able to get RetroPie to recognize the controller if I used this startup method. I'm also confused, as the manual that came with the SFC30 doesn't mention Start+R as an option. It does mention Start+B+R, but this is just "Player 2 in Mode 2", where Start+B is "Mode 2". I've been starting the controller using just Start, and it's been working fine. This may be because I'm using the latest firmware, 2.68, which was only released last month?

    3. Carrying on with the SFC30 theme - I've got the problem where, even after adding a keymap, where only Left/Up and the Back button works. It appears this is an issue with Kodi, which will be fixed in version 17, but in the meantime, has anyone come up with a workaround that I haven't found via Google?

    4. That's fine, I thought, I'll just use libcec and my TV remote to control Kodi when I switch over. But if I push any button on the remote after booting into Kodi from RetroPie, the whole system hard locks. Like, LEDs stuck on, and the only way to reboot is to pull the plug. This seems a bit extreme, and for the time being I've disabled CEC entirely via /boot/config.txt. Has anyone else had this sort of behavior?

    If this sounds like I'm complaining a lot, it's just because I've found a few niggles in an otherwise impressive package. I've been pleased with how everything else has just worked, it feels very slick. I'll also point out that, yes, I know that if the documentation is out of date I could update it myself, but I'm not sure how to take screenshots of the configuration screens to do so, at least from in front of my TV? If someone could tell me how I can try and stick together a new tutorial on adding the SFC30 because it's much easier than the wiki currently makes out!


  • administrators

    @piphil I dont have any of those controllers so I cant advise but in terms of taking screenshots, the dialog menus show over ssh (https://github.com/retropie/retropie-setup/wiki/ssh) like with putty (just set it to use font encoding so it isnt ugly) or you can install and run raspi2png to take screenshots but again you'll need to be over ssh to call the script to take a screenshot.



  • @herb_fargus Duh, I've been using ssh to set up the system... >__<

    Good point, if I get time I'll put together a few screenshots that may save others a little headscratching. It was a bit off having my problems caused by Actually Reading The Manual.

    Is the wiki fairly free-for-all, or is there specific pages for prototyping new pages etc?


  • administrators

    @piphil well I've written the majority of the wiki but as it says on the home page anyone can add to it. I dont have any 8bitdo controllers hence the lack of updated documentation for them but @Floob has written most the docs for that. I wonder if it would merit another page like @suprjami did with the Logitech controllers or just an updated tab on the bluetooth menu as I know there are a few new specific tweaks under the bluetooth menu for the 8bitdo controllers. Personally I think they merit their own page as they seem to be relatively popular maybe just title it 8Bitdo Controllers unless of course anyone has other thoughts or objections.



  • I'll try and put something together soon on the Wiki. The latest update I put on Youtube was this one

    I was reluctant to remove the old info incase it was helping people who hadnt updated yet, but maybe it should be marked as old info.
    Part of the issue with the 8bitdo guide is the combination of RetroPie version, Pi version, 8bitdo firmware and 8bitdo controller all make a difference to the config.

    I think I'll write it as though everything is fully updated and go from there.

    @piphil If you confirm your firmware version of the controller I'll paste the correct config so you can use that if you want.


  • administrators

    @Floob thats generally the approach I take, I treat the wiki as the latest and if people aren't updated... well they should be cause bouncing between multiple versions gets confusing especially when helping people troubleshoot.

    thanks for your help on this.



  • Ok, first draft here:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-an-8bitdo-Bluetooth-controller

    I may need to sort better images, these are smaller due to the sidebar, but you get the idea.

    All feedback welcome.



  • @Floob That new wiki page looks a lot better, thanks.

    The firmware I'm using is the latest, 2.68 - I tried to update it to make sure, but it appears they're being shipped with the latest firmware, from Amazon.co.uk in any case. It seems to be working now, but if you have a config that works in Kodi as well, that would be great.

    What should I do about my CEC crash? Is this a known issue? I couldn't find anything in the forums, although I may be using the wrong search terms. I'm assuming as it's a complete lock-up crash that there won't be anything logged anywhere?



  • I am not aware of crashes because of CEC, but I know that some joysticks, in rare cases can make Kodi crash. Try running Kodi without any controllers attached and if the problem remains, post you Kodi log.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.