Retropie Metadata Editor



  • I implement a Metadata Editor for Emulationstation on Retropie. It is a .NET Application runs under Windows.
    Maybe someone want give it a try... [DOWNLOAD]
    0_1474386691552_rme1.PNG

    0_1474387036404_rme2.PNG

    0_1474387127231_rme3.PNG



  • Great job!

    I'll try it as soon as I can.

    Thanks a lot.



  • What's a windows

    or a dot.....Net?



  • Awesome...can't wait to try this!



  • @CrazySpence said in Retropie Metadata Editor:

    What's a windows

    or a dot.....Net?

    It runs on the windows operating system.....
    .net is required for it to run.



  • @amadeus Looks awesome! Are you planning to share the source, would love to take a look. Also is this C# or VB.net?



  • Very cool! Thanks for your nice work. Hope you could develop for macOS or Linux debian version. THanks



  • This is awesome. Something like this would be great integrating with the web interface others are developing



  • @Ekstreme said in Retropie Metadata Editor:

    This is awesome. Something like this would be great integrating with the web interface others are developing

    What a pitty it's Windows based... :-/

    @amadeus nice work anyway! :-)



  • @wmcclelion
    Thank you and yes, i can share the source for sure. But at the moment it is implemented "quick and dirty", so it is not very solid. (e.g. losing the network connection to the raspberry will crash the programm)

    It's written in C#.



  • @meleu
    Whats about Mono?
    Can you use Mono to run the application under Linux?



  • Good start to a useful app!
    Little feedback. I am running winblows 10. I am running as administrator.
    It connects to the pi fine...but any time a roms dir is missing it crashes...gives an error.
    I got around this by creating the missing dirs. nds virtualboy in the roms dir and n64 in the images directory.

    This would be most useful to me for PSX games as well as mame arcade stuff like that....the these directories are not scanned :-(

    Any time I add an image I get an error saying it does not have access to \retropie\configs\all\emulationstation\downloaded_images<system>
    but when I click save the game image is uploaded.
    Thanks for your work!
    Forrest


  • administrators

    It sort of works on Ubuntu Linux (64bit).

    I installed mono and the forms library sudo apt-get install mono-runtime libmono-system-windows-forms4.0-cil then did "mono RetropieMetadataEditor.exe" - gui shows, but it died when I clicked connect (directory not found exception). I guess the network bit isn't working, but if it could work on a local folder, it would be easiest enough to use via mounting the retropie share manually etc.



  • Some feedback...

    It would be great if the Path Images field could be made freely editable, as I've noticed that the program automatically appends the rom directory name.

    I have my scraped images inside a separate directory into the respective rom directory, and I cannot make the Editor point to that image path.



  • @weirdocollector Yes would be cool to just be able to edit a config file for some of the common things...like directories...maybe even the username and password for those running this on an ubuntu machine etc.



  • Thank you for your feedback to all!

    First: I put the VS Solution of the application to codeplex. Fell free to take a look but take care: at the moment it is still "quick an dirty"...
    https://rme.codeplex.com

    Second: You can download a new Version from Codeplex. This Version fix the error reported by Shakz (exception on missed rom directories)
    DOWNLOAD

    All other feature request or bug fixing stuff i will do in the next days, if i got some time...
    It also need some documentation i guess (system/software requirements, which systems are supported, whar are the features...)



  • @amadeus

    Hi there. I tried downloading both the original and the one you posted on Sept. 25th.

    The original one crashed everytime I tried to connect to the pie. The newer one freezes when I try to connect.



  • Hi VinnyHaw, can you open the roms and configs shares in the explorer of the computer, which try to running RME? Take care, that the path configuration in RME ist correct and corresponding with your RetroPie configuration. (RME contains the default configuration of RetroPie)



  • Hi amadeus, first of all, thank you for this it's awesome. I'm having a problem with it though. I have sega-CD games and sega 32x games, and the program doesn't seem to find these at all. Is there anything I could try to fix this?
    Thanks again for an awesome program
    Peter



  • Hi PedroPod,

    there ist now new Release for Download:
    Retropie Metadata Editor v0.1.2.0

    Support for Sega 32X and Sega CD was added. Have Fun!

    Regards,
    ama


Log in to reply
 

Looks like your connection to RetroPie Forum was lost, please wait while we try to reconnect.