Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie Reboot freeze after memory expansion



  • Hi! I recently bought a Sandisk Ultra 128 GB Micro SD card to use on the Retropie, so I downloaded the latest img and wrote it to the card. It loads up Retropie successfully, lets me into Emulation Station, configure the controller, the works. Whenever I've tried to expand the partition on the sd card, raspian tells me that it's done and I should reboot. I do, and that's when the problem starts:

    All I see is the cursor pulsating. It doesn't go anywhere. I've left it overnight, and as of now, I think I'm on the 20th hour, it hasn't changed. Initially, I assumed that the process takes a long time, but now I think it's kinda excessive. I've rewritten the .img file to the card 3 times already, to trt different scenarios, and all of them end up the same.

    Any help would be greatly appreciated.

    -Relevant Info-
    Pi Model: 3 Model B
    RetroPie Version Used: 4.0.2 img
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: Keyboard and USB Controller
    Controller used: SNES retro PC controller
    Error messages received: none
    Log found in /dev/shm/runcommand.log (if relevant): Can't access it
    Guide used: Retropie Install Wiki First Installation


  • administrators


  • administrators

    Also what happens if you don't try to expand the FS ? Eg just boot the image ? You don't need to manually do any expansion as it is done on first boot.



  • Tried h2testw_1.4 and nothing was wrong with the drive. I enabled all 56mbs to make sure it'd find some error, but nothing.

    If I don't try to expand the drive, any reboot I do leads to the same place.


  • administrators

    Not sure what you mean by "I enabled all 56mbs"? - that doesn't sound like you tested the whole sdcard.


  • administrators

    Sounds like you need to repartition it and test the entire card.



  • Alright, tried the program again and left it running, and sure enough, the microsd card broke. I received an orange text box with an error, and the card locked.

    I'll look into buying another one soon.

    Just out of curiosity, what would a micro sd card need to be formatted to in order to work properly with the Raspberry Pi? Would there be a way to clone a working card prior to the storage expansion to bypass that step?


  • administrators

    It doesn't need to be formatted if writing the image to it as that contains all the partition information.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.