Please do not post a support request without first reading and following the advice in

PS3 Controllers Won't Connect

  • I just updated my raspberry pi 3 to the latest version of retropie. Before this I was able to connect both of our wireless PS3 controllers and play games, but there was a freezing issue. I updated because it said there was a fix for this. I connected the controller afterward and everything was fine. Then I went to bed. Today I moved it to another room/tv and tried to get it to work, but now I can not get either of my PS3 controllers to connect. I followed all the steps online, made sure all of my drivers were installed and updated, but I can not get it to work.

    Every time I boot the pi I get a little error saying "failed to start configure bluetooth modems connected by UART" When I run the command "sudo service bluetooth status" it says that it is not acative and is dead. Then I run the command "sudo service bluetooth start". When I rerun the status command it says it is functioning. I boot back into emulation station, but I still can not get a controller to connect. I go through all the menus to the "pair PS3 controller" screen, but after connecting one via cable and watching it flash slowly a bit, I unplug it and hit the PS button and... nothing, it just blinks fast until it turns off after a minute or so. Does anyone have a possible solution to this problem, or do you have a similar problem? I am a complete noob and have just been following instructions from online. I got the "sudo service bluetooth status" command from this site here: , This person seemed to have had the same problem as me, except my pi successfully starts bluetooth up when I type the "start" command. Any help would be greatly appreciated! Thanks


  • administrators

    Update the retropie-setup script, remove and reinstall the ps3controller driver and see if it helps. The standard Bluetooth stack is disabled when running the ps3 driver, so you can ignore those startup errors.

  • I tried that, but I can not get it to work. I also tried using all of the clone drivers, but they all just gave an error once I exited saying that it couldn't find the bin (binary I'm guessing) and couldn't pair the controller. We do have an official controller. Just wanted to double check, if we can play it while connected that means we are using the proper cable correct? Also, is it possible for this to be a power problem? We are not using an official power source (our arrives tomorrow) but the one we have does not give a low power signal and seams sufficient. Everything else runs fine.

  • Just to expand, I also retried to use all of the clone drivers, this time I did not receive any funny errors, but I didn't have any success in getting them to connect either. I also reverted back to my backup, and bluetooth worked again, so I know it's not an issue with the PI itself or the controllers, but something somewhere else. If anyone reading this can confirm that they have gotten PS3 controllers to work with the latest version of Retropie that would be nice, just to make sure that SOMEONE has had success with this. I am going to try and install a brand new image from online and wipe the SD card and do it that way. I just am super frustrated with this. :(

  • I have successfully gotten everything to work out now! I did a fresh install of Retropie 4.1, and the bluetooth connection worked straight away after installing the drivers. Maybe it is possible that trying to update Retropie from an older version was making something corrupt? I had not updated for probably close to a year or so, if not more. Even though I now have to reload all of my roms and everything, it seems like a small price to pay to get everything running smoothly. :) Hope this helps somebody else too!


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.