Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

joy stick works in emulation station but not roms



  • hello, i am completely new to retropie and am having trouble with the joy stick and buttons that i am using. They work fine moving around the retropie menu in emulation station but when i select a rom the controls no longer work. I found one post that had the same problem, however i did not understand how to fix the issue. there was a link to the wikki page but the link brought me to how to set up an x box 360 controller. I am completely new to linux and am having trouble knowing even where to go to fix it. I have tried watching several videos but have not been able to figure it out.
    any help would be greatly appreciated.
    I have raspberry pi 3 that i got from a Canakit raspberry pi 3 complete starter kit on amazon.
    I am running the most recent version of retropie from a pre made sd card image from retropie website.
    I am using a Happ Arcade Control Panel rgb kit, it plugs in using a usb port. i am just using one joystick although it can be set up with two.
    thank you!



  • @jodehnal
    https://retropie.org.uk/forum/topic/3/read-this-first
    This instruction is now in bold at the top of the help forum.

    It's there to enable people to help you. You do not say what emulator you are using so it is impossible to assist you. If you are able to navigate through the menus but not after booting a rom, this suggests that you are not using a libretro based emulator. If this is the case, then you will need to configure the controls according to the emulator instructions on the wiki. Did you complete the auto-configure sequence on first boot? Please fill this form out in full so that further assistance can be offered:

    Pi Model: (B, B+, 2 B etc..)
    RetroPie Version Used: (3.6, 3.8.1, 4.01 etc..)
    Built From: (Pre made SD Image on RetroPie website, Berryboot, or on top of existing OS etc..)
    USB Devices connected:
    Controller used:
    Error messages received:
    Log found in /dev/shm/runcommand.log (if relevant):
    Guide used: (Mention if you followed a guide)
    File: (File with issue - with FULL path)
    Emulator: (Name of emulator - if applicable)
    Attachment of config files: (PLEASE USE PASTEBIN.COM FOR LARGE LOGS)
    How to replicate the problem:



  • I am using a raspberry pi 3 model b
    I have the latest build of retro pie version 4.1.5
    i downloaded retro pie from the website and loaded it onto a pre made micro sd card
    I have a usb keyboard and arcade stick and buttons that are wired to a usb connector
    I am trying to use the arcade stick as the controller
    no error message comes up, the arcade stick simply will not work when i load up roms
    not sure how to find the log command
    I used the wikki page from this site for first time installation to set everything up
    I believe i am using a libretro based emulator for all of my roms, i followed the steps from the wikki page to load the emulators on my flash drive, then loaded my roms under the proper files and then put them onto the raspberry pi
    not sure how to attach the config file
    also not sure how to replicate the problem

    you asked if i ran auto config on the first boot, i honestly do not know how to do that. I followed what the wikki page said and i did not find any mention of running auto config on the first boot. I can play the games using the keyboard but not the joy stick and buttons.

    I hope that is everything that you need, thank you for taking the time.



  • @jodehnal

    i did finally see an error code, it says "GPIO controller 1 (0/0) not configured."



  • @jodehnal said in joy stick works in emulation station but not roms:

    you asked if i ran auto config on the first boot, i honestly do not know how to do that

    This confuses me. You don't have to "do" anything. When you write the image of retropie to an sd card and boot it up, you are presented with the controls configuration screen automatically as seen by the welcome screen here:
    https://github.com/retropie/retropie-setup/wiki/First-Installation#configurations

    This is where controllers are detected. If you didn't get that far, I would bet that you have a bad image or card.

    I have a usb keyboard and arcade stick and buttons that are wired to a usb connector

    What connector? An ipac? or other? Are you using each usb for a different device so Keyboard in one, encoder in another and so on? On first boot, controllers are detected as described, you sound as though you have configured a keyboard but you should go back and configure your buttons using this sequence.



  • I am so sorry for the confusion, i did not understand that the auto config was what comes up to set up the controller. yes that did pop up and i did set up the controls with both the joy stick and key board. I have the joy stick set up in the first usb slot on the left and the keyboard set up in the one right bellow it. the joy stick and buttons is recognized as an "arcade controller juyao dual arcade" when i configure it. it lets me configure the controls just fine, but will not work in the roms only the menu.

    the joystick and buttons is a Happ Arcade control panel RGB kit, I have it wired to an arcade game controller usb interface pcb kit for pc (MAME). I bought both off of Amazon.

    I am only using one joystick for this project even though the usb interface can do two. Thank you again for your help and patience!



  • @jodehnal try going to emulation station configuration in the retropie menu. There should be an option to configure liberato emulators and advanced configuration. Choose the first. Scroll down to the emulator you are using or going to use (Nes, snes). Select it then there should be an option that says joystick assign. Select this and a new menu pops up select the input devices you want to use for this emulator. Since your joystick is recognized from your initial configuration it should be listed by name. You might have to reboot for this to take effect.



  • @kinghoostine

    thank you for the advice! i went to configuration editor in the retropie menu, clicked on configure basic libretro emulator options, i then selected the emulator i wanted to try first (atari 7800), it then brought me to a menu that have options such as video smoothing and aspect ratio-i couldn't find one that said joystick assign but i did find one that says choose joypad order and player 1, 2, 3, 4 use analogue stick as d-pad and behind all of them it says (unset). I tried selecting the choose joypad order, it brought me to another screen that says 1 unset, 2 unset, 3 unset, 4 unset, when i select one it says u unset but does no have any other option to select (right above it says choose a gamepad but there is nothing to select). I tried this with all of the emulators i have loaded but all had the same thing. am i in the right menu, this was the only one i could find. thank you for your help!



  • @kinghoostine

    Same issue here,

    i'm using raspberry pi 3 in combination with the hifiberry amp for sound.
    running retropie 4.1.5

    for controls i have a 2 player USB to Jamme converting board

    first time i ran the setup i configured the controls with the usb controller,
    i also configured the keyboard, and afterwards i also managed to setup the PS3 controller,

    with all three controllers i can change everything in the emulation station itself, but from the moment i start a rom i can only use the keyboard and the ps3 controller but not
    the buttons and joystick on the bartop itself...

    i read several topics and also tried to adjust the config like explained in this thread but also like @jodehnal i only see unset, it says choose a gamepad but there is nothing to select..

    work in progress but here is my bartop at this moment
    thx in advance
    0_1480619810114_IMG_6839.jpg



  • @NastyWays85
    So I was never able to get the USB interface that i was using to work. I ended up buying a new one on Amazon and it worked great! I bought an Easyget 2 player zero delay generic game controller USB to Joystick for MAME & Raspberry Pi 1/2/3 retropie DIY projects. it was very easy to set up and worked instantly. Your arcade looks awesome, hope this helps, good luck!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.