Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Updated - How to get a Dragon's Lair USB scoreboard to work on your RPI3 - Tutorial <solved>


  • How to get your USB Dragons Lair Scoreboard working Retro Pie (command line only)

    This tutorial requires you to have a little Linux knowledge and ability to navigate in the ES file manager, if your more advanced you can use the SSH command terminal through F4. Keep in mind this is the for dummies version so linux guru's if there are any command shortcuts that can be used please let me know and i will update the tutorial.

    Ensure you have Dragon’s Lair setup and running via retro pie before you even attempt this tutorial.
    Setup Daphne on RPI3

    Once you have booted Dragons Lair through ES and the files have parsed and you are able to play, then continue. Otherwise stop and troubleshoot as the rest of this won't matter. I packaged up the relevant files to save everyone the trouble, and recompiled the libvldp2.so as for some reason PI3 didn’t like it.
    Daphne Files

    The first issue was missing libglew, and libftdi files. Unzip the attach .rar and place the libraries.tar.gz in your RPI3 /usr/lib folder.
    The easiest way for me since I am Linux dumb was to place my files in the //Retropie/daphne/config folder and then copy the files to the relevant directories via file manager.

    Once libraries.tar.gz is in the /usr/lib folder type this command
    tar zxvf libraries.tar.gz

    If successful the files should unzip into your libraries folder. You can delete the tar.gz file

    Now take your libvldp2.so file and place this in the ./lib folder, this is the root library folder, you will know you are in the correct folder if you see /lib under the word "Left" in the file manager

    Arrow down to the libvldp2.so and type
    chmod a+rwx libvldp2.so

    Hit any key then type
    chown root:root libvldp2.so

    If done correctly you will see a * next to the file

    Navigate to /opt/retropie/emulators/daphne

    Place the daphne.bin and the dlusb file in this folder, you will copy over the current daphne.bin. Back this file up if you want to restore as I have not tested this .bin on other games yet.
    Also, if you do an update via ES it will restore the original daphne.bin and your scoreboard will no longer work until you replace it again with the custom .bin file

    While in the same folder type
    chown root:root daphne.bin dlusb

    Then type
    chmod a+rwx daphne.bin dlusb

    Both files should be green now with * next to them

    While still in this folder type
    ./dlusb lair (or it could be dle21 if thats the rom your using)

    You should see some numbers show up and the scoreboard will have a - for lair or L-p21 for dle21
    Important - If you unplug your Pi, you have to run ./dlusb lair or dle21 again prior to the command below in order for the scoreboard to initialize again. I don’t know why but it doesn’t remember the scoreboard state. However after you do it once, as long as you have the Pi on and load up DL it will work. This issue can be remedied with scripts, etc. to load ./dlusb first at power-up.

    Now for the moment of truth, while in same folder type
    ./daphne.bin lair vldp -framefile /home/pi/RetroPie/roms/daphne/lair.daphne/lair.txt –usbsb
    Note - can be lair or dle21, and the below is assuming you followed the file structure in the setup tutorial above.

    Now if you followed directions the scoreboard will clear and 5 secs later you will see a 2 15p2 00,
    The game will do its normal start up and you’re good to go.

    Mods if you want to move this to its own thread for more visibility be my guest, I’ll check it from time to time and answer questions.

  • Global Moderator

    @rablack97 said in Anybody familiar with the Daphne experimental build for Retropie:

    The guy that sells these things gives very vague directions

    Tell us more about this mysterious salesman. If he was also selling Rolex watches that make your wrist green, you might need to consider starting over with a fresh RetroPie install.


  • @rablack97 said in Anybody familiar with the Daphne experimental build for Retropie:

    The guy that sells these things gives very vague directions, i have some of the files that caused grief prior to just getting daphne to boot, now i'm getting a compile error for the dlvp2.s0

    I suggest you go back to the guy profiteering from the hard work of the Retropie development team, Retroarch development team and the developers of all the included emulators, and demand better support for what he sold. Especially as the reselling of copywritten software is pretty illegal.

    Or, as @mediamogul suggests, wipe the SD card and start fresh where we can help you more effectively as we don't know what custom image the vague-guy has used.


  • Sorry let me be more detailed.

    He is not selling retropie, he sells the scoreboard hardware to get a real scoreboard to work with retropie daphne.

    He uses a custom compiled daphne.bin so the pi can interface with the scoreboard via usb. I'm running into static link issues.

    I am not linux command saavy, but have worked my way through a few issues and have made progress. Was looking to see if anyone was willing to help me troubleshoot.

    The seller is responsive but the responses are vague and may have to do with how the experimental dahpne build was coded. As the file structure may be different.

    He did mentioned it was compiled for retropie and confirmed working on a few platforms and retropie distros.


  • @rablack97 Sorry, with the vast increase in people being directed here from profiteers selling Retropie kits, I automatically assumed the same.


  • @markyh444 No worries man, i see how it could be taken that way.

  • Global Moderator

    @rablack97

    This type of confusion is also why it's a good idea to post as much information on your issue as possible upfront when you first make a support request. I remember the original thread you're referencing and outside of the contact information given there to the creator of this scoreboard and the accompanying Daphne build, the original poster ( @challenger2010 ) seemed to find himself at a standstill. Perhaps he solved it and just never posted back, but he's an active member, so I'm sure he'll respond in one of these two threads.


  • Sorry for the confusion, i'll wait and see if he responds.


  • He sells the scoreboard on his site, but also sells a secondary piece that hooks up between the scoreboard and USB. It was only $20 so I don't feel like I wasted any money. I am just waiting patiently to see if someone figures this out or if he at least puts up an image of his Daphne (minus the roms and LD files). I got no where on it :(


  • Holy crap you still dont have it running either. Wow he charged me 50.00 for my dongle.

    How far did you get on it? One issue i see is that he compiled using a 1.07 version of daphne and retropie uses 1.13. There is this compiled vldp2 library that his version refuses to open. Thats my last error, i've tried everything and still get the same error.

    I can't find where the retropie version of daphne keeps this file as it runs lair for me perfectly. Once i copy his file over the current binary here come all the errors. I have 150.00 bucks invested in this, maybe you and i can bug him enough to get the answers needed to get this working.

    I keep asking him simple questions like what is your folder structure and where are you placing the files and he doesnt give you a straight answer back like the expectation is ok you have the board now you figure it out. Its very frustrating and there's no documentation on this anywhere.

    Im not exactly sure how pi-daphne was coded with a static or dynamic file structure his command lines are using his file structure and i noticed in his framefile he's got C:/ which is window syntax. He said he compiled this for retropie but executes it from the command line. I've executed via command and via ES and still no bueno.


  • If you give me your email address, I will send you what I got from him


  • how do you send a PM on here?


  • @rablack97 Here is mine, send me something. GPPSP13@hotmail.com


  • Man you won't believe this, i got this darn thing to work.

  • Global Moderator

    @rablack97

    What was the issue?


  • @rablack97 so please send me an email now.

    Please and thanks!


  • I have one last thing to iron out and then i'll post my findings, I will tell you this it was not just copy daphne.bin over current bin file.

  • Global Moderator

    @rablack97

    I love the suspense! ...Aarrg, I'm lying, I can't stand it... Was it a hardware, or software problem? No, no. Don't tell me yet, I want to be surprised. I swear though, if it turns out that the solution can be found in any household junk drawer, you're gonna blow my mind.


  • It's all software man, the only issue i'm having now it getting it to work through ES, it works fine via command line but will not initialize via the ES GUI. As promised I will do a thorough step by step how to so folks wont have wasted money and can enjoy this cool feature.

  • administrators

    @rablack97 if it won't launch in es but will in terminal you can look at the pushd popd functions in some of the modules (eg xrick) and that may solve it

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.