Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Daphne and Joystick



  • Re: Daphne joystick control confusion..

    Hi, I have the problem describe in the topic above.
    I'm using ControlBlock.
    My joystick works well with jstest /dev/input/js0, but it doesnt' in Daphne.
    If I run evtest, I get:

    /dev/input/event0:	SINO WEALTH USB Composite Device
    /dev/input/event1:	SINO WEALTH USB Composite Device
    /dev/input/event2:	ControlBlock Arcade Gamepad
    /dev/input/event3:	ControlBlock Arcade Gamepad
    

    So I guess that Daphne assumes that event0 is a Joystick (in this case is not) and try to use it.
    Button mapping (with the "+1" rule) is OK.
    Does anyone succeeded in finding a workaround for that?



  • I have to correct myself.
    the Joystick IS recognized, but the configuration is "wrong", that is LEFT is UP and so on.
    But I guess that the problem is more general, since I have the same behaviour with Prince of Persia port.


  • Global Moderator

    @darkav said in Daphne and Joystick:

    the Joystick IS recognized, but the configuration is "wrong", that is LEFT is UP and so on.

    Unfortunately Daphne is one of a few emulators in RetroPie that tries to automatically grab the joystick without any manual alternative for configuration. The only solution you're likely to run across is key-mapping your joystick using external software such as xboxdrv, Joymap or Linux Joystick Mapper.


  • Global Moderator

    @mediamogul

    One other possibility in Daphne that I just thought of, is the ability to map directions to a controller's buttons. I've never tried it personally, but if your joystick identifies as a series of buttons, rather than an axis, I believe you could just remap it right in /opt/retropie/configs/daphne/dapinput.ini.



  • Actually, after some tests, I realized that when using /dev/input/js0, LR and UD axis are switched.
    So it must be something related with ControlBlock, I'm posting in the Control Block section for this.
    I hope that this can be changed with some configuration. Playing with jscal but with no success up to now.



  • Update: Using jstest-gtk, I setup the joystick "correctly" (I had to switch axis).
    So now in jstest-gtk directions are OK...also saved using jscal-store and all seems OK( using jstest-gtk) even after a reboot.

    BUT I still have the same issue in Daphne and Prince of Persia Port and ScummVM...so basically any emulator that uses the joystick directly in Retropie.
    So I guess that it's something that is realted with Retropie, no Daphne.



  • OK, apparently Daphne uses evdev so changing the mapping of /dev/input/jsx is useless.
    However, I fixed the problem with a small change in ControlBlock driver (see: https://retropie.org.uk/forum/topic/6936/controlblock-joystick-configuration)


  • Global Moderator

    @darkav

    Very nice!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.