Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hi,

    I took some time to find how to bind the FAST-FOWARD and REWIND function to controller. Some post ask how to do it.

    Here is how I did it. So far, I tested this with NES and SNES.

    Bind FAST-FOWARD

    2 files to edit

    • \\RETROPIE\configs\all\retroarch.cfg
      Search for : input_hold_fast_forward
      Uncomment the line and set the button number you want
      input_hold_fast_forward = 7
      (7 is the right trigger)

    • *\\RETROPIE\configs\all\retroarch-joypads\Xbox360WirelessReceiver.cfg
      Find the button number you want to use, (I choose button 7 (right trigger))
      input_r2_btn = "7"
      Replace it by:
      input_hold_fast_forward_btn = "7"

    Save all, reboot and it works!


    Now I tried to do the same with REWIND, same thing BUT, you need to ENABLE the rewind in the emulator it self.
    For exemple, for the NES, go in the emulator menu (toggle button+X) and go in Settings->Frame Throttle->Rewind. Turn it ON. You can save the setting in the same menu, go in Configurations.

    Beware, I read online that enabling the REWIND may cause emulation trouble. I did not played enough with it to confirm it.

    You can also edit the config file for every system. Here and example for the NES console.

    ENABLE REWIND

    1 file to edit

    • \\RETROPIE\configs\nes\retroarch.cfg
      Search for : rewind_enable =
      Change it to
      rewind_enable = "true"

    Bind REWIND

    2 files to edit

    • \\RETROPIE\configs\all\retroarch.cfg
      Search for : input_rewind
      Uncomment the line and set the button number you want
      input_rewind = "6"
      (6 is the right trigger)

    • *\\RETROPIE\configs\all\retroarch-joypads\Xbox360WirelessReceiver.cfg
      Find the button number you want to use, (I choose button 6 (left trigger))
      input_l2_btn = "6"
      Replace it by:
      input_rewind_btn = "6"

    Save all, reboot and it works!


    Have a nice day!
    MarcB


  • @MarcB some steps you mentioned are unnecessary.

    • you don't need to edit the all/retroarch.cfg like you did to make it work.
    • you don't need to replace that line on the Joystick.cfg. Just add the other line with the fast-forward/rewind option.
    • you don't need to reboot.

  • @meleu Well, it did not work before I modified the all/retroarch.cfg config file. Maybe i'm wrong? What is the purpose of that file then?


  • @MarcB it's the global RetroArch config file. But some configs are in other files.
    For fast-forward for example, the input_hold_fast_forward_btn = "7" line
    in configs\all\retroarch-joypads\Xbox360WirelessReceiver.cfg is enough. But keep in mind that this config will work only for your xbox joypad.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.