Please do not post a support request without first reading and following the advice in

error while loading shared libraries:

  • @buzz i have the same issue. How would i do this?

  • Global Moderator

  • @mediamogul thanks. Will try the command as i can't get into ES.

    I get this message after trying to update retropie:
    Retropie/supplementary/emulationstation/emulationstation: error while loading shared libraries: open shared object file no such file or directory

  • Global Moderator


    Browsing over your history, it looks like you're on borrowed time until you have to start over from scratch. Pre-built 3rd party images are not only illegal, but the people who set them up usually don't know or care what they're doing. It makes for a lot of extra work for us, so I hope you'll respect our policies and seek help from the people who sold you the setup in the future. You've been warned about this issue earlier and you're risking removal if you continue to ignore it. If you ever decide to start over with a clean image from this website, we're always more than happy to help you.

  • @mediamogul Listen , i don't appreciate the tone you're taking. I was looking for a retro games machine for a Christmas present for myself. I went halves with a family member. I looked thru many adverts on FB and online. I had no idea these small 'companies' or people selling retropie are doing it illegally.
    But also i would have no idea to put together a hdmi wifi box with a 360gb Harddrive. So please spare me the warnings like i'm some criminal. I just wanna play Chuckie Egg on the Sinclair. Or Road Rash on the Megadrive. If you can't help, fine. But i've seen others with nearly exactly the same problem and there is no high horse judgement going on. Just people trying to help.

  • Global Moderator

    @bg223 said in error while loading shared libraries::

    I was looking for a retro games machine for a Christmas present for myself.

    I hope it works out for you.

  • @bg223

    I understand your frustration, and the tone may be blunt from some of the members here, but we've spent a lot of time trying to help people only to find the people who build these machines have cocked something up so royally, the only way to fix it is to start from scratch.

    I would suggest that as a first port of call, go back to the person you purchased it from and ask them.

    Failing that, you will only get support from here without issue by reimaging the card to the stock image from here (which has no games installed).

    Sorry, but you've been burnt by an unscrupulous seller ☹️

  • I love Xmas... More people being scammed by rip-off merchants, then expecting others to sort out their mess. I actually feel bad for this guy but rules is rules and zero tolerance to TP images is the correct way to go.
    Use the stock, official image and people here will break their necks to help you if they can. That's the best advice you'll ever get.

  • @jonnykesh so let me get this right....i get the image from here that has no games on it. Then what? I get the emulators and games myself yeah? So do you then pay for the emulators and games?
    Genuine question.

  • @simonster i haven't been scammed, this was my own doing. The machine works fine i just need to correct the directory it is looking for. I am 36 , i had a lot of the games that are on this retropie. You know, I paid for the games with my money when they originally came out. I'm not some thief. I just want to relive some of those games.

    If you don't want to help i get it. But don't act all high and mighty with me. 90% if not all of the people on this forum all downloaded the roms and games for nothing. What's so righteous about that?

  • @bg223 You obtain ROMs like everyone else and as a consequence learn how the system you have actually works. Game ROMs are readily available from legal and illicit sources on the net.
    I would also advise you to temper the 'tude. You are about 3 posts away from being banned. To be honest I would cut your losses and either install the official image or wait until you can get support from your seller.

  • @jonnykesh so all your ROMS and games are 100% legal yeah? You yourself i mean.

  • @bg223 Did I say that? Where I get my ROMs from is no concern of yours. Anyone with a device and a connection to the internet can find ROMs. Have you ever tried a search engine? I don't mean to be rude pal, but it's actually easier to obtain game ROMs than a virus these days. If you can't be bothered to do it then that is up to you. Just don't expect people here to sort the mess you paid for out.

  • @jonnykesh nah you see there it is. You probably all do the same but you want to judge. I've already paid the companies that originally made the games and subsequently went bust from people just taking them. Have you ever paid OCEAN or Superior Software or ELITE or hundreds of other companies that made these games u have?

    Yeah i could learn about it more. But i honestly don't have the time or if i'm also being honest probably the intelligence. If i did i would of made my own box. So i guess well done for being clever.

    If this offends u as 'tude' then fine. Buts it's just words. You can either help genuine people when they are a bit stuck or you can be a dick.

  • @bg223 I've helped plenty of genuine people on this forum. Most regulars do. Go buy a SNES Mini and do everyone a favour. It's clear no one here wants to help you. I'm out. Happy New Year to you and Yours.

  • @jonnykesh @mediamogul

    ^^This guy had the exact same problem. I have linux 4.4.13v7 according to the retropie spec upon booting up.

  • Global Moderator


    You've made your opinion known and everyone's been very patient. You must know that we're not going to change one of our fundamental policies just to suit you. Now you're derailing the thread and insulting other users. I'm sorry you're having issues, but we've given you constructive options to move forward. Flash an official image, or wait for help from the people who sold you your setup. Anything further from you on this and it's time for go bed.

  • @mediamogul there is some command type that you probably know that could help me. The machine could of been put together exactly like how everyone else has and he just added the roms and games that i've seen on every video online.

  • Global Moderator

    @bg223 said in error while loading shared libraries::

    The machine could of been put together exactly like how everyone else has and he just added the roms and games

    If you're talking about the guy that sold you the illicit setup, I'm sure he had nothing but quality on his mind when he profited off the hard work of others.

    You were warned politely several times to drop the issue and you still insist on ignoring the rules. Your ban will be up in 24 hours. I hope that if you return, you'll respect our policies, as well as the other users. Otherwise it will be extended.

  • Hi Guys!

    new kid on the block! i was originally going to create this account to try and figure out why some of us are taking this way too seriously, but i figure i'll try and keep this productive since i think i may be in the same situation as the OP, right down to the xmas present for myself!

    basic setup:

    raspberry pi 3 b
    5" lcd
    prebundled jessie (GASP i know... i know)
    32gb sandisk microsd
    plugged directly into a surge protector with usb expansion
    logitech k400r wireless kb/mousie thing

    basic rundown:

    so i got the pi a couple weeks ago, set it up with hdmi, worked like a charming little bugger.
    screen came in thursday. somehow managed to get water in the lcd while applying a screen protector, so there's some minor water damage that's currently drying out. it'll be alright, i was just worried about scratching the lcd since i've got longish nails.
    side note it's pretty spunky! i can run that thing on a little cellphone recharger battery doohickey for like 4 hours. no more than that though. it died when i was almost done installing lazarus! that sucked.
    anyway. had to re-image about four times in two days because i'm anal retentive and yes, my bf hates that about me. since i'm using a prebundled os, i've gotta do things a certain way to maintain full functionality as a general purpose little sbc i could take with me anywhere for multiple uses. basically a jacked tablet i could customize for general purpose computing. i'm talking budget spreadsheets, maths, browsing recipes, reference manuals, cat memes, games, ordering lingere, you name it

    hang on, takin' it to the bridge:

    so i was sitting here tipsy off of a little vino last night, and thought "hey, i wonder if there's an emulator for this cute little thing i could sit there and play snes roms with at lunch and make all the cool kids jealous"
    and lo and behold, retropie showed up with enough googling!
    i'm thinking to myself, this is way too much for what i want.... but hey, if it makes aggregating emulation resources easier WHY THE HECK NOT?!!
    right? am i right?
    so i followed the instructions here:
    and long story short, i seem to have wasted the last 2 hours of my life screwing with this thing trying to get it to work unsuccessfully.
    followed it verbatim.
    there were some error messages i think....
    some crap about libraries not being installed successfully. or something. i didn't think it was too important so i just said "screw it, let's reboot and see what happens"
    and i get the same error message the OP is getting!
    is there some sort of logfile or directory i can purge to figure out which library couldn't be installed?

    is that all.... think so
    i'm trying to think of any more info that might be pertinent.

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.