Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

DraStic (Nintendo DS emulator) OUT NOW for pi2/3!



  • Keep in mind it's just a beta, there are going to be some issues and bugs...



  • indeed i was getting some random crashes on diddy kong racing a few mins ago

    @BuZz
    thanks for the updated setup seems to fix the save data so far :D



  • @BuZz thx for your fixes - Looking on your post regarding unwanted folder creation: is it required to cleanup anything manually afterwards (retropie latest default installation)?


  • administrators

    @daeks If you install from latest retropie-setup folders are now created in one place if launched from ES as usual. However, old folders in /home/pi/ if you installed before will need removing. I cannot change the behaviour of the app as it's closed source (My workaround is to change to a set folder before launching etc).



  • Welp, there goes any productivity for today. Scuse me while I relive my childhood.



  • I really can't believe how well this works on my pi3. Everything I've tested, works! I didn't even have to edit the drastic cfg file as the onboard gui works. Only gripe is the emulator hangs in the background for me sometimes, but I understand this is still beta. I'll totally following the progress of this.



  • I tested about 20 games on this and nearly all of them worked perfectly ! Instead of listing the games I tried, I'll list the ones that had problems.

    GTA Chinatown Wars - Exited the Emulator when it said 'saving' (very beginning of game)
    Legend of Zelda Phantom Hourglass - Exited the Emulator
    Mystery Case Files Millionheir - Exited the Emulator when it asked to use the microphone to clean the badge (No microphone emulation ?) (yet)



  • Maybe this is just for me, but run command no longer works. Upon launching any game, I get a black screen with a cursor. Only happened after installing Drastic. Also, stylus will not work anymore.


  • Global Moderator

    @lilbud said in DraStic (Nintendo DS emulator) coming to Pi 2/3 "very soon"!:

    Maybe this is just for me

    It's not just you. I believe it has to do with DraStic hanging on exit. You can continue to launch other DS games, but anything else requires the program be forced to shut down or a system restart.



  • @mediamogul

    I had the same issue and I reported it when I presented my Pull Request to add the script for DraStic.



  • I get an error when trying to install DraStic.
    I'm using RetroPie version 4.1.11
    I'm installing from binary, from the Experimental section.
    It says "Unable to install binary for drastic"

    This is what it outputs to the log:
    Log started at: Mon 23 Jan 17:14:03 UTC 2017

    = = = = = = = = = = = = = = = = = = = = =
    Installing 'drastic' : NDS emu - DraStic
    = = = = = = = = = = = = = = = = = = = = =

    bzip2: (stdin) is not a bzip2 file.
    tar: Child returned status 2
    tar: Error is not recoverable: exiting now
    Unable to install binary for drastic

    Log ended at: Mon 23 Jan 17:14:03 UTC 2017
    Total running time: 0 hours, 0 mins, 0 secs


  • administrators

    @cloudlink looks like a networking issue - make sure your RPI has a working internet connection and try again.



  • Does anyone get a black screen when pressing M for menus on pi3? Apparently myself amd someone else are having this problem. Coincidently we are both on a 4:3 monitor. Could this be the issue?
    Also i couldnt find the .cfg file in the nds config folder. Instead there was a .cf2 file which was very plain when i opened it in notpad++. I was hoping to manually edit the .cfg file since i couldnt get in the UI pressing M. Can anyone point me to the correct location of the .cfg file?

    EDIT: Sorry I was a bit rude and didn't introduce myself with my first post. My apologies and great group. Thanks in advance



  • @BuZz Thank you BuZz. You were correct. It was a networking issue.



  • @mediamogul How about the stylus, are you having this issue as well


  • Global Moderator

    @lilbud

    I haven't noticed an issue with the stylus. I've been playing 'WarioWare: Touched!' with an air mouse and it's a lot of fun. Also, I've mapped mouse movement to the left joystick of my controller for this emulator and it also seems to work decent enough in a pinch.



  • @mediamogul My stylus just stopped working, it moves, but clicking it has no effect



  • @Linkseo

    Try reinstalling DraStic.
    For the other issue, you have to edit something in the DraStic GUI first to get the .cfg file to show up...



  • @lilbud

    I have never experienced that issue...



  • @RetroPieNerd
    Thank you. I've tried uninstall and reinstall but the cfg file is simply not there. only a drastic.cf2 file is in the config folder. weird. anyway you can share your .cfg file so I can add it to my folder?


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.