Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Newb - Intial setup, video stuck at 640x480



  • Hi All!

    Newb here with what I believe is a fairly easy question.

    I've just purchased a Rasberry Pi 3 for my 9 year old son, and want him experience the fun games I grew up with.

    I had some challenges getting my Retropi to display video on my LCD TV (Sony 55inch circa 2011) after digging through the forums and the wiki, enabling hdmi_safe=1 fixed the issue, but brought another.

    My display is stuck at 640 x 480, so at the moment I am staring at this little square on my giant TV. After combing the forum and wiki, i came across https://github.com/retropie/retropie-setup/wiki/Video-Issues and used to the suggestions to no avail.

    Am I missing something here?

    Here's my config.txt

    # For more options and information see
    # http://www.raspberrypi.org/documentation/configuration/config-txt.md
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=1
    hdmi_mode=16
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    sdtv_mode=0
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    overscan_scale=1
    

  • Banned

    @Carbooja just to check... you are using an HDMI cable, right?



  • @columboscoat

    Yes that is correct, brand new pi with latest build of retropi

    TV supports 1080P


  • Banned

    @Carbooja ok. I'll check my config.txt against yours.


  • Banned

    @Carbooja You are missing a few hashes at the beginning of some lines. Is this a cut an paste error or your actual FULL config.txt file?


  • Banned

    @Carbooja sdtv_mode should be commented out with a #.



  • yes its a cut and paste of my full config, let me hash out the sdtv

    +++++++++++++++++++++++++++++++++++++++++++++

    # For more options and information see
    # http://www.raspberrypi.org/documentation/configuration/config-txt.md
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=1
    hdmi_mode=16
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=0
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    overscan_scale=1
    


  • Same issue.


  • Banned

    @Carbooja Did you reboot after the change? You will need to.



  • @columboscoat

    This is what i'm doing, I power off the unit, I have a copy of the config.txt file on PC which i'm editing using notepad++

    Once i've made the change, i plug in the SD Card into my PC, copy the config file on the the SD card overwriting the one there.


  • Banned

    @Carbooja change HDMI_mode to 1. And reboot. Can you not just make these changes on the pi from desktop or using nano text editor?


  • Banned

    @Carbooja Use the command line / terminal and enter "tvservice -s" no quotes. Post the output.



  • @columboscoat said in Newb - Intial setup, video stuck at 640x480:

    tvservice -s

    What commands do I have to run prior to this ?

    I'm connected via putty now..

    pi@retropie:~ $ tvservice-s
    -bash: tvservice-s: command not found
    pi@retropie:~ $



  • @Carbooja said in Newb - Intial setup, video stuck at 640x480:

    @columboscoat said in Newb - Intial setup, video stuck at 640x480:

    tvservice -s

    What commands do I have to run prior to this ?

    I'm connected via putty now..

    pi@retropie:~ $ tvservice-s
    -bash: tvservice-s: command not found
    pi@retropie:~ $

    There is a space before the -s: tvservice <space> -s should get you the correct output



  • @mrbwa1 state 0x12000a [HDMI CEA (1) RGB full 4:3], 640x480 @ 60.00Hz, progressive


  • Banned

    @Carbooja change hdmi_mode to 16. Reboot.



  • @Carbooja My standard Config.txt has the following lines commented out:

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1
    #hdmi_mode=1

    So as stated, change to hdmi_mode=16 (and you can probably comment out those lines if you are going for the standard 1920x1080 resolution).

    EDIT: hdmi_mode=16 is the standard 1920x1080 and what is used if the lines above are commented out.


  • Banned

    @mrbwa1 tvservice -m cea will show him all resolutions and frequencies supported. To the left there will be native and prefer. Mode 16 is the preferred mode. My TV is mode 31 (native) @50MHz because I am in Ireland and that is standard. The same for the UK.



  • @columboscoat said in Newb - Intial setup, video stuck at 640x480:

    @mrbwa1 tvservice -m cea will show him all resolutions and frequencies supported. To the left there will be native and prefer. Mode 16 is the preferred mode. My TV is mode 31 (native) @50MHz because I am in Ireland and that is standard. The same for the UK.

    Thanks for the clarification. That's what I get for only half-paying attention to the question. I forget that my TV is 1080P 60Hz native even though it's only a 720P TV.



  • We're good!

    I think in hindsight, disabling hdmi_safe=1 mode and then setting hdmi_mode=16 did the trick.

    Thanks for all your help!

    Now time to explore this thing :)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.