Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SD Card Block Size with RetroPie


  • administrators

    @siresalty how are you checking this - from a Windows machine? I don't think this is accurate - just ignore it.



  • Pi Model or other hardware: Pi3 B Model
    Power Supply used: CanalKit 2.5 Amp Pi Power Supply
    RetroPie Version Used: 4.2 (retropie-4.2-rpi2_rpi3.img.gz from https://github.com/RetroPie/RetroPie-Setup/releases)

    Ok im having this exact same problem.

    Every file is reporting as at least 1.0mb in size.

    Exactly the same issue user siresalty was having, his description of his problem is the same as mine.

    Quick rundown-Made a great image, wont fit on friends 32gb card.Great. sigh

    Now im remaking the image on his slightly larger 32gb card Sandisk Ultra card.I formatted the card using sd card formatter.

    Im using retropie 4.2 as im using nismo's 'old room theme', and from what ive read on the forums, 4.3 breaks this theme due to z-indexing.

    I copied all the the bios/configs/roms files off my old image onto the computer.

    I swap my card out for his freshly installed 4.2 stock pi image.

    Ive set it all up, downloaded all the optional emulators etc and all i need to do is drag and drop some config files, and the roms (plus associated snaps/marquees/boxart) onto his card and im 99% done.

    Heres the problem; it all doesnt fit on his card, im short about 3.5gb or so, which is a BIG difference.

    After scratching my head a while i right clicked on a random file reported through windows as 7kb, but in the properties window it says 'size on disk' of 1.0mb.So all these little files that are just a few kilobytes are all being read as 1.0mb, which added altogether suck up a tremendous amount of space.

    Highlighting all files in the configs folders yielded from memory about 8000 or so files, with a size of 60mb or so, but size on disk of around 3gb.

    It is NOT simply windows incorrectly reading the size, as using the command 'df' in the pi console command shows that 8% is already used on this 32gb card, straight after the fresh 4.2 install.

    Im really puzzled by this.Any ideas?????

    p.s. as an aside, if the community has worked out a reliable way of shrinking a pre made image THROUGH WINDOWS (no ubuntu/linux watevs) id prefer that solution over having to rebuild this image from scratch.And, no, paragon partition manager 2014 does not work.


  • Global Moderator

    @megafacehead said in SD Card Block Size with RetroPie:

    Exactly the same issue user siresalty was having, his description of his problem is the same as mine.

    There is no problem, just a misunderstanding on @SireSalty's part, as explained.

    @megafacehead said in SD Card Block Size with RetroPie:

    p.s. as an aside, if the community has worked out a reliable way of shrinking a pre made image THROUGH WINDOWS (no ubuntu/linux watevs) id prefer that solution over having to rebuild this image from scratch.And, no, paragon partition manager 2014 does not work.

    Until Windows supports reading and writing Ext4 linux filesystems, the only reliable way to shrink an image is using a Linux system.



  • But i cant fit the files on it?

    When i highlight all the roms i want to drag and drop onto his card, windows says 'there is not enough space, you need an additional ~3.5gb to copy these files'

    So...?

    -Keep in mind all this stuff, these roms, config files etc all fit fine on my 32gb card.



  • 8% of a 32GB (usually 29GB actual) card used on a fresh install sounds correct to me. The image is 2.1GB or so. Not sure what you think the issue here is exactly.



  • @jonnykesh

    Im trying to work out why when i copy everything off my 32gb card, manually, all the files found in the 4 folders roms/configs/bios/splashscreens onto my computer and then go to copy them back onto my friends card (same size, 32gb, give or take a few mb difference which happens between different cards) suddenly im 3.5gb over the limit.


  • Global Moderator

    @megafacehead The sd card has 2 partition

    • the boot partition, which is quite small. This is the partition you see if you insert the sd card into a Windows system.
    • the linux partition, which holds the rest of the SD card size and where the ROMs are stored. This partition is not accesible from a Windows system.

    If you try to copy your ROMs on the card, you'll be copying the on the boot partition, where obviously there isn't enough space.

    Use the recommended way to transfer the ROMs - https://retropie.org.uk/docs/Transferring-Roms/



  • @mitu

    i realise that, im not transfering them onto the small bott partition, ive got the pi connected to the home network and can directly access the 4 folders on the linux partition, again, bios/configs/roms/splashscreens

    EDIT-ill try moving the roms in two smaller batches.brb



  • Yep, there is a problem, regardless of whether or not someone wants to believe it.

    I think Buzz was right in saying it's a windows issue, but it cant be ignored, it has to be worked around.If windows says (incorrectly or othwerwise) that there is not enough space on a destination card/hdd it wont follow through with the file trasnfer.Doesnt matter if there IS actually enough space.

    So for other peoples benefit, ill clarify the problem and the fix.

    --
    I had a 32gb card, nearly full to the brim with roms, plus associated images/marquees/video snaps.

    I transferred all of this, via my home network, to my desktop win 10 computer.So all the stuff from the 4 accessible folders on the linux partition, splashscreens/roms/bios/configs.

    Then, i put retropie 4.2 on a new (same brand sandisk ultra) 32gb card, and went to transfer everything back (i know this is a sloppy way of 'mirroring' a card, just stay with me).I transferred all the files/folders from the bios folder, splashscreens folder and configs folder to the new card.Good no problems, told it to overwrite whatever it found identical.

    But when i went to copy the roms folder over(which is 29.0gb in size when checked via properties on win10), windows said there was not enough room on the destination card, and that i was over by about 3.5gb (all this is from memory) .

    Like seriously, i know some 32gb cards can vary in size up to 100mb but 3.5gb? No that's a problem.

    And it's a problem because win10, when viewing a files size on the pi over the network, will show any file under 1.0mb as 1.0mb (even if it's just 7kb) and for files over 1.0mb rounds up to the next nearest whole mb.

    I formatted the card again, reimaged a fresh 4.2 onto it and tried again, same result.

    The only way i got around the problem was to transfer the roms folders contents in about 4-5 'chunks', whereby the last chunk still spat out an oversize message of 96.0mb, so i deleted a couple of large pcengine cd games and it transferred fine.This oversize message may actually have been a legitimate amount as i believe this card is about 100mb or so smaller then the card i originally transferred all this stuff off.

    So yeah, i know most people who read this earlier simply assumed i was some idiot noob trying to squeeze 29gb of roms onto the boot partition or some other bonehead mistake but surely im not the only one who has encountered this.

    Again, im pointing the finger squarely at windows (windows 10 pro btw) but it was(still IS in fact) a legitmate problem i encountered and was a bit annoyed at the generic 'read the faq before posting' and 'nothing to see here user error lol git gud' replies.


  • Global Moderator

    @megafacehead Sound like an undersized card to me. Have you check what Linux reports as free space on the disk ? Log in via SSH or just drop to a command line by pressing F4 on the ES screen and run df -h to see how much space is available on the card.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.