Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PI 3 + PS3 Bluetooth controller freeze fix. UPDATED



  • After I do the "sudo rpi-update 15ffab5493d74b12194e6bfc5bbb1c0f71140155" and it's doing the update thing, then after a bit, I get several errors, like:
    "gzip: stdin not in gzip format"
    "tar: Child returned status 1"
    "tar: error is not recoverable: exiting now"

    I'm doing this on my raspberry pi 3, Retropie 3.7.

    Any idea how to solve this?



  • @opensourcefan I dont't know, I cannot reproduce it. Check /var/log/syslog.

    @thorgim reboot and try again.



  • @Rascas It did the same thing again, but after I did a "sudo rpi-update", then it update the firmware to 4.4.9-v7, and it backup the 4.1.19-v7 with no errors at all. Seems it work better than the other option.



  • @thorgim rpi-update without the hash updates to the latest kernel version available, with the hash updates to the specific commit. Since that specific commit is already verified to work for many people, and later ones not, that was the reason to pick that specific commit.

    EDIT: That is no longer needed. Kernel 4.4 is on Raspbian repo now, just update as normal:

    sudo apt-get update && sudo apt-get dist-upgrade
    


  • @Rascas Thanks



  • @Rascas Thank you!



  • pi3, 3.7, updated to kernel 4.4, ps3 wireless

    I got my pi last month and was running retropie with the old kernel before and got everything running except for the random freezing problem. So I updated the kernel to 4.4 yesterday. Now it seems impossible for me to pair my ps3 wireless with my pi. Maybe I missed some important settings?

    That's what I did:

    'sudo apt-get install rpi-update'
    'sudo rpi-update 15ffab5493d74b12194e6bfc5bbb1c0f71140155'
    'sudo update-ca-certificates --fresh'

    I also tried to use:

    'sudo apt-get update && sudo apt-get dist-upgrade'

    Still the controller is working with usb, only. Any suggestions what else I could try to get my bluetooth working again? (I'm quite new to all of this so it is hard to tell what's going wrong for me)



  • I think this is a bug with the update itself. It may be killing the Bluetooth. Take a look at this thread https://retropie.org.uk/forum/topic/905/lost-ps3-bluetooth-after-updating-raspbian/9



  • I foresaw there being a BT issue in retropie when I saw the release notes for Raspian on Distrowatch yesterday from Simon Long:

    "We've just released a new version of our Raspbian image with some (hopefully) useful features. When the Pi 3 launched back in February, we'd not had time to do much in terms of getting access to the new on-board Bluetooth hardware. There was a working software stack, but the UI was non-existent. I'd hoped to be able to use one of the existing Linux Bluetooth UIs, but on trying them all, none were really what I was looking for in terms of usability and integration with the look and feel of the desktop. I really didn't want to write one from scratch, but that ended up being what I did, which meant a fun few weeks trying to make head or tail of the mysteries of BlueZ and D-Bus. After a few false starts, I finally got something I felt was usable, and so there is now a Bluetooth plugin for the LXPanel taskbar."

    So, the new bluetooth module does fix BT in LXDE...but apparently breaks in in Retropie. The short term solution is to downgrade it as stated in the previous post (although I have yet to confirm that...but I see no reason why it would not work) but again it is a short term solution. The solution is not to suppress the update but to fix the compatibility issue in Retropie. Hopefully we'll see a v3.8 with compatibility with the new BT module fixed so that we can enjoy the best of all worlds.



  • After a dist-upgrade, do:

    wget http://archive.raspberrypi.org/debian/pool/main/p/pi-bluetooth/pi-bluetooth_0.1.0_armhf.deb

    and

    sudo dpkg -i pi-bluetooth_0.1.0_armhf.deb

    Reboot afterward. If hciconfig give you an output the bluetooth is working again.

    This will downgrade the bluetooth module and allow the PS3 controller (and other BT devices) to work again. Best part is now that the kernel has been updated the freezing no longer exists. I have been using the PS3 controller all night without a freeze.



  • what way can I check what version of the bluetooth module is installed from the commandline and also how to check if the bluetooth module is seeing the controller at commandline level?



  • @Wolfman100

    If you download the pi-bluetooth_0.1.0_armhf.deb and do a sudo dpkg -i pi-bluetooth_0.1.0_armhf.deb, you will get a warning that you are downgrading the file. You will then know you are running the newer version that is not working. You can allow the downgrade.

    I believe you can do an hcitool dev to show all on devices if I remember correctly. Don't quote me on that though...



  • @eightbit Thanks for that info.I will have a look at that this evening.I am running RetroPie installed in OSMC and am wondering whether this is causing some kind of Bluetooth conflict between 'bluetoothctl' and 'sixpair'.

    I have a bluetooth keyboard which works flawlessly with this setup and also works within RetroPie.This leads me to believe that because this Bluetooth keyboard is working in RetroPie that RetroPie is using Bluetoothctl which OSMC is using rather than enabling SIxpair?



  • I have tried the downgrade but encountered the following error:

    root@osmc://# sudo apt-get install rpi-update
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package rpi-update
    root@osmc://# wget http://archive.raspberrypi.org/debian/pool/main/p/pi-bluetooth/pi-bluetooth_0.1.0_armhf.deb
    --2016-05-16 12:04:03-- http://archive.raspberrypi.org/debian/pool/main/p/pi-bluetooth/pi-bluetooth_0.1.0_armhf.deb
    Resolving archive.raspberrypi.org (archive.raspberrypi.org)... 93.93.135.188, 93.93.128.133, 93.93.130.236, ...
    Connecting to archive.raspberrypi.org (archive.raspberrypi.org)|93.93.135.188|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 3182 (3.1K) [application/x-debian-package]
    Saving to: ‘pi-bluetooth_0.1.0_armhf.deb’

    pi-bluetooth_0.1.0_ 100%[=====================>] 3.11K --.-KB/s in 0.001s

    2016-05-16 12:04:03 (2.75 MB/s) - ‘pi-bluetooth_0.1.0_armhf.deb’ saved [3182/3182]

    root@osmc://# sudo dpkg -i pi-bluetooth_0.1.0_armhf.deb
    Selecting previously unselected package pi-bluetooth.
    (Reading database ... 51347 files and directories currently installed.)
    Preparing to unpack pi-bluetooth_0.1.0_armhf.deb ...
    Unpacking pi-bluetooth (0.1.0) ...
    dpkg: dependency problems prevent configuration of pi-bluetooth:
    pi-bluetooth depends on bluez-firmware; however:
    Package bluez-firmware is not installed.

    dpkg: error processing package pi-bluetooth (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    pi-bluetooth
    root@osmc://#

    It says package bluez-firmware is not installed.It must be though otherwise I wouldn't be able to use my bluetooth keyboard right?!Could this be that I am doing it as a root user under OSMC?



  • ive literary tried every step in this thread and now my controller when i press to connect to BT connects and then the system freezes up right after ...Is there a legit clean way to get this thing working without a million different steps?



  • @smoothmalik if you read the first post, you only need one step and it is to update and upgrade. It works for me so I cannot see why it wont work for others. I had already installed the package raspberrypi-sys-mods so check if you have that installed also.



  • @Rascas I started with the first post and nothing worked so I kept going down the thread to other suggestions which lead to where i am now lol fucked...im prolly just gonna do another clean install and try this for like the 3rd time...



  • @smoothmalik Besides the PS3 gamepad install, it is just 2 more commands, pretty easy ;)



  • Attempting to downgrade and I get the following:

    dpkg-deb: error: 'pi-bluetooth_0.1.0_armhf.deb' is not a debian format archive

    What am I suppose to do with that...


  • administrators

    You didn't download it correctly I guess. But you don't need to downgrade - install raspberrypi-sys-mods


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.