Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Disk spacefull at 4GB, on a 64GB SD Card?



  • Hi all.

    I have recently got my self a Pi3 and a 64GB sd card. I have followed the install instructions and managed to get Retropie up and running.

    However when I started to copy my roms across to the Pi after transferring about 4GB of roms across it stopped. If I try to add any more I get an error saying I need more disk space.

    I have a 64GB SD that everything is installed on but can only store about 4GB of roms.

    I have done some googeling and found this info, nor sure if it's old now but people are saying the Retropie disk image was built for a 4GB SD card. So the filesystem/partition when burned to the SD card is set to 4GB.

    If this is true how can I make it so that I can use the full 64GB SD card?

    Thanks for any help you can all give.



  • You need to expand the filesystem. I was under the impression that the newer versions of Retropie did this automatically. Its supposed to expand the filesystem automatically on the first boot. But maybe if your using a copy of someone elses image where first boot has already happened you'll have to do it manually. Hopefully this information is not too out of date.

    1. Once Emulation Station starts and your up and running, press F4 to quit and drop to terminal.

    2. Type 'sudo raspi-config' to start configuration.

    3. Look for the option to Expand Filesystem and run it.

    4. Once it completes reboot by typing 'sudo reboot now'



  • As a side note. If you bought a cheap (I mean REALLY cheap) SD Card on E-Bay or somewhere, its possible to have a conterfeit card. There are some disreputable sellers online that will sell you say a "64 GB" SD-Card online. You get it, it says 64 GB on the printing on the card, as well the system reports it as being 64 GB, but when you try to copy anything past say like 2 or 4 GB it just drops the rest of the information. This happens because its really a 2GB card thats been reprogrammed to report as 64 GB. The short of it is, if your getting a SD card for a too good to be true price, thats because its too good to be true.



  • @Thrylax thanks for this, I will give it a go when I get home from work. The image I used I got from the retropie wevsite, maybe the setup glitched if it's supposed to do it at first boot.



  • @Thrylax I got my SD card from amazon. It's a class 10 hc SanDisk sd card. So I'm confident it's a good enough and legitimate card.



  • @JoeDin2056 Since you are already running into issues, I'd try reformatting it while plugged into your computer and see if you can load it up with a lot of data, or if it flakes out past a few GB.



  • @obsidianspider I will try this. I will format it on my computer and see if it can hold all the roms I want to store on it, that's about 20gb.

    If it holds them all I will format again and burn the retropie image on to it again and follow the instructions from the other poster to extend the filesystem.



  • I now have it working. The SD card was working as it should, for some reason it was not automatically running the process to extend the filesystem, even after a reinstall. So i ran the command to do it my self.

    That has solved my issue and i now have all my roms copied across and everything is working well.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.