Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

**Solved** Unable to correctly register bluetooth controller with EmulationStation on Retropie 3.6



  • Hi,
    Unfortunately I have been struggling with the configuration of my Bluetooth gamepad controllers within RetroPie 3.6 on a RPi 2.
    I have a chinese no brand "S600 Gamepad" that was purchased from Amazon and a "ipega PG-9025" controller that was used with my Android phone which I want to re-purpose for my Retropie setup.

    Whilst I can register both the controllers (at the same time) with Retropie using the bluetooth registration process, neither are detected or will respond in EmulationStation (unless registered in "keyboard mode", but then only one will work and it overrides the real keyboard configuration).

    The controllers are working because from Linux I can type "jstest /dev/input/js0 "or "jstest /dev/input/js1" to read the inputs from the controllers, they are just not accessible to ES.

    Has anybody come across this before and have an idea how to resolve this? It is driving me crazy!

    Fingers crossed...

    Thank you.



  • Same problem here...



  • At least I'm not alone, I guess....

    Hopefully others have seen this as well and also understand how to resolve it :)



  • I had my fingers crossed that my issue might have been resolved with the release of 3.7, but unfortunately this isn't the case :(

    Does anybody have any ideas?



  • Okay, so I have had some element of success using "xboxdrv" when added to Retropie to emulate an Xbox 360 pad using event inputs.
    I haven't fully worked out the button mappings yet, and even if this will work in Retroarch emulators etc but it is a step in the right direction, at least I can control ES using the bluetooth pad.

    I'll post up what I've done when I get my head around it a little more....



  • will be watching as my Bluetooth controller doesnt even show up



  • Excuse me while I perform the ceremonial at desk/chair dance and give a little fist pump...... :)

    Hooray, I now have working bluetooth controllers on my RPi2 after much digging around.

    As stated earlier I was sidetracked slightly by using the "xboxdrv" tool to map a working event to my bluetooth controllers which did work, however it wasn't elegant because the command needed to be run after the bluetooth controller was connected.
    While trying to work out how to do this I came across the most simple fix for getting my controllers to register in Emulation Station natively.

    Basically all I needed to do was:

    1. Register both the controllers using the RetroPie menu "Configure Bluetooth Devices"
    2. Jot down the names of each device. In my case they are "S600 Gamepad" and "ipega media gamepad controller"
    3. At the main screen, press F4 to drop to the command line
    4. Type "sudo nano /etc/udev/rules.d/55-local.rules" to create a new udev rule file containing the following entries:

    SUBSYSTEM=="input", ATTRS{name}=="S600 Gamepad", MODE="0666", ENV{ID_INPUT_JOYSTICK}="1"
    SUBSYSTEM=="input", ATTRS{name}=="ipega media gamepad controller", MODE="0666", ENV{ID_INPUT_JOYSTICK}="1"

    1. Press CTRL+X and save the changes
    2. Type "reboot" to restart the Raspberry Pi
    3. Press the pair buttons on each controller and then select "Configure Input" in Emulation Station (using another wired controller or keyboard) - it now detects both my bluetooth controllers ready to configure button mappings.

    I can't really believe it has taken this long to figure it out, but I'm pretty happy now :)

    I hope this helps somebody else who is also struggling just like I was....

    Cheers.



  • Did you use this controlers on non-RetroArch emulators? (like pifba or mame4all)


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.