Please do not post a support request without first reading and following the advice in

Announcing Pegasus Frontend

  • @fluffypillow A problem. I've been having issues loading the steam link app. Permission problems. After days of troubleshooting, I ended up reinstalling retropie and it was still causing it. I finally found out it's Pegasus. ES loads it just fine.

    Error when loading Steam
    (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)

    Steam Link.shcontains:
    #!/bin/bash "/opt/retropie/supplementary/runcommand/" 0 _PORT_ "steamlink" ""
    Here's the full xorg log:

  • @Darksavior

    the retropie-setup script points to the pi2 build

    Ah, forgot about that, thanks. I've just sent the fix to the RetroPie repo.

    (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)

    Will check it out. Should I just install Steam Link from the setup script to reproduce the error?

  • @fluffypillow Yes, it's in the experimental section.

  • @Darksavior The error happens to me outside of Pegasus too, seems to be an X11 permission issue:

    • First, I tried launching Steam from the terminal, but got the same Cannot open /dev/tty0 (Permission denied) error.
    • /dev/tty0 is owned by the tty group, so I added myself to it. Restarting and trying again, I've got a xf86OpenConsole: Cannot open virtual console 2 (Permission denied) error.
    • This seems to be due to a change in recent X11 releases on Stretch. Allowing regular users to launch an X11 session can be done by installing xserver-xorg-legacy. Then I've got an Only console users are allowed to run the X server error (ie. cannot be started by scripts).
    • On Jessie this could have been fixed by dpkg-reconfigure x11-common, but unfortunately that seems to be broken on Stretch. After installing xserver-xorg-legacy, there should be a /etc/X11/Xwrapper.config file, where the allowed_users should be changed to anybody. Trying again, I've got a black screen with a mouse cursor. After loading a while (seems like it downloads itself on the first run), the "Welcome to Steam Link" screen appeared and seemed to work fine.
    • After all this fixing, I've tried again with Pegasus, and launching worked fine from there too. Turns out being in the tty group was no longer necessary, so I've removed myself from there and restarted. Steam Link continued to work.

  • Also a weekly update! Haven't had too much time unfortunately, but finally there is a game file selector for multifile games. There have been some bugfixes too: A bug where multifile games appeared multiple times got fixed, and there was a missing translation on the game directory screen too. With that done, I think I'll finally have some time to update the documentations this week.

    Also there have been several issue reports piling up recently -- don't worry, they weren't forgotten, I'll start reducing them after these changes have been handled.

  • Nice! I think I'll update my collections files now. Thanks!

  • @fluffypillow Yeah, you went with the same steps I went through, but here's some things:
    Steam installs the dependencies it needs and that's all it should be required. ES can load it fine. Doesn't work at the command line or Pegasus.
    Going with the legacy route is a temporary solution because retropie-setup automatically uninstalls it if you go back in it. There is something ES is doing to load it with no problems as-is.

  • @Darksavior after you mentioned that the legacy package gets uninstalled, I've dig into the RetroPie code, and looking around, found some interesting bits of information. And sure enough, looking into the launcher script of ES, this workaround is indeed applied. Luckily there's nothing ES-specific in it, tried the same exports after uninstalling the legacy package and it worked fine for Pegasus as well. If this solves the problem for you too I can send a patch to update the RetroPie script.

  • @fluffypillow Thanks for tracking down the problem. Yes, tty=$(tty)withexport TTY="${tty:8:1}" fixes the problem. I ran those before launching Pegasus and Steam loads fine now.

  • Weekly update!

    • Documentation:
    • General:
      • It is now possible to use environment variables in launch commands. The template is {env.MYVARNAME}, and documented here.
      • Fixed missing short names and logos for certain collections (eg. Steam)
      • There was an idea to support more than one metadata file in the global_collection directory in the future. Thus metafiles would be a more fitting name for this directory, and so this directory name is now also supported for storing a global metadata file.
      • Pegasus will now print a warning if the regular expression of regex or ignore-regex is incorrect in the metadata file
      • Minor performance improvements during loading
    • Default theme: It is now possible again to filter by title
    • ES2 theme: Fixed empty collection space in collection view when a collection has no short name. Also fixed some image loading warnings in such cases.
    • RetroPie
      • The installer will now download the Pi 3 optimized release on Pi 3
      • It is now possible to launch X11 applications
      • Update the Frontend Chooser to match these changes
    • Steam: "Steamworks Common Redistributables" will no longer appear among the games
    • Arch Linux: A community-maintaned package is now available in AUR (thanks @severinkaderli). See the installation instructions here.

    Special thanks to @iwubcode for a number of bug reports and testing.

  • @fluffypillow I may be stupid here, but I've always wanted my Gameboy and Gameboy Color collections to be merged and use the appropriate RetroArch settings from whichever menu they were selected from. Is there a simple way to do this?

    Also, thanks for adding the ability to ignore certain files. That's awesome! I'm going to make my full move over to Pegasus now! :)

  • @fluffypillow I can't load any games with the new version. I used to press A to play a game. Not sure if Enter ever worked on a kb but it doesn't work either. I've tried to delete settings.txt and when that didn't fix anything, I tried to uninstall and reinstall Pegasus. No change. All other buttons work perfectly fine. The settings.txt seems to be fine too. keys.accept: Enter,GamepadA,GamepadStart . So A or start on my pad and enter on my kb doesn't work. I reverted to the last working version I had for now.

    Also, the art reverted to the old style where if even one of them is not the exact size, it resizes them all like art overlapping over each other or making the art really small.

    A new bug as well. Sometimes when scrolling through different systems, the side menu will display a game from another system.

  • @hooperre You can create two collections with the same name but different extension filter and launch command, eg.:

    collection: Game Boy
    extension: gb
    launch: gbemu "{file.path}"
    collection: Game Boy
    extension: gba
    launch: gbaemu "{file.path}"

    @Darksavior thanks, fixed the launching issue and likely the game from different system too. Will take a look on the art size the afternoon.

  • @fluffypillow Thanks. I can launch games again. The steamlink app still doesn't work, though.

  • @Darksavior It's done on the RetroPie side: after updating RetroPie, a launcher script will be created when installing Pegasus, like with ES. It can be launched as /usr/bin/pegasus-fe (or simply pegasus-fe).

    EDIT: script location

  • @fluffypillow Ah ok. I was using the one from supplementary. Didn't know pegasus got updated to just use "pegasus-fe" from the autostart menu. Works now.

  • @Darksavior I have a possible fix but I couldn't properly test it yet; could you try out this as a theme, whether it fixes the resizing issue?

  • @fluffypillow Yep, that fixed the resizing. Thanks. The overlapping issue still exists but that's been around for a long time. If I go back and forth from systems then it fixes itself.

  • @fluffypillow Oh yea, thanks for finally providing a theme I can fool around with. I can now add custom system logos, yay. Though, I do need to resize them a bit. The system logos from ES really slows down Pegasus when scrolling. I'm still testing out what resampling method works best but so far I can't get them to look as good as the Pegasus logos.

  • @fluffypillow Hey I just wanted to say thanks for making your frontend natively compatible with shield/Android TV. I greatly appreciate it. It eliminated having to launch with sideload launcher but unfortunately I'm still plagued by the other two issues I had which were the app not seeing external storage as an option for ROM collections which I can live without but the other being that I'm sent back to my home screen when exiting an emulator as opposed to returning to frontend. Not sure if I can add a parimeter to the collection text file to make it return to frontend or if it's crashing on return due to memory limitations? Other than that through all the changes while in the frontend navigation is fluid and it works very seamlessly with all collections and assets showing and I the revamped grid theme looks really nice and clean. I just wish I could figure out how to return to the front end when I'm done a game. Anyway sorry for the burden and lack of knowledge but keep up the great work imo even in alpha astetica it's my favorite frontend for shield TV aesthetically.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.