Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Announcing Pegasus Frontend



  • @lilbud oh nice, thanks. There's a drag-and-drop kind of layout designer in Qt Creator, but it's so slow on my PC I can't use it. It can help learning the basic layout and item types at the beginning though. I've found the regular text editor in Qt Creator comfortable enough (auto complete, jump to definition, debug tools, ...), but as with XML, you can use any other editor if you want.



  • @fluffypillow sorry to keep bothering you about this, I think I am very close to getting this to work on my Amlogic S905 using Libreelec but I ran into a problem I am not sure why its happening:

    qmake: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/qmake': No such file or directory

    do you have any udea why its trying to use qt4 instead of qt5 to compile ?

    I am sure it has to be something on my system but I cannot figure it out :(



  • @shantigilbert There's probably a different qmake in your $PATH (eg. under /usr/bin/), or you have an old package called qtchooser installed, which tends to set up some weird symlinks (but x64 on an ARM? Wow).

    It's not really a problem though, you can have more than one Qt setup. Just call your own qmake directly (/path/to/my/qmake [params]). Make sure the libs are installed to the location you've set during the Qt build.



  • @fluffypillow I am cross compiling so x64 is not running on ARM, but I compile and installed QT5, I don't think I ever installed QT4 at all, so not sure why its trying to call it in that path.



  • @shantigilbert for some reasonqtchooser is a dependency of some Qt4-based programs on Debian, it might've been installed with your system. But as long as you either you directly call your own qmake or make it so it's the first qmake in your $PATH, compilation should work fine.



  • @fluffypillow Well I finally got it to work someway or the other, now unfortunately when I try to run the FE itself I get this error:

    This application failed to start because it could not find or load the Qt platform plugin "xcb"
    in "".

    Available platform plugins are: linuxfb, minimal, offscreen, vnc.

    Reinstalling the application may fix this problem.
    Aborted (core dumped)

    QT was compiled without xcb (as per your instructions) is there a way to tell pegasus not tu use xcb?



  • @shantigilbert hm it sounds like the embedded graphics plugin (eglfs) is not available; either it has some missing library dependencies, or it was not build. Here's what you can do:

    • Check that [QTDIR]/plugins/platforms/libqeglfs.so does exist
    • If it's there, it was built correctly, but it might have some separate dependencies (I think if it found touchscreen libs during the build, it tries to access them on the device too). Post the output of ldd /path/to/libqeglfs.so, which will tell what it needs exactly.
    • If it's not there, it was not build for some reason -- make sure that sou see EGL detected on the output of the Qt configure script (there should be a backup of that in config.summary). You should see EGL: yes, OpenGL ES 2.0: yes, EGLFS: yes and and EGLFS Mali: yes on the output.


  • I did a recompile making sure eglfs was there, and now this is the error:

    This application failed to start because it could not find or load the Qt platform plugin "xcb"
    in "".

    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc.

    Reinstalling the application may fix this problem.
    Aborted (core dumped)

    when I do ldd libqeglfs.so this is the result:

    /usr/lib/libarmmem.so (0xf74a2000)
    libQt5EglFSDeviceIntegration.so.5 => /usr/local/qt5/lib/libQt5EglFSDeviceIntegration.so.5 (0xf746b000)
    libQt5Gui.so.5 => /usr/local/qt5/lib/libQt5Gui.so.5 (0xf7097000)
    libQt5Core.so.5 => /usr/local/qt5/lib/libQt5Core.so.5 (0xf6bfc000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf6ab7000)
    libc.so.6 => /usr/lib/libc.so.6 (0xf6982000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf68fb000)
    libEGL.so => /usr/lib/libEGL.so (0xf67e2000)
    libpthread.so.0 => /usr/lib/libpthread.so.0 (0xf67ba000)
    libdl.so.2 => /usr/lib/libdl.so.2 (0xf67a5000)
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xf6779000)
    libz.so.1 => /usr/lib/libz.so.1 (0xf6766000)
    libm.so.6 => /usr/lib/libm.so.6 (0xf66e8000)
    librt.so.1 => /usr/lib/librt.so.1 (0xf66d1000)
    /usr/lib/ld-linux-armhf.so.3 (0xab243000)
    libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0xf66b2000)
    

    I made a pastebin of config.sumary

    https://pastebin.com/gXqJZ9Gh

    Thanks for the help!



  • Progress of week 11 (I think?):

    • The gamepad config screen is now functional: https://webmshare.com/QPnKL It's not 100% complete, but it works, so I think I'll check some other features now. The gamepad image is a bit meh, I'll redraw it later.
    • Qt 5.9 is now out, it has performance and memory consumption improvements. I'm experimenting with its build system, trying to find the best build parameters I'd use for a release.


  • @shantigilbert the config seems fine (though I think you'll need GStreamer 1.0 if you want video support), and the EGL plugin has all the dependencies too. Now that it's available, running Pegasus like this: pegasus-fe -platform eglfs should work. Alternatively, seting the QT_QPA_PLATFORM=eglfs env var should work too.



  • @fluffypillow said in Announcing Pegasus Frontend:

    gamepad image is a bit meh

    What happened to the gamepad image that @Rookervik drew?



  • I still have it, but I'd like to avoid looking too close to one specific device (though, per-device images would be possible too).



  • @fluffypillow Hi, I haven't been paying much attention to the forums but someone mentioned your project and it looks nice. I wanted to let you know that it you want to add the ability to scrape from within your app, let me know. I can and have played around with compiling my scraper as a C shared library.

    At one point I had it working in ES but never followed up and got it pushed out. It was also not great since it was hacking around ES's UI, since I didn't know enough to change it.

    I know you probably have higher priority issues to solve but when you get to something like that feel free to reach out to me on github.



  • @sselph Thanks! At the moment Pegasus is still in alpha, so scraper/external program integration is still in the planning stage.

    Ideally, I'd expect a scraper plugin to work and communicate with the frontend asynchronously, using a well defined API for reporting the current state and progress, or to allow cancelling the scraping. This would allow me to create a nice progress bar / scraping progress interface, or send the scraping it to the background while the user can continue playing, etc.

    This would probably require significant changes in most scrapers, so I'd also add a regular "start this program and wait for it to end" kind of launching too.



  • @fluffypillow THANK YOU! after a week of strugglin it FINALLY WORKS!!! it does not have video yet, but thats because I need gstreamer, but at least I can see the FE :D

    there is one small problem, not sure if its related to gstreamer, or if I should update my gamelist.xml. but no images show, I can see all the logos for the systems and names and information of all the games, but no images :( (btw the svg for famicom is missing)

    But I really love how fast it loaded!

    Edit: I should REALLY start reading all of the posts in this thread before asking questions xD



  • Does the alpha actually launch games?



  • @lilbud it does for me, I am using the gamelist.xml from ES and other than what I said about the images, it works perfectly fine.

    edit: but it crashes after a bit.

    Executing command: /usr/bin/retroarch -L /tmp/cores/fbalpha_libretro.so /storage/roms/neogeo/aof.zip
    Process 3145 started
    QProcess: Destroyed while process ("/usr/bin/retroarch") is still running.
    The external program /usr/bin/retroarch has crashed
    The external program has crashed on exit, with exit code 9



  • @fluffypillow I like the idea of asynchronous operation and would be pretty easy to implement from my side, but synchronous may be helpful for manual scraping. When I get some time, I may write up what that API could potentially be.



  • I've collected the weekly status reports and some info links in the first post.



  • @fluffypillow I've compiled the latest version, but I can't seem to get the settings panel to open, I've tried every button on my gamepad and on my keyboard but no luck, how to I open it ??


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.