Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Announcing Pegasus Frontend



  • If anyone was wondering, you can scrape the wheel (logo) pictures with universal xml scraper. Make sure it keeps them as png or they won't be transparent. For some reason it won't scrape some game's logos despite there being one on the ss site.

    The names aren't the same, of course. In a windows command prompt you can just do rename *-image.png *-logo.png



  • @Kqpout I've just tested it on a friend's Win10, worked fine (in the sense that it produced a black screen and empty systems bar, since he didn't have any emulators or ES installed). What kind of problem you get, does it fail to launch?

    Also you can get the latest automatic Windows build from here (choose the flavor=mingw row, then select the ARTIFACTS tab). The builds aren't on the GitHub releases page yet because they run on a different site; hope I can fix this eventually.



  • @fluffypillow Yes, it just does nothing, no error, no window, the process just close after one or two seconds. Launching from a cmd window show nothing.
    It's the same with the latest build, even as administrator or with compatibility.
    Win10 64 bits, 14393.1358



  • So I tried to compile it! And saw the error!

    "Found C:/Users/pophi/.emulationstation/es_systems.cfg
    Required parameter <extension> is missing or empty in a <system> node"

    And indeed one of my systems didn't have <extension>.

    Now it works :)

    But maybe it should run anyway or display an error message ?



  • Yeah, error reporting on the UI is not yet done :)



  • @fluffypillow Will we be allowed to resize the boxart rows in the future? I believe that will fix the look of the arcade sections using flyers for boxart. 3 rows should make the flyers legible.



  • @Darksavior at the moment the number of items per row is fixed (in the theme), with "hardcoded" overrides for certain systems. I certainly want to change that, but not sure what'd be the best way for that.



  • Week 17:

    • external scripting support has landed
    • a bunch of documentation fixes and source code improvements
      • added links to the latest Linux/Windows builds in the README
      • better organization of the files in the Windows package
      • developers: added a list of packages and PPAs you can use on (desktop) Ubuntu to the Build guide to easily build Pegasus (no need to compile or install Qt manually)
    • created a RetroPie script, on review at the moment


  • @fluffypillow Bug in pegasus-fe_alpha2-47-g3fee22f_rpi2-static.zip.
    If you scroll down your games, eventually they'll all disappear. Then it's unusable. Can't even see the text either. The last build I tried was #31 i think..



  • I can also reproduce @Darksavior 's bug, but only with a keyboard. I can't scroll fast enough with a controller for it to occur. I need to hold down the down arrow key on a keyboard to make it happen. Don't really see any errors at the command line but: this one: glGetGerror 0x505, not sure it's related though. If you scroll back up, previously loaded images disappear and will fail to load.

    0_1500445449367_IMAG1161.jpg



  • @retrolang Yes, I managed to exit pegasus with the distorted image to see the same error. I did use a keyboard to scroll since pegasus won't use my dpad to control the menu, but it does SEE the dpad as an analog stick for some reason..



  • I can also confirm the bug on Pi 3 + keyboard (though it also freezes for me sometimes). The bug appears somewhere between #39 and #45; I'm trying to find out which commit exactly. It seems something causes Pegasus to go out of memory (that's the OpenGL error 0x505).



  • @fluffypillow That's video/texture memory. You're trying to load textures but the GPU memory is not available.

    You can check by running

    sudo vcdbg reloc
    

    When that happens.

    You may want to implement something similar to ES Video RAM's texture cycling - but addressing the current implementation's shortcomings :)

    Happy to chat if it'd help.



  • @pjft GPU memory and textures are handled by the Qt library -- which I've recently updated on the build server to 5.9.1. It's supposed to be a minor maintenance/bugfix release to 5.9, but as it turned out it was the cause of the bug. So for now I'll revert to 5.9, and try to report the bug to the Qt devs.



  • Here's another weekly changelog:

    • added file logging
      • log file is saved to CONFIGDIR/lastrun.log, where CONFIGDIR is ~/.config/pegasus-frontend on Linux and C:\Users\<UserName>\AppData\Roaming\pegasus-frontend OR C:\Users\<UserName>\AppData\Local\pegasus-frontend on Windows
    • added external theme support
      • TODO: add documentation
    • new experimental Qt 5.9 build
      • libinput is no longer required
      • fixed missing libpng error on Ubuntu 17.04


  • You should totally make a netflix style theme with this...

    Basically using Box art but scrolling horizontal.

    When you hover over the game, on top right it shows video [like netflix] top left it shows the wheel [like netflix showing movie logo] with description underneath and rating under that.

    Then if you press the down button on controller, you can browse the next system like netflix. for example

    [ - - - - - - - - - - - -- - - - - -- - - - - - - - - -- - - - - - - -- - - - - - - -- - - - - - - - - - - - - - - - - - - - -- - - - - - - - - - -- - - - -- - - - -- - - - -- ]

        GAME MARQUEE HERE      
    
      GAME DESCRIPTION HERE                                      GAME VIDEO PREVIEW HERE        
      
        GAME Rating Here
    
    
    
               SYSTEM CATEGORY HERE [NES]
      •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• 
    
               SYSTEM CATEGORY [SNES]
      •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• 
    
               SYSTEM CATEGORY [ARCADE]
      •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• •Boxart• 
    
    
                etc etc etc
    

    [ - - - - - - - - - - - -- - - - - -- - - - - - - - - -- - - - - - - -- - - - - - - -- - - - - - - - - - - - - - - - - - - - -- - - - - - - - - - -- - - - -- ]



  • Minor bug that's existed for a while, maybe since it's creation. The keyboard stops working when going to retropie-setup or any of those type of menus like adjusting the alsamixer.

    The only reason I bring this up now is that a recent update to retropie, maybe .10 or .11, something changed that made my snes pad buttons to stop working in those menus. The dpad works in those menus. No issues in all emulators, ES, Pegasus (not the dpad though, since it sees dpad as analog sticks for some reason, but I'm hoping to be able to have the ability to remap in the future). I believe this to be an isolated problem with the gamecon driver and retropie only, not Pegasus. (update, problem fixed)

    With Pegasus or ES, Usb pads work in retropie-setup menu and alsamixer, but it won't allow me to exit the mixer menu. That's limited to ESC on kb, which doesn't work if launched from Pegasus.

    So if I want to update retropie or go to any of those menus with kb only, I must exit pegasus, boot to ES, then keyboard works.



  • @fluffypillow said in Announcing Pegasus Frontend:

    • gamelist reading and asset finding speed optimizations: currently loading ~1000 games, all with videos, box front, screenshot and logo takes less than 2 seconds on a Pi 3, and less than 10 seconds on a first gen Pi 1; these numbers may improve later

    Wow. Just freaking wow. That is amazing!



  • @pokeengineer You're late, we already did our reactions.



  • @PokeEngineer You are about 3 months late on reactions.

    alt text


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.