Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retro Pie 4.2 PSX "Bios not found"



  • @pjft

    The only reason I can think of as to why the bios folder is not there is because I had to move everything to a new SD card as I ran out of space on the old one and maybe as it was moving everything for some reason it skipped on the bios folder.



  • @Skull-Knight Yeah, that could have been it then. I'd hope (unconfirmed) that if you go to the RetroPie-Setup script and update/install all packages again, the folder will be created... maybe?

    Try it with the PSX emulator, see if it creates it. But yes, you can create it yourself - and, as long as you don't run into problems with other emulators, I suppose you'll be fine-ish. But yeah, if any emulator doesn't behave as expected, I'd suggest it could be related to that.



  • @pjft

    Ok I just looked back in the file manager and have found that the BIOS folder has reappeared inside the folder is

    /fba
    /mame2003
    /palettes
    *NstDatabase.xml
    fast.bin
    skip.bin
    system.bin

    I have no idea how the folder came back or if it was there all along and I was dumb enough not to see it but it still does not explain why the psx bios wont work.



  • @Skull-Knight Well, it does, right?

    I don't see any PSX Bios file in it :)



  • Ohhhhh that explains it how do I create a psx bios folder?



  • @Skull-Knight You'll need to get the proper PSX Bios file and copy it there.

    Where or how to get it is outside the scope of this forum, but they should reasonably easy to find using most search engines.

    Follow the guidelines from this thread, or the wiki, on what file names to look for.

    That being said, some PSX games will not run anyway, regardless of the BIOS file, so bear that in mind. PCSX-Rearmed doesn't support every single game, so if the BIOS warning stops showing up but the game you're trying to run doesn't work, either try to get it from a few different sources to see if it's a dump thing, or if it's just a compatibility thing.

    Best of luck.



  • What format do they have to be put into the BIOS folder as?
    in a zip file,on their own,ETC



  • @Skull-Knight On their own. As described in the wiki page.

    It should be something like scph<something>.bin, I believe, but the wiki is pretty much accurate.



  • @pjft

    I have fixed the problem It turns out that upon plugging my usb back in that the BIOS were just not copying to the BIOS folder so in the file manager I copied them manually and that solved the problem.

    Thank you for helping me



  • @pjft can you tell me some of the u.s. roms that dont work?



  • @edmaul69 hmm. I don't know any US specific ROMS that don't work - and sorry if I sounded more like an expert in the subject than I really wanted to.

    I know that ISS2000 does not run on the emulator, and I believe that in the emulator's GitHub page there are a few bugs filed on some games, so that's kind of what I meant by "not all games work". I didn't mean to suggest that there were a lot of them, sorry:)

    Any particular game you'd be looking for, though?



  • @pjft no i was just curious and wanted to test them. Yes, iss 2000 doesnt work. No matter what i tried. Im curious as to why some euro games dont work. But luckily i dont use pal roms so not an issue for me.



  • @edmaul69 yeah. The Japanese version of the game didn't work either.

    There's not much on the "official" compatibility list:

    https://wiki.libretro.com/index.php?title=PlayStation_Core_Compatibility#PCSX-ReARMed

    There's a list of issues on the original emulator:

    https://wiki.libretro.com/index.php?title=PlayStation_Core_Compatibility#PCSX-ReARMed

    And some on the libretro repository, which is the one we use:

    https://github.com/libretro/pcsx_rearmed/issues?q=is%3Aopen+is%3Aissue

    Maybe you can get some pointers in those lists as to what to experiment?

    Hope it helps!


  • Banned

    @pjft Fu*k compatibility lists... I can't understand why anyone would try and maintain something like that. Try it, does it work?



  • Hi, I had the "BIOS not found" problem, too.
    I stumbled on this and other threads with suggestions, but nothing worked.
    I used a BIOS file, which worked at other emulators before. It was the SCPH1001.BIN BIOS. I checked, that it was correct named, checked the md5 checksum, checked file/folder permisions... everything was correct.

    My solution was:
    Go to Retroarch menu (I did it ingame)
    Go to Settings->Directory->System/BIOS
    Select Folder /home/pi/Retropie/BIOS/<Use this directory> ... (or whatever folder you use)
    Still in the Retroarch menu navigate to MainMenu->Configurations and select "Save Current Configuration"
    Now the BIOS is found and for example GTA2 European Edition works, it didn't before.
    Hope that helps :)



  • @milok No need to do that since the default is already at /home/pi/Retropie/BIOS/.
    I guess it's good info for people that mess around with the settings or use modified retropie builds.



  • @Darksavior
    "I guess it's good info for people that mess around with the settings or use modified retropie builds."

    Yes, maybe I messed the settings up somehow and didn't notice it. Maybe not...
    It could have been by copying some folders from an older Retropie system to my current system. At least thats the only thing, I remember, that could have caused that for me... I just didn't expect that this could have been my problem.



  • @milok great! it worked! many thanks!



  • @milok said in Retro Pie 4.2 PSX "Bios not found":

    /home/pi/Retropie/BIOS/

    Just for information, if the .cue file is missing for a game, the game won't show up in retropie.
    To fix that, you can create a .cue file by copying an existing one and editing it with notepad (and renaming it ofc).

    Hope that might help anyone.



  • @skull-knight I had the same "Bios not found" problem, and fixed it by copying the SCPH1001.BIN file into /home/pi/RetroPie/roms/psx (i.e. the same directory where the ROMs are stored).



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.