Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SegaCD emulator cannot find BIOS Directory



  • I was having trouble getting the SegaCD emulators to work, and what it boiled down to was the following entry in /opt/retropie/configs/all/retroarch.cfg:

    system_directory = "default"

    Whenever I tried to launch a SegaCD title in verbose mode, I got the following in the log:

    RetroArch [WARN] :: SYSTEM DIR is empty
    ...
    RetroArch [libretro ERROR] :: Missing BIOS

    Now, I was able to fix it by changing the value of system_directory to "/home/pi/RetroPie/BIOS", but I'm wondering why it doesn't have the correct path in the first place?

    UPDATE: Ok, I put everything back how it was and tried again... the verbose log output said this:

    RetroArch [INFO] :: Environ SYSTEM_DIRECTORY: "/home/pi/RetroPie/roms/segacd/".

    I'm not sure how I had previously get "SYSTEM DIR is empty", but it seems that the latest version of Picodrive is expecting the BIOS files to be in the same directory as the roms.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.