splashscreen.sh "enable/disable" wording
-
Yes, seems confusing. How about
Show splashscreen on boot (Enabled)
vs
Show splashscreen on boot (Disabled)
-
@mitu ah, I just put this in a minute ago. I had also considered that but figured this was less change from the original (only changing "disable" to say "enable" vs. changing both of them to say "show"), but I can change it if you want.
-
@sleve_mcdichael You change doesn't reflect the re-wording you had in mind.
-
@mitu said in splashscreen.sh "enable/disable" wording:
@sleve_mcdichael You change doesn't reflect the re-wording you had in mind.
What do you mean?
-
@sleve_mcdichael said in splashscreen.sh "enable/disable" wording:
What do you mean?
I thought it was missing Enable splashscreen on boot (disabled) when disabled, but it was already there.
Seems to be ok, but I'd rather not repeat Enabled and use Show splashcreen.
-
@mitu yeah I'm good with "show splashscreen." How about for the randomizer? "Show randomizer" doesn't really fit; how about "toggle"? (Edit: or "use"?)
-
@sleve_mcdichael said in splashscreen.sh "enable/disable" wording:
"Show randomizer" doesn't really fit; how about "toggle"? (Edit: or "use"?)
Randomize image order or Shuffle images ?
-
@mitu I had a few more ideas which turned out to be relatively easy to implement. What do you think of this:
edit: https://github.com/s1eve-mcdichae1/RetroPie-Setup/commit/7620baa1dcd8226f2998f60c509284f2cb60e892
-
@sleve_mcdichael said in splashscreen.sh "enable/disable" wording:
What do you think of this:
I'd rather have the UI code stay the
gui_
function instead of splitting it into separate functions - the actions behind the menu options are simple enough to be added inline in the menu'scase
handler so that are easy to follow. -
@mitu said in splashscreen.sh "enable/disable" wording:
I'd rather have the UI code stay the
gui_
function instead of splitting it into separate functionsThe
randomize_
code was already largely a separate function; I suppose that could all be rolled intogui_
as well, but in either case I feel it's more intuitive to have "disable randomizer" merely as one of the options instead of a separate action that's invoked automatically when it's enabled; for instance it makes changing the source easier, as you no longer have to disable first & then scroll back down & re-enable to change your selection, just enter the menu once and make a different choice.I rolled the other UI stuff back into
gui_
though: -
The randomizer change is ok, but the separate sub-menu for enable/disable is redundant - just clicking on the entry should toggle it, like most menus in RetroPie-Setup.
-
@mitu said in splashscreen.sh "enable/disable" wording:
The randomizer change is ok, but the separate sub-menu for enable/disable is redundant - just clicking on the entry should toggle it, like most menus in RetroPie-Setup.
Yeah okay. This had felt clunky to me as a toggle (which is why I changed it to a choice, initially), but I think that by adding "currently:" to the descriptor (á la runcommand configuration) it feels fine now, as a toggle still:
https://github.com/RetroPie/RetroPie-Setup/compare/master...s1eve-mcdichae1:splashscreen-three
-
@sleve_mcdichael Looks good !
Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.
Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.