@moltke44 I think you've been bitten by this change in Win10 which disables the guest browsing of shares, specifically for Enterprise and Educational versions of the OS. That's why for me (Win 10 Professional) still works, but not for you. You can try the workaround described here, which I wouldn't recommend, especially if your computer is domain managed and there are security policies in place. Another option is to disable guest access in the RetroPie file sharing service (Samba), but that's a little more involved and it's not so straightforward.