Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Continued absence of \\RETROPIE via desktop, ping replies fine.



  • Pi Model or other hardware: (3)
    Power Supply used: (CanaKit 2.5A USB Power Supply)
    RetroPie Version Used (4.4 Stretch):
    Built From: (Fresh SD Image on RetroPie website)
    USB Devices connected: None
    Controller used: PS3
    Desktop OS: Windows 10

    Just updated pi to Stretch on fresh image, been moving roms via winSCP but I prefer to move files via the SAMBA shares between my desktop and my pi. Frustratingly I can't see or access \\RETROPIE from the desktop or typing the direct IP. I've battled this for a while, found numerous people with same issues but none of the solutions available seem to help me. I have a pretty normal network setup, i.e. desktop, pi, both connected to single router. I have enabled SSH and SAMBA from the pie, and can connect and browse the pi with winSCP just fine. I can ping the pi with reply from the desktop also. I plugged in a hardwire connection and see IPs for both the wifi and Ethernet wire on the pi, and again can use that in winSCP fine. I have enabled windows discovery options as suggested as well. From my router app's network map, I also see it there. I've rebooted the pi, router, desktop multiple times as some have mentioned that plays a part. All that seems to result is in the IP changes. Welcome all suggestions ... something so simple I don't get it. Thanks,
    

    Edit: On a side note, where on previous pi image I used the universal XML scrapper without issue ... with this image the autoconfig default settings also isn't able to see the roms or access the pi either.



  • @moltke44 What version/release of Windows 10 do you have installed ? Home/Professional/Enterprise - 1803, 1809, etc. ?



  • Thanks mitu, my version of W10 is 1803 Educational license.



  • @moltke44 I think you've been bitten by this change in Win10 which disables the guest browsing of shares, specifically for Enterprise and Educational versions of the OS. That's why for me (Win 10 Professional) still works, but not for you.
    You can try the workaround described here, which I wouldn't recommend, especially if your computer is domain managed and there are security policies in place. Another option is to disable guest access in the RetroPie file sharing service (Samba), but that's a little more involved and it's not so straightforward.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.