Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie keeps freezing during 8bitdo SFC30 bluetooth pairing



  • Pi Model or other hardware: (Pi 3)
    Power Supply used: (Cana Kit 2.5A)
    RetroPie Version Used (4.2.3):
    Built From: pre-made image from retropie site for Raspberry Pi 3
    USB Devices connected: USB Keyboard
    Controller used: 8bitdo SFC30 (Firmware 3.0)
    Error messages received: [See attached pics]
    Guide used: https://github.com/RetroPie/RetroPie-Setup/wiki/8bitdo-Controller
    File: (File with issue - with FULL path) --> unsure?
    Emulator: (N/A)

    How to replicate the problem:

    1. Follow normal bluetooth setup for SFC30 in retropi (turn off mapping hack first)
    2. Put device in pairing mode
    3. Search for device in retropie menu
    4. Select "8Bitdo SFC30 Gamepad" in list of available devices
    5. Select "DisplayYesNo"
    6. Device freezes and shows error output in pic

    Note: I have repeatedly removed the device and tried again but with the same result each time. Everything else works fine with the retropie. I can use this same controller when connected via USB. I don't know what else to do. Any thoughts would be appreciated.

    Once I select this option, it freezes and displays the text below:
    0_1494117125007_IMG_20170506_113407.jpg

    This text appears immediately below the prompt above.
    0_1494117137196_IMG_20170506_113413.jpg !



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.