Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retroarch not letting me map certain buttons



  • I have just built my first arcade cabinet and just starting mapping the buttons in retro arch but when I try and map Y and the start button for player one it doesn't save it. I hit A on my keyboard to get it ready to bind to a key, but when I hit that key it just says (key: ) instead of the number for the button. I at a loss here. I have tried reinstalling all of retro pie and that did nothing.
    Raspberry Pi 3
    Retro Pi 4.2
    USB keyboard
    Arcade controls



  • Hi,

    There isn't enough information in your post, we need a few more details before we can provide help:

    First try following the template in https://retropie.org.uk/forum/topic/3/read-this-first

    Then a few more questions:

    Also, what controller or interface are you trying to map?
    How is it attached to the Pi (USB or gpio)?
    Does the controller map in Emulation Station?
    If the controller maps in Emulation Station, is the controller not working in RetroArch at all?
    Which RetroArch emulators are you trying with?

    Hopefully once we have this information, we will be able to point you in the right direction.



  • It is plugged in with a USB. retroarch sees the controller as a RetroPad. The controller maps in emulation station just fine. I'm using RetroArch 1.5.0
    I'm new to this form and raspberry Pi's so if there is anything else I need to say let me know. Thanks



  • @sadkiwi Just some tips, if your question involves something that isn't working, explain it as accuratly as you can, and explain how it is connected/related to the pi. Also sometimes add the code you are using for some projects.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.