Zaxxon audio



  • How do I get Zaxxon to play audio. It uses samples which I loaded in the sample folder. Still won't play audio.



  • @stevep Which MAME? at the very least, go on, give us a clue. Or is it even MAME, I bet Zaxxon was released on about 40 platforms... I assumed MAME because you mentioned samples.



  • Every mame available on the pi including all versions of advmame.



  • @stevep Ha! Yeah, I have just tried it myself and I can't get a peep of sound out of any of the ROMs on any of the MAMEs. None that I use, anyway. Sorry.



  • It doesn't see the sample file for whatever reason.



  • @stevep doesn't seem to in any of the versions I tried. I just made the peow-peow sounds myself and it was great! Until I had to make the my ship exploding sound



  • I have Sound in Zaxxon, but had to switch "demo sounds" on in the DIP-switches for some reason.
    Before doing that samples were silent.
    (using AdvanceMame 3.4)



  • @sirhenrythe5th I looked in the dip switches but that didn't occur to me. I'll look later when I get a chance. Thanks.



  • @AlexMurphy i also outsourced the samples-folder to hide it in the ES-Gamelist.
    But i recognized that at least AdvanceMame changed the path of some things (highscores i.e.) in the latest releases from /opt/pi/configurations/advancemame to /home/retropie/roms/advmame.

    Maybe the path of samples has changed too, have you tried other roms with samples-support as donkey kong or mario to get sure samples still work in general?



  • @sirhenrythe5th I'll fully test it later. I know something is up with my advmame samples anyway. I have 2 directories. Sample and samples, so need to figure that out. Will probably just try one then the other then both just to be sure.



  • @stevep for lr-mame2003 samples go here:
    /home/pi/RetroPie/BIOS/mame2003/samples/
    Provided they are the right samples. They need to be the ones from the older .78 romset, as newer samples are different.

    AdvMAME samples go wherever the path is pointing in the .rc file. I configured mine to go in the BIOS folder similar to 2003. Of course, these too have to be from the correct romset and are probably different than the ones for mame2003.

    Both versions of MAME work though. I have Zaxxon samples working and a bunch of others, like the Galaga explosion and Marios footsteps.



  • Regarding advmame.....How do I edit the config file in retropie so to as to check the paths pointing to the correct folders?



  • @stevep open the terminal, point to the path of the config-file and open it with the "sudo nano" command.
    After you finished the editing of paths etc press Ctrl + x to leave the editor.
    You then will also be asked if you want to save the changes.



  • Regarding advmame
    Still can't get it to work.other games like Donkey Kong use samples as well. I'm using my pc to edit the .rc files through my home network. Can anyone give me the command line I need to let the emulator see the samples? Also ..I'm putting the roms in the rom folder. Is that correct because the emus that come with retropi don't seem to have a rom directory. Sorry...still trying to wrap my brain aroun this....



  • @stevep Assuming you have installed advmame (which you can do via the RetroPie configuration screens if you need to), you should have a directory for roms for this emulator:
    /home/pi/RetroPie/roms/mame-advmame

    You need to put your advmame roms in that directory, restart Emulation Station and you should be able to launch them from a MAME system that appears. I don't know which version of Advmame is the default, but you can pick that using the runcommand feature at launch. For the sake of argument, let's say you are using Advmame 1.4.

    So, make sure your roms are from a .106 romset. but crucially, that your samples are ALSO for this set. Samples are not universal. They have evolved, so you need to use the right version of samples for the romset.

    Next, open the .rc file. Again, for the sake of argument, for advmame1.4:
    /opt/retropie/configs/mame-advancemame/advmame-1.4.rc

    Look for the following line:
    sound_samples yes
    Make sure this says yes

    Then, look for:
    dir_sample SAMPLEDIRECTORYPATH

    Wherever that SAMPLEDIRECTORYPATH setting is pointed, that is where you must place your sample files. Each sample should be a zip file that corresponds to the name of the ROM for which is used.

    Save the .rc file, launch your game (again, using advmame1.4 in our example) and you should have samples working.

    If you don't:

    1. You put samples in the wrong location. See above.
    2. Your sample is the wrong format/wrong ROMset version.
    3. You don't have samples enabled. See above.
    4. Something isn't named properly (wrong directory name in your path, like 'samples' when maybe it should be 'sample', or the zip name doesn't match.

    Verify all of this detail, and if it still fails, describe EXACTLY what you are doing, where things are located, what your config looks like, what version of advmame you are using, what your rom files are called, your sample file, and we should be able to get it figured out.

    Most of the trouble I have had with this was because of two things: Either my samples were the wrong versions, or I had them in the wrong folder.



  • @caver01 Yeah, cheers mate, just getting a chance to look at this again. Samples are now working for Zaxxon & Jackson (bootleg) in advMame 3.4. Still can't get any sound out of libretro 2003 but that's good enough for me. Thanks again.



  • @AlexMurphy I have samples working in both. If you want to compare folders and/or file sizes, let me know.



  • @caver01 Thanks for the offer. I have this 710 KB (727,146 bytes) and there are 12 .wav files inside. It's named correctly zaxxon.zip and it's in ...BIOS/mame2003/samples/ It's from the 0.78 set. Samples is set to ONCan't figure out the issue at all.



  • @AlexMurphy Ok I will check my setup when I get home in a bit.



  • @AlexMurphy

    zaxxon.zip:
    727,146 bytes

    2048 -rwxrwxrwx  1 randy  staff   30014 Dec 24  1996 00.wav
    2048 -rwxrwxrwx  1 randy  staff   17842 Dec 24  1996 01.wav
    2048 -rwxrwxrwx  1 randy  staff   63640 Dec 24  1996 02.wav
    2048 -rwxrwxrwx  1 randy  staff   40464 Dec 24  1996 03.wav
    2048 -rwxrwxrwx  1 randy  staff   66338 Dec 24  1996 04.wav
    2048 -rwxrwxrwx  1 randy  staff   56082 Dec 24  1996 05.wav
    2048 -rwxrwxrwx  1 randy  staff  104736 Dec 24  1996 08.wav
    2048 -rwxrwxrwx  1 randy  staff  169014 Dec 24  1996 10.wav
    2048 -rwxrwxrwx  1 randy  staff  154188 Dec 24  1996 11.wav
    2048 -rwxrwxrwx  1 randy  staff    4172 Dec 24  1996 20.wav
    2048 -rwxrwxrwx  1 randy  staff    6898 Dec 24  1996 21.wav
    2048 -rwxrwxrwx  1 randy  staff   87022 Dec 24  1996 23.wav
    

    We definitely have different samples,<edit> I don't know why I thought they were different! </edit> I wonder if the ones in the set are correct. What I am showing you here works. I just tested, and I have audio. Perhaps these are from an older set? Worth trying I guess.


Log in to reply
 

Looks like your connection to RetroPie Forum was lost, please wait while we try to reconnect.