Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • My memory split was already set to the default of 256M. I am not overclocked.

    First things first, I updated the Retropie Setup Script and updated everything from binary before I started. I also uninstalled and reinstalled the theme I was using, even though it had been happening on other themes as well.

    I SSH'd in and ran the commands, fresh off of a system reboot. Here are the results of both: free -h, sudo vcdbg reloc

    https://pastebin.com/zRfS6Vf8

    I was using this setup in the past and had no problems.

    Another new problem I've run into is sometimes when scrolling between systems, it'll get stuck and stutter back and forth very quickly. This problem is much more rare though. The main issue happens every time. I will try and get a video of that as well.


  • @LiveFastCyYoung so, two things jump straight to me when reading those logs. The first is that you have no GPU memory available from just loading EmulationStation - you see the first few lines saying largest few block 352 bytes! If you want a quick, patchy fix, reduce the VRAM to 50, restart EmulationStation, and see if it works or not, and then if it loads the theme successfully and you still have problems, try reducing slowly, restarting again and see how it goes. You will get to a point where the theme won't load at all because you are allowing to little memory for it, but until you get there see what works.

    The second thing, and a more obvious observation, is that you do not have the right memory split. You can tell that easily from looking at the log for the free command. It states total memory is 858, which means that you have around 160mb allocated to the GPU, give or take (1024 - 858 - 16 MB of potentially reserved memory, unless you have tweaked your config file).

    Maybe the update messed up that setting or something, but I'd strongly recommend setting the split again, and confirming that the free command shows something closer to 768 total memory. If you struggle with this, do send over your config.txt file via pastebin.

    The third recommendation is also to try a lighter theme - namely Carbon - on top of all of this.

    Hope these help, let us know your findings.


  • @pjft I'm very confused with the memory split issue. My config.txt in the boot folder is the following...

    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    overscan_scale=1


  • @LiveFastCyYoung can you send over the full contents, so we see if there's anything overriding it per chance?

    Thanks.


  • @pjft The full contents of /boot/config.txt?

    That is the full content. There are no other lines in the file.


  • @LiveFastCyYoung ....Oh. That's, err, weird?

    Anyway, try explicitly adding

    gpu_mem=256

    To it. Then restart and see what free returns.


  • @pjft After adding that line to the config file...

    https://pastebin.com/NZHULBM5


  • @LiveFastCyYoung still the same, interesting. I don't know enough about BerryBoot, I suppose we need to look into it.

    What if you make it 512 and run it again?


  • @pjft

    So I ended up solving this and it was completely stupid on my part.

    The memory split was absolutely messed up. I have been having memory problems for quite sometime and it's caused more than this issue: https://retropie.org.uk/forum/topic/10467/solved-error-updating-es-from-source

    So, as I said, everything is on the PiDrive for this build. HOWEVER, it is Berryboot and does boot from the SD card. So this whole time, I have been updating the /boot/config.txt on the PiDrive but I should have been updating the config.txt on the SD card. It's the only thing the SD card is used for. The booting up process.

    So that config.txt file had gpu_mem=16. OBVIOUSLY an issue. I switched that one to 256 and it's running great now. I haven't tried but I'd imagine I could update ES from source now too.

    Why this happened? Who knows. But I think it'd be smart to put a reminder in a guide somewhere to look for the config.txt on the SD card as opposed to the hard drive.

    Thanks everyone for their help! :)


  • @LiveFastCyYoung Glad to hear that was sorted. 160 - or 16 - would have certainly been a problem.

    I doubt that would have impacted ES from source, though, as this is just about GPU memory, but I don't know much - maybe you have other things there that are impacting the overall memory.

    Glad this is sorted now.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.