Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie is not full screen on my display. I have tried almost every conventional method, but nothing works.



  • I just recently got a Raspberry Pi 3 and I was excited when I discovered RetroPie. I got it working fine on my HD flatscreen TV, but when I decided to hook up my Raspberry Pi to my 5" Elecrow HDMI LCD Display, the picture did not fill the entire screen. There was a thick black bar on the right side of the screen. I have tried everything I've seen people say on the internet to change it. I've tried 'sudo nano /boot/config.txt' and tried changing multiple things in there. I've tried going through the configuration editor in RetroPie. I have also tried 'sudo raspi-config. None of these have worked. The screen is still not fully taken up. Also, the color is really weird. The joystick logo for RetroPie is kind of a blue or green color rather than red on the display. Any help would be great. Thanks.



  • First of all , is this happening in the games or the entire thing?



  • @itsnitro It is happening in the entire thing.



  • Alright, so I'm guessing your LCD is 16:9 and the resolution you're getting is 4:3.
    Maybe change that in the config editor.



  • @itsnitro Correct, the display is 16:9, but is outputting 4:3. I have already tried changing it in the configuration editor, and when I change it to 16:9, it does not fit on the screen. I only see about the top 1/4 of the image that is being displayed.



  • Hmm, this is going to be a tough cookie to crack.



  • @itsnitro Please contact me if you find anything that might work. Thank you for your effort thus far!



  • Update: I managed to cut the bar on the side of the screen about in half by forcing the resolution from my TV to my 5" display. This is the closest I've gotten to normal, but it still is not perfect. I will continue trying, but without help from people who know what they're doing more than I do, I won't be able to do much else. Also, the color has not changed. It still seems almost as if it is not being supplied with enough power, but I am using the supplied power cord for power, so that should not be what is causing it. I am at a loss of what to do next, so any help would be greatly appreciated.



  • Another update: So I was messing around with the resolution and switching the hdmi cable from my TV to my display, and after about 10 or 20 minutes of switching back and forth trying to find a resolution that would work, my 5" Elecrow LCD Display, completely out of the blue, stopped working and displayed a white screen. I tried a different hdmi cable, I tried a different power source... Still a blank white screen. So I guess I don't need to fix the resolution anymore... I'll just have to get a completely new display or just forget about this whole thing and continue using my TV. Thanks @itsnitro for your attempt to help me, but I won't be needing anymore help. -Greg



  • Sorry that happened.

    This is actually addressed in the wiki, and if you're TV didn't have a setting to make the screen without the borders, it's easily solved by disabling overscan on the Pi system config.

    Let us know how it goes.



  • Alright, I'm back. With a new screen. It is still doing the exact same thing and I cannot get the screen to be normal with any methods that normally work. So, I guess the problem is still the same...



  • @Greg137 Ok.

    So this time, before messing up the screen :)

    sudo nano /boot/config.txt
    

    and uncomment the #disable_overscan=1 line (i.e. remove the "#" at the beginning of the line).

    Also, make sure there's a line stating overscan_scale=1.

    Then reboot.



  • @pjft I did exactly what you said, and it did not seem to do anything...



  • @Greg137 interesting. Can you paste the content of your /boot/config.txt file on pastebin and send it over for me to take a look? Maybe I missed something.



  • @pjft I'm not entirely sure how to do that. Could please explain how?



  • @Greg137 sure.

    cat /boot/config.txt
    

    Send over the contents. You can either copy and paste to a site like pastebin.com or take a picture if you can't copy and paste (though the picture will be harder to read).

    Whatever works :)



  • @pjft I'm still not sure how to go about copying and pasting... I cannot select text. And if I was able to, how would I be able to paste it to anywhere through RetroPie?



  • @Greg137 correct. The copying and pasting would only take place if over SSH which I take you're not using.

    You might be better off, then, doing

    nano /boot/config.txt
    

    And taking screenshots of the several pages.



  • This post is deleted!


  • @pjft I cannot upload a picture to the forum apparently.. So is there any other way to do this? I suppose I could just go through and type everything...



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.