Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie is not full screen on my display. I have tried almost every conventional method, but nothing works.



  • @pjft I cannot upload a picture to the forum apparently.. So is there any other way to do this? I suppose I could just go through and type everything...



  • @Greg137 there's a size limit. Either reduce the pictures on your computer (I think the maximum size is 1MB or 2MB?) Or upload them somewhere (imgur? Dropbox? Google drive?) And share the link.

    I'll look into them tomorrow. It's late here, sorry.

    Thanks.



  • @pjft Okay. I'll try a few things and post tomorrow sometime. Thanks for your help!



  • @Greg137 Not a bother.

    I suppose there are two options:

    One is to confirm that you do have disable_overscan=1 on the file (without the # sign).

    If that is there but you're still not seeing a difference, then my next suggestion is to do something like what I was suggesting here:

    https://retropie.org.uk/forum/post/86146

    1. Re-add the # to the beginning of the disable_overscan=1 line, and make sure you have overscan_scale = 1 there.
    2. Play with those values - overscan_left, overscan_right, overscan_top and overscan_bottom. Start with a single one, and make it big so you can see a difference - maybe 200 or 400 (I don't know the resolution of your screen).

    After you confirm it is making any change, then adjust the value as needed - it can even be negative if necessary. Start with a single margin, and then work your way to the others.

    Hope this works.

    You'll need to reset your Pi on each attempt.

    Remember to exit and save the config file at each attempt, though, by pressing Ctrl+X and then stating "yes".

    Best.



  • @pjft Alright, I will try that, thanks. And here is the link to the photos I took of my config file: https://drive.google.com/drive/folders/0B0uymgAR8TjMNlFpamxLYkt4VjQ

    I will grant you access as soon as I can.



  • @Greg137 Sounds good - please do so. You can erase them and revoke the access shortly after, it's just for me to take a look at the pics and see if anything stands out as off.

    Still, the guidance I'll give will be fairly similar to the one in the previous post, but keen on seeing how the file is looking. :)



  • @pjft Your last suggestion seems to be working. I changed the resolution to a setting that was too big for my screen and just changed the numbers to make it smaller. I'll just have to adjust the numbers a bit to get how I want it. Thank you so much for your help!

    -Greg



  • @Greg137 Great. Glad to hear that sorted things. Do keep the overscan_scale=1 line there, otherwise there may be some unexpected differences between console and applications.

    Welcome to the community and looking forward to seeing what you come up with!



  • @pjft Hey any chance you have the exact numbers you used? Thanks man having the same problem here able to find nothing helpful on it



  • @jabbafeet I don't expect other people's numbers to be useful for other cases, as different TV sets have different requirements. I'd encourage you to follow the steps mentioned in the previous posts and understand what ranges work for you in the end. In one monitor I have I don't need these, in another one I end up needing negative values for some reason.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.