Please do not post a support request without first reading and following the advice in

"Illegal Instruction" on previously working RP

  • Hi all,

    I'll start by saying that I tried my darnedest to search the forums for an existing post with this issue. It appears that people typically see this error when they first configure their RetroPie, usually due to the incorrect image being loaded, but that isn't my issue (I don't think)

    I was able to correctly get everything running and it has been flawlessly working for months. Recently I was watching a movie in Kodi and the image froze, unresponsive. After rebooting, and every reboot since, I was given the "illegal instruction" error including the joystick ASCII and system info.

    I was going to simply re-image my device to get it going again, but I was hoping that I could avoid doing that so I don't have to reconfigure everything.

    Raspberry Pi 3
    Retropie 4.2
    PSU: 2.5A Canakit adapter
    Peripherals: USB Wireless Keyboard & USB Xbox360 wireless adapter

    Let me know your thoughts. Thanks!

  • Anybody?

  • @choogar I am having the same issue. I have multiple Rpi2 and Rpi3's. I use a master image for both, and have never had any problems. For some reason this issue has manifested itself in this load. I have not tried to reimage the SD card yet, but will try soon.

    Did you ever find a solution? Anyone?

  • I have the same issue. I had a working RPi2 with Retropie 4.2 (all manually installed and updated). I decided to update Jessie to the actual build (via apt-get update / apt-get upgrade) und Retropie to the actual version 4.3.1.
    Now I get "illegal instruction" after trying to start Emulationstation.
    I tried to re-update Emulationstation but this didn't helped.
    What went wrong? Is my SD card corrupted? Any dependencies missing?

  • Global Moderator

    @jimbo27 Did you also upgrade Jessie to Stretch ? I've seen this 'Illegal instruction' in ES when the wrong GLES libraries are installed and ES thinks it's running under X11 instead of the framebuffer.

  • @mitu hm, I just made an update via apt-get update/upgrade and got a new kernel. I thought I'd stay on the Jessie path if I did a normal update. Did I accidentally installed Stretch over Jessie? How can I check this?

  • My kernel is Linux 4.9.35-v7+

    cat /etc/os-release:
    PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
    NAME="Raspbian GNU/Linux"
    VERSION="8 (jessie)"

  • Global Moderator

    @jimbo27 No, you didn't upgrade - as you mentioned below, to upgrade you need to change the distro release in the sources.list and then do a apt-get dist-upgrade. Just wanted to check that you didn't accidentally upgrade to Stretch, since it's still unsupported.

    Can you run EmulationStation via SSH (should work) and paste the complete error message ? What does ldd $(which emulationstation) show (paste here the output) ?

  • @mitu said in "Illegal Instruction" on previously working RP:

    ldd $(which emulationstation)

    Starting Emulationstation via SSH results in:
    Illegal Instruction

    Using ldd $(which emulationstation) results in:
    not a dynamic executable

  • Global Moderator

    @jimbo27 Then it's not the same error as I've seen before. I'm at a loss.

  • @mitu Thanks anyway. I will restore my backup and install all updates step by step. Let's see at which point Emulationstation will break.

  • I made a fsck on the partition which contains Retropie. There were several errors. :(
    So it seems my SD card is corrupted.

  • I can confirm it was the SD card. I bought a new one and made all updates. After that everything runs as intended. :)

    PS: I buyed a more expensive SanDisk Extreme. Much faster than the SanDisk Ultra I had before!

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.