Please do not post a support request without first reading and following the advice in

runcommand segmentation fault after update today

  • Hi,

    I'm having a small problem with my retropie installation. I've updated the OS and Retropie today. I'm using a precompiled Retropie image. Everything went fine with that update, seemingly.
    But now, every time I try to start a game from EmulationStation (ES) it won't load games anymore. None of the emulators work at the moment. When I look at the runcommand logfile I get a segmentation fault of the runcommand script as followed.

    Does anybody know why this is happening?

    Best regards


    Copy & paste from runcommand.log:
    bash: /opt/retropie/supplementary/joystick-selection/ No such file or directory
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-prosystem/ --config /opt/retropie/configs/atari7800/retroarch.cfg "/home/pi/RetroPie/roms/atari7800/Ace of Aces (Europe).a78" --appendconfig /dev/shm/retroarch.cfg
    /opt/retropie/supplementary/runcommand/ line 1005: 3615 Segmentation fault /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-prosystem/ --config /opt/retropie/configs/atari7800/retroarch.cfg "/home/pi/RetroPie/roms/atari7800/Ace of Aces (Europe).a78" --appendconfig /dev/shm/retroarch.cfg

  • Hmm... nobody has an idea? Maybe my English is too bad and too hard to understand.

    I kind of solved that problem myself. Still I have no idea what what went wrong with the update. In the end I restored a backup I previously made a couple of months a ago and which mostly resembled the state of the machine before the update.

    Then I updated again. Now the image works as its supposed to.

  • @willy-goergen in the log above there's a clear issue with RetroArch when loading atari7800 core emulator. Does it happen with other systems too?

    Also, looks like you had installed my joystick-selection tool and don't have it anymore. Can you confirm that?

  • Hi meleu,

    thanks for your answer.

    I had exactly the same problem with any other emulator (NES, SNES, Genesis, you name it).
    The joystick-selection tool was also installed. Removing it made that message disappear, but the segfault stayed. Reinstalling everthing related to Retropie also didn't help.

    What made me wonder is the file not found error. But on the other side all the files were there and accessable. I also tried to download mentioned files per FTP. At least everything seemed to be ok as I was able to watch the content (code) of that downloaded script file.

    That problem was really strange to me. The fact that it didn't occur again after restore and updating again surprises me even more. At the moment I suspect that the SD-card was corrupted somehow, albeit it is relatively new and barely used. The last time I used it was about three months ago.

  • @willy-goergen that jsonstart not found message is completely unrelated with the segfault. It seems to be a RetroArch bug.

  • @willy-goergen can you please post your /opt/retropie/configs/all/retroarch.cfg in ?

  • @meleu said in runcommand segmentation fault after update today:

    @willy-goergen can you please post your /opt/retropie/configs/all/retroarch.cfg in ?

    @meleu, there you go:

    Let me know if you need further information. I would gladly provide it.

  • @willy-goergen I thought you could be having the same issue as this guy here, but according to your config file it isn't your case.

    Can you confirm if it stills happening?

  • @meleu, the state of the machine where the error occured is unfortunately lost, since I've made a recovery with a backup I created some time ago. After that I updated again (about two days ago) but this time I haven't had any errors until now.

    The only thing I can confirm that it works now and that I'm still using your (?) joystick-selection tool. It's pretty handy for me since I always have keyboard connected to my RPI that I'm using with an other sd-card as living room PC. Maybe there was an overlapping with your fix (if I understood correctly) and my second attempt on updating?

    According to the error description in that other thread he or she had exactly the same issue that I had. But just like I said, that previous state is gone on my side.

  • @willy-goergen the issue was on the "Disable" option for a player. But now it's fixed.

    If it's solved maybe you should mark this thread as solved. ;-)
    edit: oh, you already did it. :-)

  • You're welcome! ;)

    Thank you for helping us and your work on that joystick-selection tool. :)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.