Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Pier Solar (SegaCD)... How to play when .BIN is intentionally masked?



  • EDIT: SOLVED.

    Simply re-name your "Pier Solar.bin" to "Pier Solar.cue". Just make sure whatever you named the .BIN file is an exact match of what you named the .ISO file or you won't get the CD music.

    Thanks to everyone who replied.

    ============================================

    Hey everybody.

    From my understanding, in order to run Pier Solar, you have to have the .BIN rom image and the .ISO audio image in the same folder, and then you can launch the rom in genesis-plus-gx and call it a day.

    My problem is that I filtered everything out of the romlist but the .CUE files so that you only get one entry per game on the Sega CD.

    There is no .CUE file for Pier Solar... just the .BIN and .ISO.

    If I actually add .BIN to the list of games shown, that will make it so two entries show up for every game on the system since they're all in BIN/CUE format.

    Anybody have any suggestions how you could get around this, or make a singlular exception for Pier Solar?

    Maybe I could add something like "Pier.bin" in the es_systems.cfg?

    Thanks!


  • administrators

    @Used2BeRX you can create cue files.



  • @herb_fargus That would be a perfect solution if it works here.

    How would you write a cue file with nothing but a .BIN and .ISO? Which would be Track 1 and track 2?

    Or..... could I just create a file with a CUE extension that just loads the BIN? Kind of like a .BAT file in DOS?

    The ISO itself doesn't have any CUE, so I'm assuming that the BIN file knows all of the information about tracks and such. I opened the ISO in ISOBuster and without the CUE there is no track information, and there is very little data on the CD image otherwise.



  • @Used2BeRX use sega cue maker. It can make cue files for iso and bin for sega cd and pc engine cd/ turbografx cd.



  • @Used2BeRX I'm not used with this stuff, but maybe this info in the docs can help:
    https://retropie.org.uk/docs/Saturn/#why-dont-my-bin-or-iso-files-show-up



  • @meleu Yeah... that's not working for me here. I don't think this is actually a .BIN file like most other CDs would be. The ".BIN" here is essentially a large Genesis/Megadrive rom file. The ISO is the audio track that accompanies the game. (The game will actually run without the ISO, but you have no music then).

    To my knowledge, this is the only game of this kind for the system. I'm not sure why they programmed it this way.

    What I'm wondering is if we can somehow create a pointer to the .BIN file that is either a .CUE, or another type of file that I can add to the list of filetypes to show in the es_systems.cfg file (as well as our script to actually find this and add it).

    That pointer would function only to select the .BIN file of this game that is hidden because the .BIN extension is not included for segacd in thie es_systems.cfg file.



  • @Used2BeRX before tweaking es_systems.cfg test if the following command is able to launch the game (adapt the path to the ROM according to your system):

    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ segacd "/home/pi/RetroPie/roms/segacd/Pier Solar.BIN"
    


  • @meleu Yes! That launches it. :)

    I don't think it's going to work great on my Pi Zero because genesis-plus-gx runs so poorly on it, but at least that gets it to run even if the music is choppy. (I think I read somewhere that it won't work in picodrive unfortunately).

    Also strange is that my keyboard won't do ". Everytime I try to type in ", it instead types @. So I had to change the name of the .BIN and .ISO to CD-PierSolar without any spaces to get the command to work without quotes.

    So.... what's next?



  • Did you try shift+@? :D

    It's something to do with keyboard layout/language preferences vs your actual keyboard.



  • @arkive lol... yeah. That's the first thing I tried. @=@

    The number keys work fine and most of the symbol keys work fine too. The two important keys that don't work right in Linux console are \ and ".

    I've got a weird mini-keyboard that doesn't have a numpad on it. My big keyboard broke a while back and I haven't replaced it. I had this one in a box of stuff for XBox emulation. It was good to break out on occassion if I wanted to play some Kings Quest on the XBox.

    I had this problem on Windows with it a while back, but I managed to make some change I don't remember how I made it in Windows 10 config files to get it to work fine in Windows, so I don't have problems posting the characters here. I just don't have a clue how to change any of that in Linux.



  • Have you tried launching the game from the megadrive folder rather than segacd? I have Pier Solar in .bin and .iso format and copied them into my roms/megadrive folder. That system can launch .bin files using lr-genesis-plus-gx and when launching the game it says "Disc ready!" in Options.

    No changes were necessary. Just the .bin and .iso files.



  • @sonicsheppard That's not a bad idea and I don't know why in all the hours I was messing with this yesterday that I didn't think of it myself. lol.

    I really rather would not have that in the Genesis library of games though since its' a small library by size, and that single ISO file is larger than all the Genesis games several times over. If I absolutely have to I suppose I could use a symbolic link to a folder on a USB stick for that one Genesis game.

    I'm hoping that @meleu had something in mind when he last replied. Im' still waiting to hear back from him on this.

    Thanks for the idea though sonicsheppard. That will work if there is no better solution.



  • @Used2BeRX well, I don't have a perfect solution... But as a workaround I would suggest you to create a symbolic link with a valid extension. Something like:

    ln -s "/home/pi/RetroPie/roms/segacd/Pier Solar.BIN" "/home/pi/RetroPie/roms/segacd/Pier Solar.CUE"
    

    I think EmulationStation will show it and runcommand will launch it.



  • @meleu I'm still going to try to wrap my head around this, but that idea doesn't work for me.

    It looks like I'm unable to create a symbolic link on the USB drive itself. I'm assuming it's because the USB drive is FAT32, and not the Linux table.

    What I'm thinking now is that I might keep /segacd/ an actual folder on the Pi itself instead of a link. Then I could make each of the sub-folders symbolic links to their respective folders on the USB drive. This way I could have a special symbolic link exclusively for Pier Solar within the main /segacd/ folder on the Pi.

    Not exactly ideal, but it might be the best option available.

    Fortunately this is a one-off problem that I shouldn't ever run into again. If the game wasn't supposed to be so damn good I wouldn't have even bothered wasting half a day trying to figure this out. :)

    Thanks for the suggestions everyone. I'll let you know what I end up doing, and I'll let you know meleu if our script picks up the "symbolic link cue" when I make a synopsis and get artwork for this game.



  • @Used2BeRX said in Pier Solar (SegaCD)... How to play when .BIN is intentionally masked?:

    It looks like I'm unable to create a symbolic link on the USB drive itself. I'm assuming it's because the USB drive is FAT32, and not the Linux table.

    correct. You can't create symbolic links on a FAT32 partition.

    Another ugly workaround is just rename the file using the .CUE extension. I think RetroArch doesn't care about extensions...



  • @meleu

    I think RetroArch doesn't care about extensions...

    Jeezy Creezy.... It was just that easy.

    Ahhhhhhh well. At least when I'm wasting a ton of time and the answer is just this simple at least I'm learning new things, right?

    I absolutely can't believe the best answer was changing .bin to .cue. Works perfect for launching the game, and it shouldn't give any problems with our script either.

    Thanks everybody!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.