Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Pier Solar (SegaCD)... How to play when .BIN is intentionally masked?



  • @Used2BeRX before tweaking es_systems.cfg test if the following command is able to launch the game (adapt the path to the ROM according to your system):

    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ segacd "/home/pi/RetroPie/roms/segacd/Pier Solar.BIN"
    


  • @meleu Yes! That launches it. :)

    I don't think it's going to work great on my Pi Zero because genesis-plus-gx runs so poorly on it, but at least that gets it to run even if the music is choppy. (I think I read somewhere that it won't work in picodrive unfortunately).

    Also strange is that my keyboard won't do ". Everytime I try to type in ", it instead types @. So I had to change the name of the .BIN and .ISO to CD-PierSolar without any spaces to get the command to work without quotes.

    So.... what's next?



  • Did you try shift+@? :D

    It's something to do with keyboard layout/language preferences vs your actual keyboard.



  • @arkive lol... yeah. That's the first thing I tried. @=@

    The number keys work fine and most of the symbol keys work fine too. The two important keys that don't work right in Linux console are \ and ".

    I've got a weird mini-keyboard that doesn't have a numpad on it. My big keyboard broke a while back and I haven't replaced it. I had this one in a box of stuff for XBox emulation. It was good to break out on occassion if I wanted to play some Kings Quest on the XBox.

    I had this problem on Windows with it a while back, but I managed to make some change I don't remember how I made it in Windows 10 config files to get it to work fine in Windows, so I don't have problems posting the characters here. I just don't have a clue how to change any of that in Linux.



  • Have you tried launching the game from the megadrive folder rather than segacd? I have Pier Solar in .bin and .iso format and copied them into my roms/megadrive folder. That system can launch .bin files using lr-genesis-plus-gx and when launching the game it says "Disc ready!" in Options.

    No changes were necessary. Just the .bin and .iso files.



  • @sonicsheppard That's not a bad idea and I don't know why in all the hours I was messing with this yesterday that I didn't think of it myself. lol.

    I really rather would not have that in the Genesis library of games though since its' a small library by size, and that single ISO file is larger than all the Genesis games several times over. If I absolutely have to I suppose I could use a symbolic link to a folder on a USB stick for that one Genesis game.

    I'm hoping that @meleu had something in mind when he last replied. Im' still waiting to hear back from him on this.

    Thanks for the idea though sonicsheppard. That will work if there is no better solution.



  • @Used2BeRX well, I don't have a perfect solution... But as a workaround I would suggest you to create a symbolic link with a valid extension. Something like:

    ln -s "/home/pi/RetroPie/roms/segacd/Pier Solar.BIN" "/home/pi/RetroPie/roms/segacd/Pier Solar.CUE"
    

    I think EmulationStation will show it and runcommand will launch it.



  • @meleu I'm still going to try to wrap my head around this, but that idea doesn't work for me.

    It looks like I'm unable to create a symbolic link on the USB drive itself. I'm assuming it's because the USB drive is FAT32, and not the Linux table.

    What I'm thinking now is that I might keep /segacd/ an actual folder on the Pi itself instead of a link. Then I could make each of the sub-folders symbolic links to their respective folders on the USB drive. This way I could have a special symbolic link exclusively for Pier Solar within the main /segacd/ folder on the Pi.

    Not exactly ideal, but it might be the best option available.

    Fortunately this is a one-off problem that I shouldn't ever run into again. If the game wasn't supposed to be so damn good I wouldn't have even bothered wasting half a day trying to figure this out. :)

    Thanks for the suggestions everyone. I'll let you know what I end up doing, and I'll let you know meleu if our script picks up the "symbolic link cue" when I make a synopsis and get artwork for this game.



  • @Used2BeRX said in Pier Solar (SegaCD)... How to play when .BIN is intentionally masked?:

    It looks like I'm unable to create a symbolic link on the USB drive itself. I'm assuming it's because the USB drive is FAT32, and not the Linux table.

    correct. You can't create symbolic links on a FAT32 partition.

    Another ugly workaround is just rename the file using the .CUE extension. I think RetroArch doesn't care about extensions...



  • @meleu

    I think RetroArch doesn't care about extensions...

    Jeezy Creezy.... It was just that easy.

    Ahhhhhhh well. At least when I'm wasting a ton of time and the answer is just this simple at least I'm learning new things, right?

    I absolutely can't believe the best answer was changing .bin to .cue. Works perfect for launching the game, and it shouldn't give any problems with our script either.

    Thanks everybody!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.