Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

updated retroarch now joystick selection doesnt work



  • i tried to update joystick selection after it stopped working after updating retroarch. unfortunately i cannot find it anywhere in retropie setup. i looked in experimental where it is supposed to be and everywhere else in the retropie setup and i cannot find it.



  • @edmaul69 i tried to reinstall but the first command gives me an error

    if [[ ! -d "$RP_SETUP_DIR" ]]; then
        echo "ERROR: \"$RP_SETUP_DIR\" directory not found!" >&2
        echo "Looks like you don't have RetroPie-Setup scripts installed in the usual place. Aborting..." >&2
        exit 1
    fi
    
    curl "$JS_SCRIPTMODULE_URL" -o "$JS_SCRIPTMODULE_FULL"
    
    if [[ ! -s "$JS_SCRIPTMODULE_FULL" ]]; then
        echo "Failed to install. Aborting..." >&2
        exit 1
    fi
    
    sudo "$RP_SETUP_DIR/retropie_packages.sh" "$JS_SCRIPTMODULE"
    sudo "$RP_SETUP_DIR/retropie_packages.sh "$JS_SCRIPTMODULE" gui
    
    


  • i updated retropie setup too.not sure why it is telling me i dont have the retropie setup script in the usual location



  • i get an error trying to open retropie setup in command line

    root@retropie:~# ~/RetroPie-Setup/retropie_setup.sh
    -bash: /root/RetroPie-Setup/retropie_setup.sh: No such file or directory
    

    i dont have a retropie setup directory there. it is in /home/pi /RetroPie/



  • @edmaul69 are you sleepy? :)

    you're using the root account!



  • @edmaul69 the installation method has changed. I think this is the reason of your confusion. Sorry abou that but some users were having problems with the previous one.

    Please, follow the instructions here: https://github.com/meleu/RetroPie-joystick-selection/#installation

    I won't change it anymore, I promise! ;-)



  • problem solved. if using the install guide on github you need to use sudo to not get this error.

    @meleu i wasnt logged into root. i just looked for my retropie setup in the root folder under root as the joystick-selection.sh kept saying the retropie setup wasnt in the root folder. i deleted the joystick-selection.sh and that fixed the retropie setup. then i used sudo to get the joystick selection install to stop giving me the error on my first post. thank you for your help



  • Did you modify the default prompt then ? It really looks like you were root.
    By default, a # at the end of the prompt is specific to root user. Normal users should have a $. Moreover the prompt indicates root@retropie.

    pi@retropie:~ $ 
    


  • @Sano and pi before @retropie. :-)



  • @meleu I was precisely editing my message :)



  • @meleu @Sano i did that root thing just to look at the root folder after having problems. Everything before that was using user pi. The problem is this, if you try to run the joystick-selection following the guide, if you dont use sudo which the guide doesnt say to use, it dumps all that junk from my first post into the joystick-selection.sh which then makes the retropie-setup no longer work. The only way to get retropie-setup to work is to either delete the joystick-selection.sh or run the joystick-selection guides first command with sudo which then properly installs the joystick-selection.



  • @edmaul69 The guide to install my tool looks fine, I tested it before writing. But it changed recently and maybe you used the old method of installation and it caused the confusion.

    The sudo is not needed to use install.sh, but I've just changed it to work fine if the user invoke it with sudo.

    Thanks for the feedback and sorry for the inconvenience. :-)

    Cheers!



  • @meleu after i deleted the joystick-selection.sh which fixed retropie setup, i ran your first command from your github without sudo and it then gave me the same error as my first post. I then added sudo and it immedietly worked. So not sure why, if it is working without sudo for you.



  • Hi, not sure if I am doing something stupid but I am using the Xin Mo Dual Arcade controls, have typed in the usbhid.quirks code and everything is recognised but naturally the player 1 and 2 controllers are switched so I am trying to use your code to switch them back. When i type your code in i get this...

    0_1514722406521_20171231_115937-640x480.jpg

    Can you help at all?



  • This post is deleted!


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.