Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Wifi - Issues with Password



  • Hi Guys,

    I have a RP0W and have loaded RetroPie on an SSD and it boots up fine.
    I tried to connect to my wifi and it will not connect at all, I have tried everything:

    • Tried to connect through the menu option and selecting my SSID and entering my password.
    • Updated the wifikeyfile.txt with my wifi login details and choosing the import option.
    • Created a wpa_supplicant .conf file in the root directory like you would with a default Raspbian install.

    None of these options worked. Each time it advises "Could not connect to network". I am starting to think it may be my wifi password as it contains special characters like these "~!@#$".

    Does anyone know if RetroPie has issues with long passwords with special characters?

    Please Note: I connected to my wifi using the default Raspbian Jessie setup without issue.

    Any help would be much appreciated.

    Cheers,

    Ben



  • some USB keyboards have problems with the Pi, and dont put out all keystrokes....does your password display as * (dot/stars)?
    try and make them visible to check if you keyboard puts out the correct keystrokes, if not, try another keyboard



  • Thanks for the tip, what I found interesting was when I entered ~ two asterisks show instead of one.
    However, I also created the wifikeyfile.txt from my windows machine and copied it to the card and I could see what I was entering.

    Also, I tried to tether the RP0W with my phone as it has a plain password and it still couldn't connect so I don't know what the issue is now.

    Any other thoughts?



  • I discovered the issue with RetroPie not accepting my password.

    Basically, RetroPie by default has the British keyboard layout selected which causes some special characters to be behind different keys. Most notably the ~ key and the @ key, which are contained in my password.

    Follow this guide to change back to a US layout and try re-entering your WIFI password again:

    This should resolve the issue :)



  • @benzine78 dont forget # is a £



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.