Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Trying to disable pi3 BT, made a mess...



  • Hi guys,

    This is a pretty straightforward enquiry (I hope). Unfortunately I'm a noob so will probably get this wrong.

    pi model: 3 B
    powersupply: unknown but sufficient
    retropie version: 4.2
    built from: retropie website download SD image
    usb device: csr 4.0 bluetooth dongle (tried with and without)
    controller: 8bitdo NES30 & SNES30

    Built my pi, everything was great - was running with no case, so bought a case from aliexpress. Aluminium with a heatsink, looks nice, good quality. unfortunately when I put it back together, the bluetooth reception went to shit and the controllers became barely useable. so, I bought a bluetooth dongle which will be outside the case... (read a website which said they're OK for pi - I don't believe this is the issue)

    Added the following to /boot/config.txt (by typing sudo nano /boot/config.txt):

    dtoverlay=pi3-disable-bt

    The first time it didn't save, second time it saved - appeared to work, as the bluetooth controllers won't connect at all now. However, when emulationstation boots to the "gamepad not detected" screen, hitting f4 on a keyboard now takes me to the command line instead of retropi GUI.

    So I can't attempt to detect the gamepads etc. Just stuck now :-( Any ideas?

    tl;dr - I just want to use a bluetooth dongle instead of pi3 onboard bluetooth. Hoping this will fix my reception issues, but now I can't get into retropie gui



  • Hi all,

    I should update that I have tried to use 8bitdo controllers wired through usb, and it won't detect them at all at the "no gamepad" screen. Nothing :-(



  • OK guys, I solved this one - eventually got the gamepad to connect via usb by trying different ports. Wouldn't work with the bluetooth dongle plugged in, but did without. Then plugged the dongle in, and searched for devices - was able to pair with the plugged in snes30 control (?) and then pair the nes30 control on second attempt. Tried a reset and everything is great!

    Strange that it wouldn't let the wired keyboard take me to the gui, but it's done now.

    For anyone that wants to disable onboard bluetooth and use a dongle... the above config entry is good.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.