Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

No more sound in all emulators but ok in emulation station menu



  • Hi there.

    I have a raspberry pi 3b and retropie 4.2. I have an amp connected to the jack 3.5 of my raspberry

    I have a new probleme very weird.

    I have no sound anymore when i am in games. But sound is working in emulationstation menu.
    Everything was ok 2 hours before.

    Retroarch.cfg seems ok

    I don't know why this issue comes ? And mostly i don't what to do ???

    Any ideas ? Somtehing to do or verify ?



  • I think when I tried 3.5, I had to set the RPi audio settings from auto to 3.5 specifically. I might have had to reboot after doing that too. Maybe worth a try if you haven't already.



  • You mentioned that your system was working fine a few hours before you lost sound. This could be due to overheating. The Raspberry Pi will shutdown services if it's overheating. This happened to me a few weeks ago, and running the fan controller script again solved the problem once the temperature dropped (I just need to get a quieter fan).

    Hope this helps.



  • Thank you for your answers, actually the probleme is solved.

    I had tried to modify my controllers in retroach.cfg with my local network. But when i save the file with wordpad, the sound disappears.

    I must modify retroarch.cfg in configuration editor and no probleme anymore



  • It's actually a really bad idea to modify a linux text config file with a rich text editor.
    The best option is to use a linux text editor (vim, nano, ...), or a simple MS notepad (or better, notepad++).
    You're lucky only the sound was impacted :)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.