Please do not post a support request without first reading and following the advice in

PS4 controller - constant phantom button press

  • Hi,

    I'm fairly new to retropie and still finding my way. I've set up everything with two controllers. One is a PS4 controller and the other is an Xbox controller. The latter works nicely but the PS4 controller acts like it's constantly pressing up in retroarch and in the games. It's not an issue with the controller because I've tried other PS4 controllers with the same result.

    When in retroarch or in a game it is like the up directional pad is being pressed constantly which makes the controller unusable.

    I've searched the forums but I can't find a similar issue to this. I've tried wiping the controls in retropie and starting again but with no luck. It works in retropie but its just in retroarch that it doesn't.

    What am I doing wrong?

  • I'm guessing it's an accelerometer problem, but just a guess without some more information. (Suggest you read the 'read this first' at the top of the page.

  • @lifeinkyoto How are you connected? With the PS3 driver or the normal Bluetooth option in ES? This happens with my DS4 controller as well but to a lesser degree. While I'm playing at times a start menu will pop up without being pressed or it will skip down the menu list a few extra lines without pressing down. Nothing like a button is being constantly held down but I know what you mean. It seems to only happen when I have more than one controller connected with Bluetooth, could be signal interference, I'm honestly not sure, but you're not alone. I've just come to expect that the Bluetooth isn't perfect and the occasional phantom press will happen from time to time.

  • Try out the method(s) in the link below. I've used both methods though... I rarely get any phantom button presses anymore. You may need to reboot your pi a few times or shutdown for the changes to actually take effect (at least for me I had to do this). Hope this helps. Worked for me, I'm using 2 ps4 controllers over the Pi's onboard bluetooth.

  • @yfresh59 This is to do with the runcommand menu, I haven't noticed any problems there, however it may explain my menu jumps in ES. When actually in game I seem to be getting the occasion phantom start button press, not sure if that is related to the accelerometer.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.