Please do not post a support request without first reading and following the advice in

Help troubleshoot my power problem!

  • Perhaps this??
    Although I don't need 21 inches...

  • Seems the power supply is capable of doing what it needs, but only just as a comment from the reviewer who tested it under load has wrote., suggesting that a USB device drawing power from the USB ports might be pushing it over the power supplies therotical limit

    The Canakit 2.5A supply crosses 2.5A at about 4.5V (2.54.5 = 11.25W). Both of these are well below 5V. Probably high enough that the RPi won't crash, but cutting it close.*

    If your using USB hard drive, some can take considerable power from the USB ports which is why a power splitter was suggested as its then taking power from two USB ports. I use a 1TB Seagate expansion drive which also supports USB3

    I also have one on my PS3 which are well known for very poor voltage for anything other than game controllers from the USB ports and it works perfectly even with that

    Just had a quick look on Amazon UK, they are still available and in 1,2,3 or even 4TB all in 2.5" sizes and all measuring a very tiny 12.2 x 1.5 x 8.1 cm. The 3TB and 4TB are slightly smaller as well

    Its a 2.5" USB hard drive designed for low power devices and works perfectly with the power supply I use which is a Stontronics switching adaptor Model DSA-13PFC-05, apparently produces 5.1v at 2.5a and tested with the RPI3 under load

    If you can get a good quality USB power supply that gives out 5.2v at 3a even better as the slight voltage drop taken when you connect power hungry devices to the RPI will be compensated by the 5.2v output.

  • Get a power supply with more current (3A or higher). The voltage drop on the 5V rail is caused by all the devices that are connected to the RPi's USB ports due to the current demand from these devices. As the demand for more current goes up, the voltage drops because the power supply cannot keep up with this demand.
    Also, you will have a more stable setup if you can have a separate power source for USB HDD, as it will not be depleting the power on the RPi .

  • I ordered one of these guys and it arrived today:
    It's a 5v 3A power supply. With the CanaKit power supply, I was getting the lightning bolt icon on my screen while the RetroPie image displays during load up (the default one installed, that displays before the EmulationStation image displays). If I watch the Pi, the power light would also flicker the moment the icon comes on. When I tested this NEW power supply tonight, the red power light stayed solid during the entire bootup, and I never saw the lightning bolt icon. I also had the icon display during each time the hard drive is being accessed to load up a new video in the video screensaver. That has now stopped as well. So (I don't want to jinx it but...) I think this is the solution I needed.

    Arriving today as well, I also ordered one of these:
    This USB3 power splitter for external hard drives was a new thing for me. I first tested it using the CanaKit power supply. I wanted to see if I could use this cable instead of the power supply because I already have the CanaKit taken apart and wired inside the case. Unfortunately, using this cable did NOT solve the problem. I still had the issue of the icon and power light flickering during bootup, and upon loading each video in the screensaver. Since I already knew the solution had been found with the other power supply, I didn't even bother testing this cable in conjunction with it.

    I'm happy in knowing the power supply alone was all I needed. I thought about maybe returning this splitter cable, but it's only $7. I might end up needed it in the future anyway, once I get everything all hooked up and what not. So I think I'll hold on to it just in case.

    So for future problem solvers... if you run into this problem, find a power supply that gives more amps! When I was looking for this one, I had actually searched for "5v 3a microusb power supply". Then I tried searching for "5v 4a", etc. They exist, but it looks like they split into 2 plugs with each putting out 2a. So this 3a was probably the best option. I think I found a new favorite power supply, and it's even cheaper than CanaKit's. I just need to experiment with it a bit. I'm gonna plug it in and let the screensaver run while I'm at work tomorrow and see how it holds up and how hot it gets.

  • @hansolo77 i use the canakits and yeah it doesnt work. I use 2 power supplies. (My apple iie has a fully used 13 port powered hub so i definitely need two power supplies) but i am going to try out the power supply you posted for my pistation. I had a different power supply that worked splitting the power between a usb hub (only used for the hard drive) and the pi but i ended up giving the power supply away. So now i need to try another power supply since the canakit just isnt enough.

  • I had a cheap knockoff power supply I bought from MicroCenter called iEssentials or something. It was crap. With NOTHING connected, it gave me lightning bolts. I couldn't remember if it was THAT power supply or not, so when I built a second Kodi box, I bought another one. They're absolute crap. CanaKits were great "upgrades" from that when doing simple projects. But when going on to more beefy setups like my NesPi and PiStation that have hard drives, it's just not enough. My NesPi is stable with the CanaKit because the drive requires a lot less power. This one I'm using for my PiStation is 4tb (to hold all the roms and videos). So This new power supply is working great for it now.

  • @hansolo77 What are the power requirements (voltage, current) on your hard drives? What other devices are connected to the USB ports?

  • I don't know the drive's requirements. I looked online but all I can find is it's specs saying it's USB 3.0 yet 2.0 compatible. As for other devices, just the USB plug for the PS3 controller.

  • Aww man this suuuuuxxxx!!! I'm like 98% there! Building my PiStation, I now have a working RESET button and LED, and the new NorthPada 3a power supply is giving me good clean no lightning bolt power. Then I go and throw a Mausberry circuit into the mix, and all of a sudden I start getting that lightning bolt again during boot up, and the occasional (not all the time) icon during video screensavers. So now the culprit seems to be the circuit. It works fine without it.. But also, without it, I don't get that nice feature of being able to turn the power on and off. I just can't win. :(

    I also need to work with my skin a bit. I'm getting a lot of black screens, where the background image isn't loading, and the various bits like star ratings, system logo, and even the Select menu buttons (on/off, etc). I've tried dropping my VRAM to 80, and now it's at 60 and I still have this problem. So I think I need to drop my resolution of the skin to 720 instead of 1080.

    Other than that, I just need to get some more videos because only about half of these games have them.

    So yeah.... anybody had this happen with them? Where the power is great until we throw in the Mausberry on top of it?

  • How thick is the wire coming from the Mausberry to the pi? Because if your just using a standard USB charging cable, it may not be thick enogh to handle the current. You might need to make your own cable like I had to. Or just solder the power wires directly to the pi.

  • @hansolo77 It may be worth considering something more substantial. Something like this.

    I have used these on projects. They are rated such that you don't need to think much about the extras you add. Things like LED light strips etc. Use #22 hookup wire. You could use it to power up a USB hub with no effect on your Pi.

  • @lostless It's a direct plug. so there are no wires.

    @rbaker Holy crap. :)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.