Please do not post a support request without first reading and following the advice in

Help troubleshoot my power problem!

  • I'm doing a new project and I've been having some problems with my power supply. I'm getting a lightning bolt icon on screen. Normally that's no big deal, means I've got a voltage drop and the power supply sucks. Thing is, this is the 3rd power supply now, all CanaKit's from Amazon. This current one only flashes up the icon when it's trying to boot up (during the RetroPie screen but before the ES screen). Then it'll run fine but everytime the video screensaver runs and it goes to load the next video it pops up.

    The particular issue I'm having is because of the cramped space in my project. I've had to remove the circuitry from it's plastic shell in order to make it all fit. I then cut the power leads from the plug and solder them to a different plug. I've tested this all with a multimeter and it's working fine. I even went as far as to get some mini alligator clips and just attach the soldered wire (on the new plug) to the power plug of the adapter. Again, works fine but there's no clearance inside the case to work that way.

    So I'm looking for a different solution. Can somebody recommend a good power supply that doesn't suffer voltage or amp drop after removing it's plastic shell? Is there a good power supply that is designed differently to where the power prongs aren't sideways that might fit better? Does removing the shell have any impact on performance? I've read that having a shorter cable might work, but this is supposed to be a good supply to have with Pi3's..... Should I risk cutting and shortening it?

  • Before you do any of that..are you overclocking and do you have other things connected?

  • Yes, a USB Hard Drive. That's why I think it's getting a voltage drop when it accesses the drive. Once a video is loaded into memory, it runs fine. Then a new video is loaded and the icon reappears then disappears.

    I also have the GPIO wired up to run a small 30mm fan (strangely my Pi gets HOT just idling on the ES menus). I may end up replacing this fan though. It was highly recommended on Amazon but it's way too noisy. I have a 30mm fan in my NES from Noctua and it's almost silent.

    I also have the GPIO wired to an LED and a Reset button. In the future I will also be adding a power button and have it wired to the GPIO. The only thing different between this build and the NES is that I have the fan, a larger capacity hard drive, and have to take the adapter apart. The NES build is rock solid, no over heat or under voltage warnings.

    I thought maybe my soldering sucks with the various buttons. But I've checked and re-checked. Everything is solid and not loose, and nothing is touching anything it shouldn't.

  • @hansolo77 It's probably the usb hdd. Get a splitter and power it seperately or connect it to a usb hub so it can power the hdd that way. Also, if you're not going to watch movies on it, I suggest getting a usb stick instead.

  • If you ripped apart a power supply and are wiring directly to it, are you using thick enough gauge wiring? I did a build one time and i used a USB cable from the power supply to the pi that was designed for a printer, what i didnt realize was the thin gauge power cabling in printer specific USB cables was really think and couldnt carry the proper current even though the power supply was rated properly. Make sure you are using 22awg at the thinnest for power distribution, solid core is better than stranded.

  • @Darksavior I'm not aware of a splitter. Can you link to an Amazon or similar store item? If that's indeed a possibility, I don't mind doing that. This build is for a PiStation and I've only ever had a max of 2 players in my (+20? damn I'm getting old) years of playing on mine. The 2 USB ports are rerouted to the front for controllers, 1 is already dedicated for the drive, so using another one for the drive is cool with me. I'm just curious how such a thing even works. The drive only has 1 cable.. So using a splitter, how would that work? I can see using 1 cable for data and 1 for power, but like I said.. it only has 1 cable. A splitter makes 2 out of 1 right? So I split the cable from the drive into 2 ports on the Pi. How does the Pi know which one is for the device? How does the drive know it's getting additional power? This is new to me.

    @Capeman The first power supply I did it with, I had used really thin wire. I have some GPIO wires that look like an old IDE hard drive cable, but with female jumper things on each end. I chopped off the ends and stripped and soldered them to the leads on the power supply and the plug on the back of the case. It worked.. everything powers on and stuff. But I was getting some interference trying to solder up the button and LED. I thought I had screwed up and grounded something. The power supply started only working half the time. So I threw it away and ordered another one from Amazon. That 2nd one was doing the same thing as soon as I took it apart and soldered it in. So I took it out and checked the leftover traces around the buttons/LED. I found the issue and corrected it. Then I re-soldered the 2nd power supply back in. Things looked good, but there was still the occasional lightning bolt icon. So I thought maybe the wire wasn't thick enough to support the power coming from the wall (as you suggested). I went to the hardware store (Home Depot, because there's nothing like Radio Shack around anymore). The best they had to offer of decent size was 16awg. They also had a 14awg solid core, but it was so stiff (somebody had opened the plastic wrap on one and exposed the wire) I thought it was the wrong thing to get. So I bought a spool of RED and a spool of BLACK. Took it home and soldered a bit of THAT to the leads. Then I started hearing a buzzing coming from the power supply. I immediately disconnected the power and checked for shorts. Everything looked ok, but the buzzing continued when I hooked it up. So I cut all the traces and removed the 16awg wire. I then ordered a 3rd Canakit from Amazon along with a hobbyist kit of 6 spooled 22awg wires in a box. Soldered it up with the 22 and that's where I'm at now. The buzzing is gone, but the lightning bolt remains.

    After posting my last reply, I went back to Amazon and ordered this:
    It says it's 5v but 3000mA. So that extra 500mA might solve the problem. I forgot to mention that I'm also using a PS3 controller via USB (for the time being, until I get the bluetooth working). I thought maybe the Canakit just can't supply enough juice with the HDD and the Controller. It hasn't shipped yet, so if you guys think the problem I'm having won't be solved this way, let me know and I'll cancel it. Or maybe I should just let it come anyway to have a backup. $10 ain't much, that's why I've not felt guilt buying 3 Canakits already.

  • @hansolo77 0_1500866621692_51Sr1W5gepL.SL1000.jpg
    This cable is meant to be used with a second usb port to help power a hdd that has trouble being powered by one port, but i think you can power the red usb cable with an ac adapter instead of using another usb port.

    I was getting voltage drops with a wired ps3 controller since I believe it's also trying to charge it. I removed the battery because I'm not going to use bluetooth and the drops were gone.

    For the insides, I also highly recommend you use cables as thick as a pc's power supply. I have a dead pc power supply so I cut my cables from that.

  • So is there a female connector on the other side of that cable? I would imagine so. :)

    Good idea about power supply wires. I had done that years ago for something else but I can't remember what now. I think I was fixing a usb plug or headphone wires or something.

    Interesting info about the PS3 controller. I never really thought about that, that it's trying to charge the battery. I'll have to look into that and see if I can figure out either removing the battery or getting the bluetooth to work. Maybe even as a test I can just try to boot the thing up without the controller plugged in to see if I still get the icon.

  • Perhaps this??
    Although I don't need 21 inches...

  • Seems the power supply is capable of doing what it needs, but only just as a comment from the reviewer who tested it under load has wrote., suggesting that a USB device drawing power from the USB ports might be pushing it over the power supplies therotical limit

    The Canakit 2.5A supply crosses 2.5A at about 4.5V (2.54.5 = 11.25W). Both of these are well below 5V. Probably high enough that the RPi won't crash, but cutting it close.*

    If your using USB hard drive, some can take considerable power from the USB ports which is why a power splitter was suggested as its then taking power from two USB ports. I use a 1TB Seagate expansion drive which also supports USB3

    I also have one on my PS3 which are well known for very poor voltage for anything other than game controllers from the USB ports and it works perfectly even with that

    Just had a quick look on Amazon UK, they are still available and in 1,2,3 or even 4TB all in 2.5" sizes and all measuring a very tiny 12.2 x 1.5 x 8.1 cm. The 3TB and 4TB are slightly smaller as well

    Its a 2.5" USB hard drive designed for low power devices and works perfectly with the power supply I use which is a Stontronics switching adaptor Model DSA-13PFC-05, apparently produces 5.1v at 2.5a and tested with the RPI3 under load

    If you can get a good quality USB power supply that gives out 5.2v at 3a even better as the slight voltage drop taken when you connect power hungry devices to the RPI will be compensated by the 5.2v output.

  • Get a power supply with more current (3A or higher). The voltage drop on the 5V rail is caused by all the devices that are connected to the RPi's USB ports due to the current demand from these devices. As the demand for more current goes up, the voltage drops because the power supply cannot keep up with this demand.
    Also, you will have a more stable setup if you can have a separate power source for USB HDD, as it will not be depleting the power on the RPi .

  • I ordered one of these guys and it arrived today:
    It's a 5v 3A power supply. With the CanaKit power supply, I was getting the lightning bolt icon on my screen while the RetroPie image displays during load up (the default one installed, that displays before the EmulationStation image displays). If I watch the Pi, the power light would also flicker the moment the icon comes on. When I tested this NEW power supply tonight, the red power light stayed solid during the entire bootup, and I never saw the lightning bolt icon. I also had the icon display during each time the hard drive is being accessed to load up a new video in the video screensaver. That has now stopped as well. So (I don't want to jinx it but...) I think this is the solution I needed.

    Arriving today as well, I also ordered one of these:
    This USB3 power splitter for external hard drives was a new thing for me. I first tested it using the CanaKit power supply. I wanted to see if I could use this cable instead of the power supply because I already have the CanaKit taken apart and wired inside the case. Unfortunately, using this cable did NOT solve the problem. I still had the issue of the icon and power light flickering during bootup, and upon loading each video in the screensaver. Since I already knew the solution had been found with the other power supply, I didn't even bother testing this cable in conjunction with it.

    I'm happy in knowing the power supply alone was all I needed. I thought about maybe returning this splitter cable, but it's only $7. I might end up needed it in the future anyway, once I get everything all hooked up and what not. So I think I'll hold on to it just in case.

    So for future problem solvers... if you run into this problem, find a power supply that gives more amps! When I was looking for this one, I had actually searched for "5v 3a microusb power supply". Then I tried searching for "5v 4a", etc. They exist, but it looks like they split into 2 plugs with each putting out 2a. So this 3a was probably the best option. I think I found a new favorite power supply, and it's even cheaper than CanaKit's. I just need to experiment with it a bit. I'm gonna plug it in and let the screensaver run while I'm at work tomorrow and see how it holds up and how hot it gets.

  • @hansolo77 i use the canakits and yeah it doesnt work. I use 2 power supplies. (My apple iie has a fully used 13 port powered hub so i definitely need two power supplies) but i am going to try out the power supply you posted for my pistation. I had a different power supply that worked splitting the power between a usb hub (only used for the hard drive) and the pi but i ended up giving the power supply away. So now i need to try another power supply since the canakit just isnt enough.

  • I had a cheap knockoff power supply I bought from MicroCenter called iEssentials or something. It was crap. With NOTHING connected, it gave me lightning bolts. I couldn't remember if it was THAT power supply or not, so when I built a second Kodi box, I bought another one. They're absolute crap. CanaKits were great "upgrades" from that when doing simple projects. But when going on to more beefy setups like my NesPi and PiStation that have hard drives, it's just not enough. My NesPi is stable with the CanaKit because the drive requires a lot less power. This one I'm using for my PiStation is 4tb (to hold all the roms and videos). So This new power supply is working great for it now.

  • @hansolo77 What are the power requirements (voltage, current) on your hard drives? What other devices are connected to the USB ports?

  • I don't know the drive's requirements. I looked online but all I can find is it's specs saying it's USB 3.0 yet 2.0 compatible. As for other devices, just the USB plug for the PS3 controller.

  • Aww man this suuuuuxxxx!!! I'm like 98% there! Building my PiStation, I now have a working RESET button and LED, and the new NorthPada 3a power supply is giving me good clean no lightning bolt power. Then I go and throw a Mausberry circuit into the mix, and all of a sudden I start getting that lightning bolt again during boot up, and the occasional (not all the time) icon during video screensavers. So now the culprit seems to be the circuit. It works fine without it.. But also, without it, I don't get that nice feature of being able to turn the power on and off. I just can't win. :(

    I also need to work with my skin a bit. I'm getting a lot of black screens, where the background image isn't loading, and the various bits like star ratings, system logo, and even the Select menu buttons (on/off, etc). I've tried dropping my VRAM to 80, and now it's at 60 and I still have this problem. So I think I need to drop my resolution of the skin to 720 instead of 1080.

    Other than that, I just need to get some more videos because only about half of these games have them.

    So yeah.... anybody had this happen with them? Where the power is great until we throw in the Mausberry on top of it?

  • How thick is the wire coming from the Mausberry to the pi? Because if your just using a standard USB charging cable, it may not be thick enogh to handle the current. You might need to make your own cable like I had to. Or just solder the power wires directly to the pi.

  • @hansolo77 It may be worth considering something more substantial. Something like this.

    I have used these on projects. They are rated such that you don't need to think much about the extras you add. Things like LED light strips etc. Use #22 hookup wire. You could use it to power up a USB hub with no effect on your Pi.

  • @lostless It's a direct plug. so there are no wires.

    @rbaker Holy crap. :)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.