Please do not post a support request without first reading and following the advice in

Cannot properly run Retropie

  • Hello all. I seem to be having an issue getting retropie to function normally.

    Pi Model: 3 B 1GB
    Power Supply used: 2.5A
    RetroPie Version Used: 4.2
    Built From: Pre made SD Image from this site
    USB Devices connected: xbox one controller, keyboard
    Controller used: xbox one
    Error messages received: N/A
    Guide used: Followed guide for first time installation
    How to replicate the problem: Simply booting the device

    I followed the instructions to a T. However, when I get to the point where it says to expand the SD card to utilize available space, I get an error saying "There was an error running option A1 Expand Filesystem. I attempted to continue with instructions bypassing this step. Naturally, I had issues. For example, I could not update per the instructions. I had to type in

    $ sudo rm /var/lib/dpkg/status
    $ sudo touch /var/lib/dpkg/status
    $ sudo apt-get update

    Even after this, nothing worked from the retropie menu. Any option i chose (splash screen, get ip, wifi, etc) would simply start a string of commands and send me back to the retropie menu. If I were to click on the same option again, I would be returned to the menu.

    I reached out on Reddit for help and someone suggested running a hash check on the MD5. Lo and behold, the MD5 does not match the MD5 on this website. I have tried 4 times to download the same file, and even tried downloading the file from the torrent provided on this site. Neither of them match the hash key shown on here which is

    The hash key I get is

    Can someone help me out? I'm sure this is the root of my problems. This is my first pi project ever, and I am really eager to get this working.

  • @ghostnappa611 Your problem points to a bad or incompatible SD card. Do you have another one to try out? Also please comply with request above so that we may know your full setup:
    Please do not post a support request without first reading and following the advice in

  • @ortsac Hello and thanks for the reply. I've edited the original post to match the format provided. However, it does not seem to me that it is the SD card. The image that I've downloaded from this site, does not match the hash provided.

    I am using an MD5 checker to verify the hash keys match and they do not match in the slightest, so it seems to be an issue with the original download. Is the 4.2 version corrupt? Am I simply screwing up when I extract the img? Thanks in advance for any suggestions.

  • administrators

    @ghostnappa611 either try downloading from a different browser or use etcher to write the image as it doesn't require extraction beforehand

  • @ghostnappa611
    I've just downloaded the image to double check and the hash key matches that of the .gz file. The hash key you posted is from the extracted image which is why it's different (though I can verify still correct for the extracted image), if you do the hash check on the original gz file you will see it matches.

    There is no problem with the image file you have. As @ortsac said try another SD card.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.