Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

No Install from Binary Option [4.2]



  • Hey,

    Pi Model or other hardware: 3
    Power Supply used: Anker USB Power Supply (https://www.amazon.co.uk/gp/product/B06Y5RJ32B/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1)
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.2 (I believe)
    Built From: On top of Raspbian OS & LITE
    USB Devices connected: Wireless Acer Keyboard Mouse Combo
    Controller used:N/A (Xbox One Wired 1697 - It worked after a long setup - See Below)
    Error messages received: N/A
    Log found in /dev/shm/runcommand.log (if relevant): N/A
    Guide used: (Mention if you followed a guide): Multiple -

    How to replicate the problem:

    Below is some backstory, feel free to skip it if its irrelevant, I have no idea what is relevant here

    Picked up a RPI3 from Maplins last week, it came with NOOBS SD Card.

    Long story short, I've had a number of weird issues with the installing and uninstalling of OS's on my RPI3, I decided to start fresh with a new install of Raspbian OS [Full not Lite (Can't specify because i didn't take note the first time round whether its Debian/Jessie/Stretch], I managed to install RetroPie (VIA Binaries) and it was all great times, I had BK music on the menus too, it was perfect.

    I wanted to get to get some options in the GUI to boot between RetroPie and PIXEL desktop, because I had STARTED with the PIXEL desktop i was skeptical installing the "PIXEL Environment" in the RetroPie Setup files, I did it anyway and the option for DESKTOP appeared, but it didn't work.
    Shortly after tried to play a rom of Zelda Majoras Mask, IT RAN LIKE CRAP.... 1FPS... IF THAT.

    It was lagging so hard it wouldn't accept my START+SELECT input from the Xbox Pad or Keyboard (Xbox One Pad was riddled with issues too (Model 1697, took ages to setup).

    I pulled the plug ... corrupted the init file... wouldn't boot

    Started again...

    Installed PIXEL Desktop, Got the RetroPie-Setup window and there was no Binaries install option.... this was odd....

    Now, that i was more in the know I know, I noticed that the Raspbian OS i was installing was DEBIAN JESSIE in the NOOBS Boot Selector, (I didn't notice this before but it may of said that the whole time OR NOOBS updated it when its connected via the WIFI, I have NO idea)

    So here are my questions:

    • Because i managed to install via Binaries before, during the process of "Sudo apt-get update/upgrade/install etc" did i accidentally also update my Raspbian OS from Debian to Debian Jessie?

    • What reason could there be for the Binaries Option to be missing?

    • I just installed Raspbian Lite (Debian Stretch) - this too won't allow for install via Binaries, is this to be expected?

    • Building from Source seems to hang during ([ 99%] Building CXX object es-app/CMakefiles/emulationstation.dir/src/views/ViewController.cpp.o") is this just part of the painfully long slow recompilation process?

    Im trying to build from Source in Raspbian LITE now instead and I will leave this overnight so it should have a good 12 hours to work something out or at least progress past the first lockup.

    I don't have an SD Card reader otherwise I'd start with RetroPie, sorry about the bombardment of questions.



  • @nemecyys one of your issues could be you lost internet connection. If you dont have a connection it wont show binaries. Other than that i dont know.



  • @edmaul69 Interesting - that would fill me with undying rage if it were that simple, but I doubt it/hope not NOOBS never kicked up a complaint and i did try to install it 2/3 times with the same hanging point.

    UPDATE:

    Installing from Source (Basic Install) in the Raspbian LITE Debian Stretch CML(Command Line) version has powered through the Controller Issue and is making its way through the Emulators...

    Looks promising.. and im still unsure what the hell has changed here...

    Is it just Debian Stretch as opposed to Debian Jessie?


  • administrators

    @nemecyys Debian stretch on rpi is not supported.



  • @buzz But, Its installing RetroPie right now...

    Does that mean it will just not work once it finishes?

    Would I be right in saying if i install the Raspbian Full OS and boot into commandline and run the whole setup from there it would be almost identical to the process im running now with Raspbian Lite?

    UPDATE:

    Im now at the part where it begins with
    w -Wall -W -Wshadow ...... and the only files that seem to change are at the end with entries like

    -o src/burn/drv/sms/sms.o
    -o src/burn/snes/snes.o

    things of that nature, if Buzz is correct, then this won't work anyway, but out of curiosity what am i looking at?
    Is this the recompilation of the drivers/packages etc?


  • administrators

    @nemecyys it won't work. I will add some code when I next have some time to disable RetroPie on stretch on rpi. Use a Jessie image or the RetroPie image (which is Jessie lite).

    Ps. It's just compiling packages..many will compile but many things won't work.



  • @buzz said in No Install from Binary Option [4.2]:

    . I will add some code when I next have some time to disable RetroPie on stretch on rpi

    Ahhh ok

    Thanks, then can you explain why i no longer see Binaries on my install of Raspian Debian Jessie Full?
    If you can answer any of my original questions too that would be great :)


  • administrators

    @nemecyys are you sure it's Jessie? What's the output of cat /etc/issue



  • @buzz

    I don't think i understand how NOOBS works at all, but i installed the Full Desktop Version - and then was cleaning out some programs and instead of your command i used cat /etc/os-release

    Turns out it was Stretch...

    I messed around trying to change the Source.list files to download Jessie file instead, didn't seem to work.

    So I thought that if i turned off the wifi while I booted NOOBS and then reinstalled Raspbian (Assuming the way NOOBS works is it connects to an online repository) then I would hopefully get Jessie (I dunno, im probably totally wrong)

    Seems the OS I installed overnight is now Jessie, so i dunno what to believe.


  • Global Moderator

    I think it would be better to start with a clean .img containing Raspbian Jessie, instead of trying to downgrade via APT/DPKG.
    Old Raspbian releases are over at http://downloads.raspberrypi.org/raspbian/images/



  • @mitu

    Ahh thanks for that links Mitu, I had no idea where they were stored.

    Yeah i agree it didn't work trying to downgrade, I read it was basically unsupported to begin with, however I reinstalled Raspbian after this anyway via NOOBS Recovery, and now it says I have Jessie.

    • Can I put a new Image of Jessie on my SD Card VIA Raspbian now that it's installed (I don't have an SD Card Reader on my PC)

    • Am I right in how i think NOOBS works?
      https://www.raspberrypi.org/documentation/installation/noobs.md
      Appears NOOBS comes with Raspbian on it - So im thinking my NOOBS will install Jessie as long as theres no net connection otherwise it tries to get latest ( I THINK )

    • During the RetroPie install tutorial it says to make sure your up to date using Sudo apt-get Update/Upgrade does that update my OS?

    P.S. The install option clearly says this is a install of Debian Jessie when i choose to install it, so maybe I accidentally updated my OS before without releasing.


  • Global Moderator

    @nemecyys The update/upgrade via APT does not automatically upgrade your OS from Jessie to Stretch unless you manually modify the APT Sources file, so no worries here.

    I don't know about NOOBS with RetroPie, I didn' use it - alwayes used the RP image.

    As far as flashing a new image on the SD Card from within the OS booted from it, I don't think will work straight up, maybe some trickery using a recovery shell and a network mounted folder from where to get the .img file, but I woudn't recommend this.



  • @mitu Ahh right ok, that makes sense - a Fresh install should of replaced ALL the files then, and ahh I see no worries.

    I want both Raspbian and RetroPie so I can play games and learn python without switching SD Cards.

    Ahh fair enough - I thought adding the image would mean it would appear in my NOOBS Boot Recovery List when i wanted to install a new OS.

    Thanks for your help :)


  • administrators

    @nemecyys RetroPie images on the site are Raspbian (lite). RetroPie is not an OS. Might just be easier to use the image.



  • @buzz

    Would creating an image require me to have an SD Card reader?
    I believe that has been the source of the majority of my current hurdles, however I liked the flexibility of having NOOBS just while im getting to grips with the RPI3 and what im planning to use it for.

    Cheers for the advice though.

    UPDATE:

    By disconnecting my Pi from the internet, I was able to install the Jessie Version 8 of Raspbian, otherwise it was going online to retrieve Stretch Version 9

    From here on out - it's a standard install, Binary options were available, and now its all setup.

    • Seen as I already have Pixel Desktop Installed how do I enable the Pixel Desktop Option in PORTS without "Installing Pixel Desktop" via the RetroPie-Setup?
      It didn't seem to work last time.


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.