Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

ES scraper error



  • While using Emulation Station on my RP, I ran into issues with the onboard scraper. I knew thegamesdb.net site was down for a while and recently it was back online. However, I tried scraping some roms and it didn't work. I checked the site and it was online but when I restarted ES, this error showed up:

    Level 10 GamesDBRequest - Error parsing XML.
    Start-end tags mismatch

    Can anyone help, please?

    Pi Model or other hardware: B
    Power Supply used: 2.5A
    RetroPie Version Used: 4.2.20
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: keyboard, xbox 360 wired controller
    Controller used: xbox 360 wired controller
    Error messages received: Level 10 GamesDBRequest - Error parsing XML., Start-end tags mismatch



  • I am having exactly the same problem, all of a sudden scrapping on Emulation Station started to fail, is it because I updated my retropie packages to the latest and something got broken?



  • I'm having the same problem. And I also did updated my RetroPie to the latest build.

    However, I think I found the reason why that happened, and it seems that the issue is still on thegamesdb.net's end.
    I tried using thegamesdb.net API, and this is what I came up with:
    http://thegamesdb.net/api/GetGamesList.php?name=batman
    is working normally, and I can get a valid XML:
    <?xml version="1.0" encoding="UTF-8"?>
    <Data>
    <Game>
    <id>33228</id>
    <GameTitle>Batman</GameTitle>
    <ReleaseDate>06/08/1990</ReleaseDate>
    <Platform>PC</Platform>
    </Game>
    <Game>
    <id>35375</id>
    <GameTitle>Batman</GameTitle>
    <ReleaseDate>01/01/1986</ReleaseDate>
    <Platform>Sinclair ZX Spectrum</Platform>
    </Game>

    etc...

    However, when I try to get all the data for a single game ID (let's use the first game ID on the XML Response above: 33228):
    http://thegamesdb.net/api/GetGame.php?id=33228
    I get 503 Service Unavailable error.

    And when I try to do this:
    http://thegamesdb.net/api/GetArt.php?id=33228
    to extract the image for this game, I get CloudFlare 502 Error.

    So it seems that the API is still not working even though thegamesdb.net is.

    Can anyone else confirm this as well? Are API links working on someone else's network?

    p.s. API Information has been extracted here: http://wiki.thegamesdb.net/index.php/API_Introduction



  • Same
    After the update scraper doesn't work anynore.



  • @ducksalmon As the previous poster indicated, it seems to be a problem with the source site (thegamesdb.net) and their API, not particularly tied to any RetroPie updates.



  • Yup, me too having the same problem with the same error code popping up. Sucks cause I just added a bunch of games and almost have my build done and now cant scrape the damn new ones. Well, just checked the gamesdb forums and its a problem on their end for sure, guess we'll have to wait it out.



  • Why not try SSelphs scraper on the Pi or UXS from a windows machine (and connect to your Pi across the network but make sure you exit Emulation Station first). I didn't think anyone still used the inbuilt scraper.



  • In my case, the only one missing are NES roms (in *.zip format). And I'm getting "hash not found" via SSelph scraper for these NES roms.



  • @bladehunter I did try using SSelph's scraper and the same result happened. I would normally use that scraper but I wanted to scrape just a few games at the time.



  • @sandin Associate the hash on screenscraper.fr, and it'll catch it.



  • @sandin Whats the crc and md5 of the zip? I will run it through my scrape tool and associate it for you if it exists.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.

Looks like your connection to RetroPie Forum was lost, please wait while we try to reconnect.