Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

MAME - 2nd joypad does not work in-game



  • Hi again,

    I have 2 USB iBuffalo controllers. They both work. Playing NES games (like Mario Bros.) on 2-player work fine.

    When I open a 2-player MAME game (tried Gauntlet and Knights of the Round Table, both in Mame 2003), if I open the retroarch menu, I can configure player 2's controls, and if I turn on the option, I can even let Player 2 control the Retroarch menu.
    However, when I Select + X back into the game, Player 2 loses all control. No buttons work. I cannot even re-access the menu using the 2nd controller.

    I've set up the controller in EmulationStation, and like I said, I also set it up in RetroArch inside the specific game.. and it still doesn't work.

    I'm sure I need to set it up somewhere else, but I can't figure it out. Help?

    Running Retropi 4.2, Mame 2003, 0.78 roms, iBuffalo controllers, and I do have a USB keyboard plugged in too.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.