Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[SOLVED] PSX - Not working with EU games



  • EDIT - Looks like the issue was games with protection not working, tried another small handfull of games which seemed to work.

    Hi all,

    I am seriously embarrassed even posting this question as I feel it's a BIOS issue, but I have used the BIOS file with the suggested MD5 hash that I saw elsewhere on this forum. I am using lr-pcsx-rearmed as my emulator.

    PSX Games from USA region play fine, albeit these are in PBP format but I have a full European collection in BIN/CUE format. I have uploaded both the BIN and CUE file to /home/pi/RetroPie/roms and I have the scph1001.bin and spch5002.bin file in /home/pi/RetroPie/BIOS

    The EU games boot to a black screen, upon using the reset hotkeys, it boots the PS logo and states "Sony Playstation Europe" along the bottom but I can't get it to boot EU games whatsoever.

    I'm almost certain I had this working fine previously, but after starting over from scratch I can no longer get just the EU games to boot, this leads me to beleive although I have the BIOS files in place, something is either wrong with it (but i've tried a couple of different ones) or something else is wrong.

    I have tried this on a fresh install from the RetroPie image available on this site, I ran sudo-apt update and sudo apt-get upgrade, updated all installed packages.

    Is there anything else I can try?

    Thanks in advance



  • If you think you had this working in the past, you could attempt to compile an old version of the emulator on your own and see if it changes anything, in case it's an emulator bug. I doubt it's the case, but worth bringing it up just in case.



  • Yeah, good idea. I have a spare microSD lying around, I might try run it without doing any updates at all and see what happens..



  • @locvez have you tried it in all caps SCPH5002.BIN



  • @locvez also i just noticed you have the bios spelled wrong. Is it spelled correctly in the bios folder?



  • @edmaul69 hi, thanks for your reply, yes the files are named correctly, I had them miss spelled in my opinion. It's also capitalised, I've tried both caps and lowercase but the effect is the same



  • You can also try scph7502.bin, it's what I generally use. Caps doesn't matter, I believe. Also remember that EU games might have protections that the emulator can't bypass. You might need to patch the protections if the patches exists. They also run 10fps slower than the US/JAP games. I'd stick to EU exclusives.



  • @darksavior Thanks for the info. I've tried the 7502.bin as well. What I wasn't aware of was that some games have protection, I take it FF8 is one of the games with protection. I tried another game (GTA London) and this worked okay, (not perfectly, but it worked :-D) I'll have to go download the USA set and convert to PBP I guess rather than the EU set.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.