Please do not post a support request without first reading and following the advice in

PCSX-Rearmed Enhanced Resolution on Pi Zero

  • Hi folks,

    I'm running some PS1 games on my Raspberry Pi Zero W. I'm happy with the performance but not image quality. I've seen numerous instances of people talking about "Enhanced Resolution" option in RetroArch menu, but I can't find this option. I also tried to enable "pcsx_rearmed_neon_enhancement_enable" in the config file, but noticed the line containing this setting doesn't exist! Trying to add the line and setting it to "enabled" doesn't make a difference.

    Is it something about Pi Zero vs. Pi 2/3? Or I need to grab/enable this NEON plugin first?

    Any help will be appreciated. Thanks.

  • Not sure why you can't find the option, but be aware the enhanced resolution makes every game unplayable on an overclocked pi2, so don't hold your breath for a zero to do it.

  • @delphiboy

    First of all, you need to have RPi 3 in order to even have some sort of chance of making it work somewhat playable way. It is really HEAVY for the system, since it renders all the real time rendering in higher resolution than it originally did. And it brings in variety of issues, that are different on each game. It can be easily accessed during gameplay, when opening the Retroarch quick menu with hotkeys. You can test it out, but you might need to overclock the RPi in prder to make it run more smoother. When it comes to the shaders, putting those on while you use that Enhanched Graphics option is too much for the system and therefore, not recommended.

    Edit: Sorry, that guide was meant for the lr-version of the emulator, I dunno which version of the emulator you're using, the lr one or the non-lr one.

  • @dd-indeed said in PCSX-Rearmed Enhanced Resolution on Pi Zero:

    have RPi 3 in order to even have some sort of chance of making it work

    I have tried both.

  • @delphiboy

    So you tried to open the Retroarch menu while on the game with hotkeys ?

  • @dd-indeed Yes. And as mentioned added the lines to the config files. But no luck.

  • @delphiboy

    Hmm, uninstall and reinstall that emulator.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.